Custom firmware build for R7800 v. 1.0.2.30SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Very Senior Member
Continuation of

https://www.snbforums.com/threads/custom-firmware-build-for-r7800.36859/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-22sf.37222/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-23sf-v-1-0-2-24sf.37477/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-25sf-v-1-0-2-29sf.38032/

New version of my custom firmware build: 1.0.2.30SF.

Changes (vs 1.0.2.29SF):
1. Bridge mode is working now (bug in stock GPL source codes (git_home/qca-hostap.git).
2. OpenVPN is upgraded 2.4.0->2.4.1.
3. ethtool is upgraded 4.8->4.10.
4. Synchronization of other binaries with the stock firmware to avoid “bridge mode” bug.
5. OpenVPN init script is changed to avoid problems with some clients.
6. Some internal optimization.

Thanks to vladlenas and Csection for testing.

The links are:

https://www.mediafire.com/folder/tyj61i5uc610w/voxel-firmware

or

http://ownweb.eu/Downloads/

No reset is needed to upgrade from my previous versions.

Voxel.
 
Last edited:

gobble

Occasional Visitor
Hey Voxel,

Did it just now (through WiFi, I couldn't bring myself to wait to get the laptop with the Ethernet port this week). Took it fine, did a factory reset after and setup again and looks good so far :)
 

staticfree

Regular Contributor
Hi Voxel, just dropped by and glad to see that you've updated to the latest Netgear firmware version. I have also now loaded it over the older v1.0.2.24sf firmware and up and running on v1.0.2.30sf now. So far looking good, no problems after installing without resetting nor wiping configuration. Good job! Thank You again!
 

avtella

Very Senior Member
Voxel I don't know if you participate in Netgear's Betas, if not, you should consider joining. Anyhow thanks for improving on the stock firmware.
 

rbird2

Regular Contributor
Installed 1.0.2.30SF on my R7800 (performed a hard reset) yesterday. After noticing a slight lag in web browsing, I realized that I had forgotten I forgot to change my ISP's DNS servers (unreliable and slow when internet traffic is heavy) to OpenDNS. Everything is now working great.

Voxel, another Thank You for your efforts!
 

ulaganath

Senior Member
Can any one post the firmware UI screenshoots. Is this firmware different from Stock.

Does the additional functionality might always need SSH to enable or disable. No UI to manage.

Hope flashing this wont void warranty. As it was for R7000
 

Voxel

Very Senior Member
Can any one post the firmware UI screenshoots. Is this firmware different from Stock.

Does the additional functionality might always need SSH to enable or disable. No UI to manage.

Hope flashing this wont void warranty. As it was for R7000
UI is practically the same. Just look at UI of stock firmware. And the same procedure of flashing firmware file (*.img) from the disk.

You can use router with my build w/o enabling SSH. SSH is needed mainly for those who want to significantly extend the functionality of their router by Entware. You can use telnet enabling it by http://routerlogin.net/debug.htm to make small changes such as use of dnscrypt-proxy or add USB webcam support. W/o SSH. LTE modem should work w/o any additional manipulations.

Voxel.
 

ulaganath

Senior Member
thanks Voxel. One more query. Is this future proof mu-mimo. Or there will be 3rd gen AC which will work without mu-mimo clients.

As this is currently restriction or min req for the mu-mimo functionality to work. Will this be overcomed .

Also there is new set of frequency say 2mhz bandwidth which can accomodate more bandwidth and channels. Any idea on those.

I watched netgear market this router as 4k ready router. it has enough bandwidth. Hope netgear will keep pushing updates like R7000. But somehow the web ui is worst load time irrespective of the processor capable.

In R7000 advanced tomato the interface loads quiet faster than webpage would do in 1gb line of internet.
 

ulaganath

Senior Member
i even tried voxel firmware it is not working. WAN port only LED no sign of Ip address
 

ulaganath

Senior Member
Is there any way to test of WAN port . LED is blinking but IP aquiring is nill
 

pege63

Very Senior Member
Did you go back to stock first like this

1) erase nvram
2) use r7000-back-to-ofw.trx file and upgrade router via gui
3) log in to genie - login "empty", pass "admin"
4) restore default settings
 

ulaganath

Senior Member
This is not a tomato. Its ddwrt. yes i did revert back to 1.0.0.40 firmware by revert to stock kong.img .

Trx is no more extension for R7800. Only IMG. wired that i was back to centria series with img file.
 

Voxel

Very Senior Member
Sorry for a silence, my ISP had problems and I did not have Internet connections since yesterday.

This is not a tomato. Its ddwrt. yes i did revert back to 1.0.0.40 firmware by revert to stock kong.img .

Trx is no more extension for R7800. Only IMG. wired that i was back to centria series with img file.
I agree with Killhippie:
Just take it back. It should not have come like this and its certainly not new if it came with third party firmware on it.
You should take it back. It is not new and maybe it is with pure hardware problems (broken flash memory or something like that). NETGEAR does not set DD-WRT to its routers.

Voxel.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top