Custom firmware build for R7800 v. 1.0.2.46SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Very Senior Member
Continuation of

https://www.snbforums.com/threads/custom-firmware-build-for-r7800.36859/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-22sf.37222/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-23sf-v-1-0-2-24sf.37477/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-25sf-v-1-0-2-29sf.38032/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-30sf.38366/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-31sf.39142/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-32sf.39657/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-33sf.40198/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-34sf.40523/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-35sf.40794/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-36sf.41166/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-37sf.41317/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-38sf.41751/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-39sf.41945/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-40sf-1-0-2-41sf.42222/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-43sf.42683/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-44sf.42882/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-45sf.43853/

New version of my custom firmware build: 1.0.2.46SF.

Changes (vs 1.0.2.45SF):

1. Integration of changes from the latest stock v. 1.0.2.44.
2. Correction of several bugs introduced with the stock v. 1.0.2.44.
3. OpenVPN client changes: it is forced to use core 0 (affinity).
4. OpenVPN client changes: net-wall script is corrected to process "restart" argument (thanks to kamoj).
5. ubus package is upgraded 2017-11-13->2018-01-16.
6. curl package is upgraded 7.57.0->7.58.0.
7. liblz4 package is upgraded 1.8.0->1.8.1.2.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

NOTE: Most probably no reset is needed to upgrade from my previous versions. But if you face problems it is better to perform reset.

Voxel.
 

e38BimmerFN

Very Senior Member
Thank you Voxel. Got mine loaded now. Will report any findings. ;)
 

Paul Smith

Occasional Visitor
Hi Voxel, I have just purchased an r7800 and currently have stock firmware. The Parental Controls are a bit clunchy and it doesnt seem easy to add time restrictions to individual devices. Is this something your firmware can achieve?

Rgds
 

avtella

Very Senior Member
I think you need OpenDNS enabled for proper parental controls.
 

e38BimmerFN

Very Senior Member
Voxel, I'm seeing this issue with your FW and I presume it stems from Stock on well:
https://www.snbforums.com/threads/n...r-x4s-r7800-1-0-2-44.44251/page-2#post-380456

AP mode is working however we can't access the web UI with a static IP address assigned on the R7800. Also can't find any active connections with network scans or on host router client table. However internet is working thru the R7800 in AP mode. :confused: We missing something here?
 

Voxel

Very Senior Member
Hi Voxel, I have just purchased an r7800 and currently have stock firmware. The Parental Controls are a bit clunchy and it doesnt seem easy to add time restrictions to individual devices. Is this something your firmware can achieve?

Rgds
Hmm, I did not change Parental Control. It is the same as in the stock fw. Your requirements for Parental Control look as a bit over complicated. Scheduling time for such restrictions and only for individual devices... Does it mean that you are sharing your devices with your kids?

Well, if I would need something similar (time scheduling) I would use cron and dnscrypt-proxy. Using for example adguard-dns-family-ns1 and adguard-dns-family-ns2 for dnscrypt-proxy. I.e. cron starts dnscrypt-proxy in concrete time period. And stops it (e.g. night time, when kids are sleeping, but parent are not ;)). But it is manual job to setup using ssh/telnet console.

If you need to set up Parental Control only for concrete devices, I would use dnscrypt-proxy always (for all devices), but using manual dns configuration for parent's gadgets (e.g. 8.8.8.8).

Combination of this is too complex IMO.

Voxel.
 

Voxel

Very Senior Member
Voxel, I'm seeing this issue with your FW and I presume it stems from Stock on well:
https://www.snbforums.com/threads/n...r-x4s-r7800-1-0-2-44.44251/page-2#post-380456

AP mode is working however we can't access the web UI with a static IP address assigned on the R7800. Also can't find any active connections with network scans or on host router client table. However internet is working thru the R7800 in AP mode. :confused: We missing something here?
I tried: something similar. Probably it is a bug in stock. I did not change the scheme for AP. I am using R7800 as an AP, but it gets IP using main router assignment (address reservation). When I tried static IP I was able to enter to AP, but it displays problems with Internet (the last if OK however).

Voxel.
 

Paul Smith

Occasional Visitor
Hmm, I did not change Parental Control. It is the same as in the stock fw. Your requirements for Parental Control look as a bit over complicated. Scheduling time for such restrictions and only for individual devices... Does it mean that you are sharing your devices with your kids?

Well, if I would need something similar (time scheduling) I would use cron and dnscrypt-proxy. Using for example adguard-dns-family-ns1 and adguard-dns-family-ns2 for dnscrypt-proxy. I.e. cron starts dnscrypt-proxy in concrete time period. And stops it (e.g. night time, when kids are sleeping, but parent are not ;)). But it is manual job to setup using ssh/telnet console.

If you need to set up Parental Control only for concrete devices, I would use dnscrypt-proxy always (for all devices), but using manual dns configuration for parent's gadgets (e.g. 8.8.8.8).

Combination of this is too complex IMO.

Voxel.
Hi Voxel,

Thanks for the reply. I think I may be over complicating things. Maybe I don't fully understand the stock Parental Control. Basically, I just want to be able to block my daughters Ipad and Iphone from 9pm till 8am. They are not shared devices. I had a look through the stock parental control but it does not seem possible without having the genie app and running the internet through a bypass account which I think is clunky.

I'll have another look through and see if I have missed anything.

Second question I have is regards to your OpenVPN. So I currently have a VPN account with AirVPN. If I add the VPN to the router itself is there a way of UK based apps like Iplayer/ITV player not going through the VPN?
 

e38BimmerFN

Very Senior Member
Thanks Voxel for check yours as well. Seems like a bug. Will try and get NetGearGuy notified.

All have to factory reset mine to get access it it.

I tried: something similar. Probably it is a bug in stock. I did not change the scheme for AP. I am using R7800 as an AP, but it gets IP using main router assignment (address reservation). When I tried static IP I was able to enter to AP, but it displays problems with Internet (the last if OK however).

Voxel.
 

Voxel

Very Senior Member
Info for Entware users: Entware is upgraded. It is enough to run:

Code:
/opt/bin/opkg update
/opt/bin/opkg upgrade
to upgrade your version.

Voxel.
 

cordezz

Occasional Visitor
Hello,
I have installed V1.0.2.46SF, too, but I dont know if this problem is related to this fw version:

When I want to select a folder of my usb hdd in the "Downloader Settings" I click on "Browse" and the popup window with the tree appears. When I select one folder of the tree, then only "400 Bad Request This server does not support the operation requested by your client." is displayed.
But I can close the popup with "Ok" and the selected folder is displayed correctly in the "Folder" field.
When I click "Apply" in the "Downloader Settings" again "400 Bad Request This server does not support the operation requested by your client." is displayed and the folder ist not saved.

And I am wondering why I always have to authenticate with user/password (ftp and https), even when I create a network folder without password protection for the Media Server

I started with Voxels 1.0.2.43 and did a factory reset after the first fw flash, but since then I updated Voxels fw without factory resets. My hdd is ext4 formatted.

Can anybody reproduce this problem?

/EDIT: I tried the Netgear Downloader for the first time now and it always says "Failure" in the "Status" field. No matter if I download from ftp or http. With my browser the download works, so the links I inserted are ok.

Could the EXT4 format be the problem? I am running the R7800 in AP-Mode (if that makes any difference).
 
Last edited:

ulaganath

Senior Member
Hi Voxel,

What is the rated speed the usb 3.0 host of this router can achieve.

I tried with lan port the usb 3.0 reached 77MB/s which is 608Mbps but the windows taskmanager says 668Mbps which fluctuates like 20-30

So the windows 10 filetransfer is not acurate

As in the other thread i posted the usb 3.0 gain from the usb 2.0 on ac 2x2 adapter was neglible.

But when i see the taskmanager transfer it was close to 240-296 mbps with peak was 37MB/s if calculated rightly. But the windows hardly hits 32.5MB/s

i dont understand the right way to test. Do i really get a speed increase with usb 3.0 or not. wireless adaptor i mean.
 

Voxel

Very Senior Member
When I want to select a folder of my usb hdd in the "Downloader Settings" I click on "Browse" and the popup window with the tree appears. When I select one folder of the tree, then only "400 Bad Request This server does not support the operation requested by your client." is displayed.
But I can close the popup with "Ok" and the selected folder is displayed correctly in the "Folder" field.
When I click "Apply" in the "Downloader Settings" again "400 Bad Request This server does not support the operation requested by your client." is displayed and the folder ist not saved.
Yeah... There is such a problem. Well, it is because of using USB volume label as a point for mounting USB disk in my version instead of /mnt/sda1 or /mnt/sdb1 etc. (stock).

OK. Such stuffs are processed by enclosed part of NETGEAR's GPL (no source codes). So I'll correct it like it was done for R9000, i.e. leaving /mnt/sd*, but adding symlink == volume label (/mnt/volume-label).

But next problems...
I tried the Netgear Downloader for the first time now and it always says "Failure" in the "Status" field. No matter if I download from ftp or http. With my browser the download works, so the links I inserted are ok.
Well. This NETGEAR Downloader is too BETA IMO. I do not think that problem is in EXT4. I had to test it after your report with a stock 1.0.2.44, but I failed to download with stock e.g.

ftp://ftp.heanet.ie/mirrors/ftp.debian.org/debian-cd-weekly/amd64/iso-cd/debian-testing-amd64-xfce-CD-1.iso

I see just "Pending" status and when I try to pause/resume I'm getting "Failure"... Directory for downloads I set with 777 permission, so I do not think that it is EXT4 specific.

I'd not recommend to use this downloader for http/ftp links. Even with stock fw. First, it does not support https, but the last is de facto standard. It is difficult to find plain http link, all downloads servers deals with https. FTP is also a bit exotic link. Second, really too BETA. I did test with high attention BT protocol in this downloader, and it should work OK (but use of Transmission I think is much better). But such problems with http/ftp... I really cannot correct everything. No wishes and no time to convert my USB to NTFS or other format for more testing. IMO I just have to leave only Transmission...


Voxel.
 

Voxel

Very Senior Member
Hi Voxel,

What is the rated speed the usb 3.0 host of this router can achieve.

I tried with lan port the usb 3.0 reached 77MB/s which is 608Mbps but the windows taskmanager says 668Mbps which fluctuates like 20-30

So the windows 10 filetransfer is not acurate

As in the other thread i posted the usb 3.0 gain from the usb 2.0 on ac 2x2 adapter was neglible.

But when i see the taskmanager transfer it was close to 240-296 mbps with peak was 37MB/s if calculated rightly. But the windows hardly hits 32.5MB/s

i dont understand the right way to test. Do i really get a speed increase with usb 3.0 or not. wireless adaptor i mean.
Sorry I do not quite understand what do you test? Wireless speed or USB speed or Windows 10 taskmanager accuracy in measurement... If USB, then it is really faster (USB 3.0 vs USB 2.0). Very theoretical maximum for USB 2.0 is 60MB/sec. I have more with wired connection. If wireless speed, there are other tests for measurement, check with e.g. with iperf.

BTW all this also depends on disk you use for your testing.

Voxel.
 

ulaganath

Senior Member
Ok now this is what i want to know

A6210 or a6200 being the same chip or different chip no idea but only difference outside i see is usb 3.0 vs usb 2.0

r7800 have only usb 3.0 ports so the theoritical max it can go is 1gbs as that the max speed link to get the data from the usb 3.0

When i tested the wired read speed i can see max of 77MB/s .

My query is does a6210 can give theoritical max speed of ac 2x2 when it was used in usb 3.0 port as when compared to usb 2.0 port.

I see some variation in WIndows file transfer speed and Network monitor in windows. some 2-3MB/s when calculated .

So at idle condition what is 2x2 adaptor with strongest signal can achieve in wireless when usb 3.0 host read speed is 650Mbps + The adaptor is connected at 867Mbps but when data transfer is initated it falls down to 526Mbps
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top