Devices connecting to wrong AiMesh-enabled router/node

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

asusmancanada

New Around Here
Hello,
I am running two RT-AC5300s (both updated as of Dec 13/2020) in an AiMesh network, with the main router connected to my modem in my room, and another node in the living room (about 25-35 feet away). I notice almost all my devices (even the devices 2-5 feet away from my main router) connect to the node in the living room. This problem suddenly started after I got a new modem from my ISP (Rogers [Canada]), but I'm not sure why as the XB6 modem is in bridge mode. Also, my devices seem to be connecting weirdly in the sense that I'll be 4ft away from my main router, but but the device is connected via 2.4GHz band instead of the 5GHz-1 (and these are strong devices such as a 2019 MacBook Pro or 2018 iPad Pro). Anyone experience anything similar with their setups?
I've tried the basic troubleshoot steps: reboot both routers, reboot and reconnect clients/devices, factory restore routers and setup a new network.
 

Attachments

  • Screen Shot 2020-12-13 at 3.27.19 PM.png
    Screen Shot 2020-12-13 at 3.27.19 PM.png
    398.4 KB · Views: 32

bones5050

Regular Contributor
Hello,
I am running two RT-AC5300s (both updated as of Dec 13/2020) in an AiMesh network, with the main router connected to my modem in my room, and another node in the living room (about 25-35 feet away). I notice almost all my devices (even the devices 2-5 feet away from my main router) connect to the node in the living room. This problem suddenly started after I got a new modem from my ISP (Rogers [Canada]), but I'm not sure why as the XB6 modem is in bridge mode. Also, my devices seem to be connecting weirdly in the sense that I'll be 4ft away from my main router, but but the device is connected via 2.4GHz band instead of the 5GHz-1 (and these are strong devices such as a 2019 MacBook Pro or 2018 iPad Pro). Anyone experience anything similar with their setups?
I've tried the basic troubleshoot steps: reboot both routers, reboot and reconnect clients/devices, factory restore routers and setup a new network.

I don't know that much about your physical layout, but having two mesh routers 25-30 feet apart could be the problem, overlapping wifi bands causing your clients to connect to any of the routers. I would think you could get be with one router or move the second router to a further location.
 

OzarkEdge

Part of the Furniture
Hello,
I am running two RT-AC5300s (both updated as of Dec 13/2020) in an AiMesh network, with the main router connected to my modem in my room, and another node in the living room (about 25-35 feet away). I notice almost all my devices (even the devices 2-5 feet away from my main router) connect to the node in the living room. This problem suddenly started after I got a new modem from my ISP (Rogers [Canada]), but I'm not sure why as the XB6 modem is in bridge mode. Also, my devices seem to be connecting weirdly in the sense that I'll be 4ft away from my main router, but but the device is connected via 2.4GHz band instead of the 5GHz-1 (and these are strong devices such as a 2019 MacBook Pro or 2018 iPad Pro). Anyone experience anything similar with their setups?
I've tried the basic troubleshoot steps: reboot both routers, reboot and reconnect clients/devices, factory restore routers and setup a new network.

Make sure the ISP router WiFi is OFF. Spread your nodes as far apart as you can. And consider significantly raising (less negative) your router Roaming Assistant RSSI thresholds per band. The recent inclusion of a new OEM WiFI SDK in the Asus 386 firmware seems to have improve effective signals... so maybe your clients have too many strong signals to intelligently cope with without a helpful nudge from RA.

OE
 

Michael Salinger

Occasional Visitor
Make sure the ISP router WiFi is OFF. Spread your nodes as far apart as you can. And consider significantly raising (less negative) your router Roaming Assistant RSSI thresholds per band. The recent inclusion of a new OEM WiFI SDK in the Asus 386 firmware seems to have improve effective signals... so maybe your clients have too many strong signals to intelligently cope with without a helpful nudge from RA.

OE
I'm having similar issues where it seems clients move between nodes too readily and disconnect/reconnect for short periods. What's a good rule of thumb for this? Is RA required for AiMesh to function well? Would a setting of -85db be too high? Would decreasing the power be a viable option as well?
 

OzarkEdge

Part of the Furniture
I'm having similar issues where it seems clients move between nodes too readily and disconnect/reconnect for short periods. What's a good rule of thumb for this? Is RA required for AiMesh to function well? Would a setting of -85db be too high? Would decreasing the power be a viable option as well?

The first rule of thumb is details matter. The default 2.4/5.0 RSSI thresholds are -70/-70 dBm. When I wrote 'raise (less negative)', I meant raise (less negative)... try -55/-70 if you are troubleshooting 2.4 connections.

Decreasing power could be a similar option (or spreading nodes farther apart), but it is uncertain to me how the router Tx power varies and if this equally affects node Tx power. So I'd prefer to place nodes to suit their max power and vary RA RSSI thresholds to tweak that.

There is not much to RA... OFF or ON and one RSSI setting per band, so you can easily experiment and see how your clients behave.

OE
 

Mr Tvardovsky

Occasional Visitor
What's a good rule of thumb for this? Is RA required for AiMesh to function well? Would a setting of -85db be too high?
In my AiMesh setup (see the signature below), I’m using the following RSSI thresholds for Roaming Assistant:
-60 dBm for 5Ghz
-55 dBm 2.4Ghz
And I’m generally happy with how the laptops and mobile devices roam between the nodes. But definitely don’t take it as a universal reco - as OE pointed out, you need to do your own testing.

What helped me to come across the right values was downloading network analyzer apps on my phone and on my laptop. Using them I could make a better guess in which dBm range I should look for my solution.
 

OzarkEdge

Part of the Furniture
In my AiMesh setup (see the signature below), I’m using the following RSSI thresholds for Roaming Assistant:
-60 dBm for 5Ghz
-55 dBm 2.4Ghz
And I’m generally happy with how the laptops and mobile devices roam between the nodes. But definitely don’t take it as a universal reco - as OE pointed out, you need to do your own testing.

What helped me to come across the right values was downloading network analyzer apps on my phone and on my laptop. Using them I could make a better guess in which dBm range I should look for my solution.

Main router: DSL-AC68U, GNUton 384.17 (AMTM, NextDNS CLI, Skynet, WiFi off)
AiMesh Router in AP mode: RT-AC66U B1, Merlin 386.1 beta (ethernet backhaul)
2 AiMesh nodes: RT-AC66U B1, Merlin 386.1 beta (MoCA backhaul)

And like with your thrifty/optimized network, using different SSIDs per band can further encourage wireless clients to behave.

OE
 

Mr Tvardovsky

Occasional Visitor
And like with your thrifty/optimized network, using different SSIDs per band can further encourage wireless clients to behave.

OE
That’s precisely what I do :) My routers don’t offer Smart Connect, so different SSIDs per band are a must.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top