What's new

Diversion - the Router Ad-Blocker

Mutzli

Very Senior Member
I'm getting ads. If they're served by the website itself, they (likely) can't be blocked. Given that they have the "VIP" thing, I'd imagine they are serving the adds themselves.
View attachment 18742
Same here, looks like the ads are hosted on the same site as the other content.
 

Kariphoenix

New Around Here
Is anyone else having issues with the android app Fandango? I keep getting the message in the attached screenshot when trying to select a time for buying movie tickets. I've tried whitelisting blocked domains with the [f] (follow dnsmasq.log) option to no avail. The app works if I disable ad blocking.

android fandango app.jpg
 

Therion87

Regular Contributor
Is anyone else having issues with the android app Fandango? I keep getting the message in the attached screenshot when trying to select a time for buying movie tickets. I've tried whitelisting blocked domains with the [f] (follow dnsmasq.log) option to no avail. The app works if I disable ad blocking.

View attachment 18748
Try leaving blocking enabled, but disable pixelserv. See if you still get the issue. There are some site that don’t like pixelserv.
 

Ubimo

Senior Member
I cannot open https://www.chuyu.me/ on my PC.

I know how to resolve/whitelist a domain in diversion and skynet.
I can open this page on my mobile phone, when I disconnect from my wlan.
I also can open this page when I connect my PC to my mobile phone hotspot.
I just cannot open this page when I'm connected to my wlan.
I already temporarily disabled diversion and skynet, still I cannot open this page.
Strangely I can ping www.chuyu.me, and it says "Antwort von 47.246.47.208: Bytes=32 Zeit=58ms TTL=53"
I don't use a proxy.

My router is 192.168.1.1 and this is in syslog:
Jul 28 22:24:33 dnsmasq[2804]: using nameserver 8.8.4.4#53
Jul 28 22:24:33 dnsmasq[2804]: using nameserver 8.8.8.8#53

So this problem is not related to diversion, skynet or my browser.

Any suggestions?

Edit:
I now tried to set DNS 1.1.1.1 manually in my router, now I can reach the website, but another website still doesn't open: https://www.dnsperf.com/
Edit2:
I had to whitelist dnsperf.com in skynet.
All good!
 
Last edited:

martinr

Part of the Furniture
I cannot open https://www.chuyu.me/ on my PC.

I know how to resolve/whitelist a domain in diversion and skynet.
I can open this page on my mobile phone, when I disconnect from my wlan.
I also can open this page when I connect my PC to my mobile phone hotspot.
I just cannot open this page when I'm connected to my wlan.
I already temporarily disabled diversion and skynet, still I cannot open this page.
Strangely I can ping www.chuyu.me, and it says "Antwort von 47.246.47.208: Bytes=32 Zeit=58ms TTL=53"
I don't use a proxy.

My router is 192.168.1.1 and this is in syslog:
Jul 28 22:24:33 dnsmasq[2804]: using nameserver 8.8.4.4#53
Jul 28 22:24:33 dnsmasq[2804]: using nameserver 8.8.8.8#53

So this problem is not related to diversion, skynet or my browser.

Any suggestions?

Edit:
I now tried to set DNS 1.1.1.1 manually in my router, now I can reach the website, but another website still doesn't open: https://www.dnsperf.com/
If you are not already using DNSFilter, try enabling it and ensure the Global Mode is set to router, thereby making sure the PC is using the same DNS server as your other devices as well as using Skynet and Diversion.

That site opens for me (redirecting to https://www.chuyu.me/en/index.html). I use Skynet and Diversion, default blocking lists (and DNSFilter, Global Mode Router).
 

Ubimo

Senior Member
If you are not already using DNSFilter, try enabling it and ensure the Global Mode is set to router, thereby making sure the PC is using the same DNS server as your other devices as well as using Skynet and Diversion.

That site opens for me (redirecting to https://www.chuyu.me/en/index.html). I use Skynet and Diversion, default blocking lists (and DNSFilter, Global Mode Router).
Where do I find "DNSFilter"?
Edit:
Ah, found it.
Gonna play around a bit.
Edit2:
Do I have to manually add clients to the clients list in DNSFilter or are all clients automatically using the custom DNSs?
 
Last edited:

martinr

Part of the Furniture
Where do I find "DNSFilter"?
Edit:
Ah, found it.
Gonna play around a bit.
Edit2:
Do I have to manually add clients to the clients list in DNSFilter or are all clients automatically using the custom DNSs?
You list all the exceptions to the Global Mode in the Filter Mode boxes at the bottom of the page. And if the DNS server you want is in the list eg OpenDNS, you select that, otherwise you have up to 3 custom choices. (In my case, I simply use Router for Global and no exceptions.)
 
Last edited:

HairyA00

Senior Member
Can you tell me what you're trying to open when you get the "oops" error message? I can try to mirror what you're doing to see if i get the same error message.
Any luck reproducing this issue with the Amazon Shopping app on Android? Appears to be 100% reproducible on my end so I am still keeping pixelserv-tls disabled.
 

cmkelley

Very Senior Member
Any luck reproducing this issue with the Amazon Shopping app on Android? Appears to be 100% reproducible on my end so I am still keeping pixelserv-tls disabled.
I gave up a long time ago on using the amazon android app at home.
 

Skeptical.me

Very Senior Member
Hi peoples,

It's been awhile since I've posted. Things have been going really well with my new AX88U and merlin, amtm, skynet, and diversion. I've had no issues until tonight.

All of a sudden ads started showing up, everywhere, on all devices. And Diversion is on and I have no idea why.

Example:



And here you can see Diversion is on:



So, since my experience is limited I'm not sure what I can do to fix this. Other than maybe do a complete reinstallation of amtm and skynet and Diversion. If someone here has any suggestions I will be really grateful because I'm stuck.
 

L&LD

Part of the Furniture
Have you tried rebooting the router? :)

Maybe, twice? ;)

And waiting a good ten minutes after it boots up before testing if it works?
 

Skeptical.me

Very Senior Member
Have you tried rebooting the router? :)

Maybe, twice? ;)

And waiting a good ten minutes after it boots up before testing if it works?
Doh! Didn't even think of that simple action lol

I'll do that now and get back to you :)
 

Skeptical.me

Very Senior Member
Have you tried rebooting the router? :)

Maybe, twice? ;)

And waiting a good ten minutes after it boots up before testing if it works?

So, I just rebooted the router, and devices made sure Diversion is on and it has made no difference ads are still appearing :(
 

Skeptical.me

Very Senior Member
Have you tried rebooting the router? :)

Maybe, twice? ;)

And waiting a good ten minutes after it boots up before testing if it works?
Okay, I figured out what was causing this.

I setup a new Openvpn Profile (Expressvpn) and for some reason it just wouldn't work. All the settings were correct to allow diversion to work, Ive done this a million times over.

So the solution to making the VPN connection to work was to add DNS addresses to LAN>DHCP Server>DNS and WINS Server Setting>DNS 1 and DNS 2. This stopped Diversion from working it appears.

So to get the VPN connection to work, and get Diversion working I went to LAN>DNSFilter>Enable DNS-based Filtering to ON > Global Filter Mode set to Router.

Now the VPN is working and Diversion is working. No more Ads.
 
Last edited:

QuikSilver

Very Senior Member
Okay, I figured out what was causing this.

I setup a new Openvpn Profile (Expressvpn) and for some reason it just wouldn't work. All the settings were correct to allow diversion to work, Ive done this a million times over.

So the solution to making the VPN connection to work was to add DNS addresses to LAN>DHCP Server>DNS and WINS Server Setting>DNS 1 and DNS 2. This stopped Diversion from working it appears.

So to get the VPN connection to work, and get Diversion working I went to LAN>DNSFilter>Enable DNS-based Filtering to ON > Global Filter Mode set to Router.

Now the VPN is working and Diversion is working. No more Ads.
Might be time to update some things too....AMTM has been updated to 2.7 now. ;)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top