Solved Error during Diversion installation: "Not enough free space available on /mnt/[NAME_OF_ENTWARE_PARTITION]"

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

papypaprika

Occasional Visitor
Hi all,

I'm a longtime user and fan of Diversion. I noticed I had issues with certs yesterday, and decided to remove and reinstall Diversion.

When I now try to install Diversion, I'm greeted with the following error:
"Not enough free space available on /mnt/[NAME_OF_ENTWARE_PARTITION]"

My entware set-up is fine, and my USB key has plenty of free room (3-4 GB).
When looking at the install script, I see that there is a disk size test, but I'm wondering if the command (df) used for such test is correct:
df -h /mnt/[NAME_OF_ENTWARE_PARTITION] reports the wrong size (43mb) of my Entware USB stick, and the wrong usage (20.5mb).
du -hs /mnt/[NAME_OF_ENTWARE_PARTITION] reports the right size of usage my Entware USB stick (3.3Gb).

I thought that my USB stick may be failing, formated it, but I still have the same error message and weird df -h output showing wrong disk size and disk usage.

I'm on RT-ACC66u, FW 374.43_44EAj9527, amtm 3.1.8 FW

Any ideas?
Otherwise, where can I manually comment the disk size check in the Diversion script / modules?

Thank you !!
 
Last edited:

ColinTaylor

Part of the Furniture
Your disk partitioning may be wrong or corrupted. I suggest that you use amtm's fd option to re-partition and reformat the drive.

How big is the drive?
 

papypaprika

Occasional Visitor
Ok, formatting and re-installing from scratch did the trick.
When I restore (rsync -a) my previous entware back-up, I have again the same problem... Oh well, I guess I'll have to set-up everything from scratch...

Thank you for helping me pinpoint the issue.
 
Last edited:

thelonelycoder

Part of the Furniture
Any ideas?
Otherwise, where can I manually comment the disk size check in the Diversion script / modules?
This would have been a bad idea anyway, right?
 

papypaprika

Occasional Visitor
Indeed, it would have postponed data corruption for later.

I suspect that my usb stick got corrupted because the swap partition didn't unmount properly.

May I suggest an improvement to the way swapoff is added by amtm/diversion to the services-stop script?

What about appending the swapoff command at the end rather than the top of the script?

My swap refuses to unmount until mysql/mariadb is stopped, and the current addition of the swapoff command amtm/diversion does not append it necessarily at the end of the script unless mistaken.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top