1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Failing to upgrade AC68U from 384.5 to 384.6 or higher

Discussion in 'Asuswrt-Merlin' started by WAppeal, Feb 22, 2019.

  1. WAppeal

    WAppeal New Around Here

    Joined:
    Feb 22, 2019
    Messages:
    2
    Summary: Even after factory/NVRAM resets, AC68U won't update any Merlin version past current 384.5

    Router: RT-AC68U (originally TM-AC1900, upgraded) Firmware: 384.5

    Obviously, I'm behind a few revisions; had a lot going on this Winter. After trying to update to latest-and-greatest and failing, I did the Factory default via GUI, retried update, and that failed.

    I then did reset via the reset button, and switched to trying 384.6. That didn't take, so I put router into Recovery mode (both efforts guided from wiki instructions) and tried 384.6 again, and then tried Recovery mode yet again, this time clearing the NVRAM.

    None of these are moving the firmware version past 384.5, per the router's GUI.

    To be clear: settings are wiped each time. Notably, in Recovery mode it just seems to sit; I waited ~30min for the update to complete before restarting.

    Can someone recommend next steps to get my router up-to-date?
     
    Last edited by a moderator: Feb 22, 2019
  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    7,759
    Location:
    UK
    Read the multiple sticky posts near the top of this forum.:rolleyes:
     
  3. WAppeal

    WAppeal New Around Here

    Joined:
    Feb 22, 2019
    Messages:
    2
    I am sincerly sorry. I read the stickies and missed that one; I honestly have been thinking of the unit as a AC68U and, until I was writing up this note and added the conversion note towards the end of the write-up, it didn't click it was a converted unit. Nor did the sticky impact me -- perhaps you need a mallet for these things. :)

    I did not mean to overbuden anyone, and you're welcome to do whatever you wish with this thread.

    Again, my apologies -- this is a very useful forum and I've enjoyed my usage of this unit, which appears to be coming to an end :(