How to change language of latest firmware of AC68U?

Grisu

Part of the Furniture
would be much easier for 68U by changing region-settings in cfe and you can use all languages!
 

Hale_JP

Occasional Visitor
Since this was deliberately done by Asus, there's nothing from their point of view to fix - it's how they want it to work. So unless they have a change of heart, this isn't gonna change in the future.
It appears, they sneaked this malicious nazi code to your latest beta 384.7_beta2
I installed Merlinwrt particularly in order to get that language selection feature. And it does not work. Neither "nvram set preferred_lang=EN" works.
It is stuck in creeping Japanese, and I don't know what to do. Really, Japan is a country, ignoring existence of non-japanese residents. And most Asian companies here follow the same frigging pattern of removing foreign languages. I am starting to believe, that's a government's unofficial enforcement policy.
 
Last edited:

Grisu

Part of the Furniture
I installed Merlinwrt particularly in order to get that language selection feature. And it does not work. Neither "nvram set preferred_lang=EN" works.
It is stuck in creeping Japanese, and I don't know what to do.
Merlin doesnt touch this part of firmware, so same as in newer stock firmwares.
Why dont you read the posting just above yours?
Google for RT-AC68U change region and have a look at the first hit ;)
 

ColinTaylor

Part of the Furniture
Or search the Merlin forum for "change language japanese".
 

Hale_JP

Occasional Visitor
actually I tried, and didn't get a working method. can you please, avoid speaking riddles, and just give the link? It would save some meters of text. "reduce kilobytes, save earth"
 

Grisu

Part of the Furniture
not allowed here as changing region may hit FCC or forum rules, thats why you have to google yourself exactly what I wrote above ...
 

ColinTaylor

Part of the Furniture
not allowed here as changing region may hit FCC or forum rules, thats why you have to google yourself exactly what I wrote above ...
Changing the region and changing the UI's language are two different things. Changing the region has other implications which may not be required or desired.
 

Hale_JP

Occasional Visitor
From "safe" solutions I got only "overload dictionary" method, which is neither user-oriented, nor stable solution...

I guess I got what message you mean, but there is: "Do not use autochannel, only manually set those allowed in your region!"
well... breaking the radio in order to get a language... is it possible at least changing to "compatible" region?
 

Grisu

Part of the Furniture
From "safe" solutions I got only "overload dictionary" method, which is neither user-oriented, nor stable solution...

I guess I got what message you mean, but there is: "Do not use autochannel, only manually set those allowed in your region!"
well... breaking the radio in order to get a language... is it possible at least changing to "compatible" region?
correct, you can set any channel allowed in Japan!
Japan allows all 2G channels, no problem with Auto, need only to have a look at 5G.

There is no other Japan-compatible region as only Japan allows ch. 14!
 

Hale_JP

Occasional Visitor
Well.. and I use 5G. And prefer auto, because I tend to forget things I reconfigured a few years ago.

I bookmarked this topic in the beginning of this year, and did not expect things got that worse :-(
 

Grisu

Part of the Furniture
Take it or leave it!

Instead of beeing happy to have a workaround you want and prefer ...
If you have a problem with Asus than tell them, here is the wrong place I think especially to users leaning out far to help you.
 

RMerlin

Asuswrt-Merlin dev
I installed Merlinwrt particularly in order to get that language selection feature. And it does not work. Neither "nvram set preferred_lang=EN" works.
Contact Asus then. There's nothing I can do, the language control code is now closed source, therefore my previous changes can no longer be implemented.
 

Hale_JP

Occasional Visitor
Contact Asus then. There's nothing I can do, the language control code is now closed source, therefore my previous changes can no longer be implemented.
I got it. Already found your earlier explanation; it just took some time finding it.
I only state here the sadness of the fact, what I was offered Merlin-WRT as a solution earlier, before ASUS made that irritating change. "Open code", they say. :-/
And yes, they simply ignore every inquiry relating the problem.

Grisu.. oh, you are really big and angry fire-breathing dragon, as on your avatar. Anyway, thank you for trying answering the question. It would be wise to put it into FAQ.
 

James Morrison

New Around Here
The same place you download the current version.
Sorry - I should be a bit more specific - I'm trying to change my language settings back to English. I'm assuming you are referring to the Asus website and the earliest version of the Firmware I am seeing is 3.0.0.4_382_9736. I'm trying to find 3.0.0.4_380_1842.
 

Grisu

Part of the Furniture
Sorry - I should be a bit more specific - I'm trying to change my language settings back to English. I'm assuming you are referring to the Asus website and the earliest version of the Firmware I am seeing is 3.0.0.4_382_9736. I'm trying to find 3.0.0.4_380_1842.
they deleted older firmwares!
I have some saved or use Merlins versions from that time you want.
But whats your problem to set it to English, no prob on all firmwars on 68U as you can change region setting? http://whatsyourrouter.com/mybb/showthread.php?tid=387
 

Tor

New Around Here
I signed on after I found a way to set the language to English.
Thanks to the thread I learned about the ssh login and the nvram utility.
I tried, but could not change preferred_lang from JP, as others reported already. I'm using the latest firmware (3.0.0.4.384_32799, as of Dec. 9 2018).
Once it actually did show =EN, but only once, it didn't change anything, and it didn't survive a reboot. I've also found a 'temp_lang' setting, which *will* stay at =EN if set so, but it doesn't seem to do anything interesting.
HOWEVER: I tried this: "nvram set preferred_lang=", i.e. I set it to empty. 'nvram show' showed that it stayed that way, also after nvram commit.
I then refreshed the web page (I was also logged in via the gui), and lo and behold, it changed to English!
I have not rebooted. I don't know if it survives a reboot, but this thing never need reboots anyway - this is my second AC68U, I've had another one running for years non-stop in Japan (and that one had the normal language selection tab, so I never imagined that the new second one wouldn't too). Anyway, my problem is solved - I can struggle through the Japanese UI, but it's is definitely easier with the English version.

TL;DR;
This fixed it for me:
ssh in as admin
nvram set preferred_lang=
nvram show|grep lang
verify that it's still empty
nvram commit
nvram show|grep lang
verify that it's still empty
Don't reboot (don't know if this makes it reverse again - I haven't tried)
Refresh web browser UI, or log in fresh.
It should change to English.
 
Last edited:

ja_rou

New Around Here
I signed on after I found a way to set the language to English.
Thanks to the thread I learned about the ssh login and the nvram utility.
I tried, but could not change preferred_lang from JP, as others reported already. I'm using the latest firmware (3.0.0.4.384_32799, as of Dec. 9 2018).
Once it actually did show =EN, but only once, it didn't change anything, and it didn't survive a reboot. I've also found a 'temp_lang' setting, which *will* stay at =EN if set so, but it doesn't seem to do anything interesting.
HOWEVER: I tried this: "nvram set preferred_lang=", i.e. I set it to empty. 'nvram show' showed that it stayed that way, also after nvram commit.
I then refreshed the web page (I was also logged in via the gui), and lo and behold, it changed to English!
I have not rebooted. I don't know if it survives a reboot, but this thing never need reboots anyway - this is my second AC68U, I've had another one running for years non-stop in Japan (and that one had the normal language selection tab, so I never imagined that the new second one wouldn't too). Anyway, my problem is solved - I can struggle through the Japanese UI, but it's is definitely easier with the English version.

TL;DR;
This fixed it for me:
ssh in as admin
nvram set preferred_lang=
nvram show|grep lang
verify that it's still empty
nvram commit
nvram show|grep lang
verify that it's still empty
Don't reboot (don't know if this makes it reverse again - I haven't tried)
Refresh web browser UI, or log in fresh.
It should change to English.
I made an account to thank you! This worked for me.

I got my router at fw version 3.0.0.4.382.50135 but nvram commit reset all the values back to what it was. I had to upgrade to 3.0.0.4.382.52272, and nvram commit worked. Also, I set preferred_lang to one space instead of empty, because setting preferred_lang to empty did nothing in my terminal (Mac OS ssh utility).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top