How to get status of aimesh nodes from command line?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Pergola Fabio

Senior Member
You know you can run a script with crontab on the nodes just like the main router.
Maybe something like

#!/bin/bash
ping -c1 192.168.50.1 > /dev/null
if [ $? -eq 0 ]
then
echo ok
exit 0
else
reboot
That will not help, when they are offline, i can still ping them
 

rlj2

Regular Contributor
That will not help, when they are offline, i can still ping them
A reboot doesnt help? only time I had issues with nodes going offline when the distance/obstructions were questionable. Even though signal showed great most the time.
 

Pergola Fabio

Senior Member
is there an easy way to revert back to stock firmware on my nodes?
should i just update the stock firmware over the merlin firmware?
or do i need to hard reset it afterwards?
 

L&LD

Part of the Furniture
Flash the firmware you want via the main router's GUI.

Remove the AiMesh node after it has rebooted and connected via the main router's GUI. This will reset it to factory defaults. You may want to do an additional WPS Button reset appropriate for your router, to fully reset it.

[Wireless] ASUS router Hard Factory Reset | Official Support | ASUS Global

After doing the above, do not 'touch' the node except by the method below.

Re-associate the node with the main router, again, via the main router's GUI.
 

Wisiwyg

Senior Member
is there an easy way to revert back to stock firmware on my nodes?
should i just update the stock firmware over the merlin firmware?
or do i need to hard reset it afterwards?
FWIW - I use Merlin 386.4 alpha on Main and latest current Official on my nodes. Everything seems to work, with exception of the Guest1 on Mesh issue that Asus has with the Mesh2 codebase. See my sig.
 

Laxarus

Regular Contributor
@L&LD did give a pretty good explanation. After that you should not have any issue. If you are still having the same issue, I would advise going to stock fw on your main and try it. If the issue still persists, that is RMA territory.
 

Pergola Fabio

Senior Member
just an update... since running stock firmware on the nodes, no drops anymore from the nodes... so it was a merlin firmware issue after all
main router is still running merlin firmware
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top