(Moved to ASUSWRT-MERLIN forum): Resolving local hostnames from OpenVPN clients

Bufflehead

New Around Here
Good morning,

I have an ASUS RT-AC86U router, running Merlin 386.1_2. I have enabled the VPN on my router, and I have successfully connected over the WAN from several OpenVPN clients (Android phone, Windows laptop). My clients are able to connect to my LAN devices using the local IP address. They cannot, however, resolve the associated hostnames that I set up on my router's "DHCP Server" tab.
I would appreciate any examples for how to solve this. Thank you!
 

eibgrad

Part of the Furniture
Most likely the problem is DNSMasq (the DNS server) is NOT listening on the OpenVPN server's tunnel network interface. You could try adding the following directive to the DNSMasq config file using a postconf script.

Code:
interface=tun2*

P.S. Since this is Merlin specific, it would probably have been more beneficial to have posted it in that forum.
 

eibgrad

Part of the Furniture
UPDATE: I was puzzled why the OpenVPN server didn't automatically add this to DNSMasq. Then realized is won't do it unless you enable the "Advertise DNS to clients" option. It will also push your router's LAN ip to the client for the purposes of DNS.

So no need for the DNSMasq postconf in this case.
 

Bufflehead

New Around Here
Most likely the problem is DNSMasq (the DNS server) is NOT listening on the OpenVPN server's tunnel network interface. You could try adding the following directive to the DNSMasq config file using a postconf script.

Code:
interface=tun2*

P.S. Since this is Merlin specific, it would probably have been more beneficial to have posted it in that forum.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top