My 5GHz network is very slow

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

andresmorago

Senior Member
Hello to all
I know there are tons of threads about this around but i just cant get to find a fix or explanation about it. I was hoping any of you could give me some light about my issue.
My 5Ghz wifi is just painfully slow.

Some context and parameters
AC3100 running 384.19 and Aimesh main
AC68u running 384.19 and as a Aimesh node with ethernet backhaul (i dont usually connect to this since the main router is closer)

5GHz spectrum looks very clean so i dont think this is an interference issue.

1598458753087.png


and im decently close to the main router as you can see on the RSSI values. im 7m away from the router with no walls in the middle.
My device where im testing in particular is ANDRES-PC-1. I do want to point out that this issue happens with all the devices as well so im ruling out a driver problem on my PC.

1598458625763.png


Wifi Parameters
Also, i have USB2 enabled instead of USB3
1598459046919.png
1598459024251.png


I run an iperf3 server on my Synology NAS which is connected to the main router via ethernet gigabit. from my windows pc i run speedtests to the NAS and these are the results. this is connected to the 5Ghz network at all times

1598458968058.png



could i be missing something on my config? can you please give me some advise?
 

ATLga

Regular Contributor
Hello to all
I know there are tons of threads about this around but i just cant get to find a fix or explanation about it. I was hoping any of you could give me some light about my issue.
My 5Ghz wifi is just painfully slow.

Some context and parameters
AC3100 running 384.19 and Aimesh main
AC68u running 384.19 and as a Aimesh node with ethernet backhaul (i dont usually connect to this since the main router is closer)

5GHz spectrum looks very clean so i dont think this is an interference issue.

View attachment 25779

and im decently close to the main router as you can see on the RSSI values. im 7m away from the router with no walls in the middle.
My device where im testing in particular is ANDRES-PC-1. I do want to point out that this issue happens with all the devices as well so im ruling out a driver problem on my PC.

View attachment 25778

Wifi Parameters
Also, i have USB2 enabled instead of USB3
View attachment 25782View attachment 25781

I run an iperf3 server on my Synology NAS which is connected to the main router via ethernet gigabit. from my windows pc i run speedtests to the NAS and these are the results. this is connected to the 5Ghz network at all times

View attachment 25780


could i be missing something on my config? can you please give me some advise?
Change channel bandwidth from 40 to 80 or 20/40/80
 

andresmorago

Senior Member
Thanks. will try that again. some concerns arise about this tho:

by using 20/40/80, would that mean that sometimes 20 will be used. is using 20 useful at all?
in addition, isnt using 80 considerably decrease my network coverage around the house?
 

ATLga

Regular Contributor
Thanks. will try that again. some concerns arise about this tho:

by using 20/40/80, would that mean that sometimes 20 will be used. is using 20 useful at all?
in addition, isnt using 80 considerably decrease my network coverage around the house?
80 will open up the speeds. Here is a recent thread to answer your question about the 20/40/80
 

andresmorago

Senior Member
very interesting. will change that asap and report back.

in addition, ive seen other users using this flag when running iperf
Code:
-w 4M
 

ATLga

Regular Contributor
very interesting. will change that asap and report back.

in addition, ive seen other users using this flag when running iperf
Code:
-w 4M
I don’t use that and stick to the GUI so someone with some understanding of that will hopefully come along and offer some input. I will offer my two cents on setting the 80 vs 20/40/80. I’ve found that some of my clients don’t like it set to 80 so I use the 20/40/80. Try with all three before limiting yourself to the one.
 

OzarkEdge

Part of the Furniture
Thanks. will try that again. some concerns arise about this tho:

by using 20/40/80, would that mean that sometimes 20 will be used. is using 20 useful at all?
in addition, isnt using 80 considerably decrease my network coverage around the house?
20/40/80 will suit all clients.

80 will suit those clients.

Try 80 (should double speed?) and watch for clients that don't like it. Later, set 20/40/80 with acquired insight.

OE
 

andresmorago

Senior Member
thanks to all.
i have tried both options and i dont see significant improvement so far. speeds vary too much and shouldnt be that low per my current environment

1598466790833.png
 
Last edited:

SheikhSheikha

Regular Contributor
Disable IPGM Snooping / Disable TX Bursting / Disable WMM APSD / Disable Multi-User MiMo

Further I see that you have the Roaming Assistent Enabled. If you do not need it: turn it offf.
The 5GHz: put it on 80MHz. If a device cannot deal with that than it should be on your 2.4GHz.
Play with the channel you select, turn of DFS and make sure you select the channel (so no AUTO).

Once you have hit apply and the wifi comes back: pull out the power cord. Wait for 5 minutes before putting it back and boot the router..
 

andresmorago

Senior Member
Disable IPGM Snooping / Disable TX Bursting / Disable WMM APSD / Disable Multi-User MiMo

Further I see that you have the Roaming Assistent Enabled. If you do not need it: turn it offf.
The 5GHz: put it on 80MHz. If a device cannot deal with that than it should be on your 2.4GHz.
Play with the channel you select, turn of DFS and make sure you select the channel (so no AUTO).

Once you have hit apply and the wifi comes back: pull out the power cord. Wait for 5 minutes before putting it back and boot the router..
thanks
Disable IPGM Snooping / DONE
Disable TX Bursting / DONE
Disable WMM APSD / DONE
Disable Multi-User MiMo / DONE

Regarding roaming assistant, im using it in order to force clients to go to the aimesh node if possible

Regarding channel bandwidth, i have tried 40, 20/40/80 and 80, being 20/40/80 the one which gives me better results. still, i get terrible speeds being relatively close to the router :(
1598537947157.png

Regarding DFS channels, i dont see it at all on my router. Why? Still, my 5Ghz spectrum looks very clear as im the only one around in that channel
1598537966420.png
 
Last edited:

SheikhSheikha

Regular Contributor
thanks
Disable IPGM Snooping / DONE
Disable TX Bursting / DONE
Disable WMM APSD / DONE
Disable Multi-User MiMo / DONE

Regarding roaming assistant, im using it in order to force clients to go to the aimesh node if possible

Regarding channel bandwidth, i have tried 40, 20/40/80 and 80, being 20/40/80 the one which gives me better results. still, i get terrible speeds being relatively close to the router :(
View attachment 25802

Regarding DFS channels, i dont see it at all on my router. Why? Still, my 5Ghz spectrum looks very clear as im the only one around in that channel
View attachment 25803
If you live close to an airport or the glide slopes of a runway, (weather) radar or wind sheer radar your 5GHz can be disturbed.
Other option: consider to completely reconfigure and flash your router (look at the handy and excellent guidance of user L&LD)
 

andresmorago

Senior Member
If you live close to an airport or the glide slopes of a runway, (weather) radar or wind sheer radar your 5GHz can be disturbed.
Other option: consider to completely reconfigure and flash your router (look at the handy and excellent guidance of user L&LD)
thanks for the feedback.
the closest airport is 15 miles away from my place. could that still affect? since i dont see the DFS channels, how can i consider this as an alternative fix?
in regards of the router firmware, i just did that a couple days ago. its already running 384.19 on a fresh install?
 

MaziahBebop

Regular Contributor
From a pure debugging and isolation perspective, have you tried switching off the AC68U, taking down the mesh while you test the AC3100?
 

andresmorago

Senior Member
From a pure debugging and isolation perspective, have you tried switching off the AC68U, taking down the mesh while you test the AC3100?
i did as well a couple hours ago. no significant improvement.

as a extra evidence, im starting to see that speeds are very low during the day. once the night enters, speeds tend to improve. im considering moving away from UNII-3 to UNII-1 and see what happens. there might be an empty channel for me

EDIT: moved to UNII-1, channel 48 :(
1598548639048.png
 
Last edited:

SheikhSheikha

Regular Contributor
thanks for the feedback.
the closest airport is 15 miles away from my place. could that still affect? since i dont see the DFS channels, how can i consider this as an alternative fix?
in regards of the router firmware, i just did that a couple days ago. its already running 384.19 on a fresh install?
Stay away from DFS. 15 Miles can cause problems, depending how the weather/radar/wind sheer systems are setup.
 

andresmorago

Senior Member
Stay away from DFS. 15 Miles can cause problems, depending how the weather/radar/wind sheer systems are setup.
interestingly, at this time of the day 6PM, channel 153 at 80Mhz is the one which gives me the best results. this rules out any issues with the router as im getting pretty good speeds.


1598568316940.png


in the morning, all the channels are just garbage and i cant understand why

1598568544760.png
 

KGB7

Very Senior Member
1. Test each router independatly with out Mesh.
2. Test each router with previous Merlin firmware.
3. Test each router independently with Fork Firmware.
4. Disable QoS. Ive been having issues with .19 firmware when QoS is enabled.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top