What's new

Problems with XT8 AX6600 (RT-AX95Q) HW ver 2 running stock firmware.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello all. i purchased the Asus Zenwifi XT8 AX6600 bundle in feb 24. This bundle consisted of one router and one AI Mesh "node". Everything ran really well until last week when the router started having intermittent connection failures. Essentially connectivity would drop out. Either wifi or ethernet hardline. I couldnt find anything in the logs that was obvious. At first i could access the router and perform a reboot. But yesterday it completely locked up and i had to force restart it using the power switch. After that reboot it still failed to connect clients. Since i WFH and needed to be working i reinstalled my old router (had not wiped it yet) and finished out the day. I started researching the issue and found many troubleshooting recommendations and then found out about the asuswrt-merlin-ng firmware. I would love to try installing the firmware to see if it fixes the issues i have been having BUT i have hardware version 2 Mfg in 2023. And i have found in other threads that HW 2 is not supported yet.
The router is powered by UPS so that shouldnt have caused the problem. Firmware is the ASUS official latest. It ran well until last week and just started randomly dropping connections.
I am using both 2.4 and 5 in smart connect mode.
I am using wireless backhaul.
It is set up with AIMesh to the node.
I had all the trendnet protection services turned on. but i tried turning them off and it made no difference.
I cant return the bundle so i have to try and figure out how to 'fix' the issues.
Is there any timeline on merlin-ng firmware for HW ver 2?
What else can i try to make the stock firmware function reliably? i have already factory reset and need to reconfigure.
There is no GNUTON firmware for HW V2 yet only V1 i know it was being worked on but nothing has been released as of yet. Also are you running a wired or wireless backhaul to the other XT8? Since you already did a factory reset I would start setting it up again with basic settings and see if things smooth out. The XT8’s are and have been issues for a while especially with a wireless backhaul i have HW Ver 1 I personally use and there solid in a wired backhaul scenario. I have had HW V2 as well before and I ended up returning the V2’s because of the issues I was having with them.
I cant return the bundle

Your solution for current and future issues with it.

If it doesn't run well on stock firmware - send it back.
i decided today to revert back to the january firmware 3004.388.24609 as this was what was on it when i bought it. It ran fine for over a month. It seemed like the issues started happening after the 3/19 update 3004.388.24621. So i reinstalled it and the node and reconfigured all my network settings. I did disable smartconnect and some other features. I am still using wireless back haul as i dont have any cat 5 in the location where i need the node. I am out of the window for returning to Amazon so my options are either to try to make it work, sell it, or just abandon it and stick with my old router which means i am out the money. if wired backhaul is more stable then i will have to look at pulling some wire.
Its just weird. it ran really well and then just last week started flaking out. Then yesterday it went bonkers and i couldnt get it working again until i factory reset.
This "mesh" set is perhaps the one with most issues reported here on SNB Forums. There was a long period of time users were hunting for somewhat well working firmware. Then V2 version arrived and perhaps the issues loop continues. You had to do some more research before purchasing this set. Explore wired AiMesh options.
If running cat 5 cable is out of the question you can always use moca adapters and use existing coax wire in your location to get a wired backhaul
So is it the wireless mesh causing the problem or the smart connect or something else? There were good reviews about this system when I first looked at it but that was before I found this site and before I found out there are 2 hardware versions. If there is a config that works I can get there. Running a hard line is difficult but not impossible. I just got off of Moca and there is no coax where I need it anyway.
So far about 24 hours on the old firmware with smart connect turned off and it is running well. Fast, no disconnects or drops. I set up a syslog server to offload the logs to so I don't miss anything. right now it is just wait and see.
XT8 has firmware issues the hardware is decent but firmware has been an issue for along time that’s one of the reasons a lot of people run the XT8’s with a wired backhaul. GNUTONS firmware for HW V1 has helped quite a bit with the wireless backhaul problems and hopefully the V2 hardware gets some love soon because pretty much everywhere the XT8 is sold they are HW V2 the V1 are getting harder to find not impossible but definitely harder to find.
GNUTONS firmware for HW V1 has helped quite a bit with the wireless backhaul

Different Asuswrt base helped. AiMesh is closed source.
I had a similar experience when I first set mine up over a year ago. These tweaks stabilized my connection; not sure which ones did the trick, but maybe they can help you as well. 388_21617 firmware (have been too scared to update haha); all three bands separated (Smart Connect off):
  • Backhaul Connection Priority set to "5GHz-2 Wifi first"
  • set 2.4Ghz bandwidth to 20MHz
  • set control channels on 2.4GHz/5GHz-1/5GHz-2 to 1, 36, 149, respectively (don't think it matters which one specifically, but if you choose "Auto", just make sure you toggle DFS channels to off)
  • disable Universal Beamforming on all bands
  • disable Roaming Assistant on 5GHz-2 band
Thanks j4y-t. i will give those settings a try. right now it has been running without issue for 5 days. just had one disconnect/reconnect with my work pc this morning. work pc is on ethernet not wifi and i dont see anything in the XT8 logs that indicates there was a disconnect. could just be an ISP hiccup or something on the work vpn side.
So, after 2 1/2 weeks of stability i had my first outage yesterday. Internet access dropped out both for ethernet and wifi. I logged in to the admin console and saw nothing in the logs, Internet connection showed as up with traffic, then the admin console dropped out and was inaccessible. Took about 5 minutes to come back. But still no internet on ethernet or wifi. Logged back in, still nothing in the logs. Went to the network tools page and tried a ping to google.com. Came back with no record found. Tried another ping to yahoo and boom, internet came back up. Total outage time about 15 minutes. Nothing in the logs on the XT8. I rebooted the router just for completeness's sake. I went to my syslog server and went through the kernel, rc_service, and dropbear logs. Nothing to indicate a problem. Also, the reboot didn't appear. Could i be missing a log? Still running the 3004.388.24609 firmware. I haven't let it update even though it keeps telling me there is a newer firmware.
This is kind of what happened the first time i had issues. Intermittent dropouts that slowly got worse until the router became completely unresponsive. I am not at the later stages yet as i have only had one dropout. But if it starts to get worse then i know i have a problem. If this whole thing happens again then i am probably going to replace the system.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!