Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Rt-ac66r printer and usb drive issues

Discussion in 'ASUS AC Routers & Adapters' started by pokermic, Mar 16, 2013.

  1. pokermic

    pokermic New Around Here

    Mar 16, 2013
    ***I am thinking about downloading the Merlin Firmware, but not sure if it will help with my issues or not, and I didn't want to mess up what I have so far...

    I bought an ASUS RT-AC66R (which is apparently the Best Buy version of the AC66U?) when our old crappy belkin bit the dust two days ago. I bought this router for a couple reasons, but one big one was the ability to share a usb external hard drive between multiple computers and possibly access that hard drive when we are on the road through either a remote or internet connection. Before the asus, we had an external drive hooked up to the desktop computer, then the other computer had to access those files through the desktop...a pain in the neck if the desktop wasn't on.

    So, we bought the Asus, did manage to set it up so that we are getting internet (at great speeds). That's where all my troubles begin. That's the most I can do.

    We have an HP Photosmart 7250 printer I need hooked up and available on both wireless and wired computers. I set it up with the USB cable (I would prefer to set it up with ethernet so we could hook up TWO external hard drives on the usb ports--but couldn't get the router to see the printer as a printer on ethernet). The router never spotted the printer, even on usb, so I followed the instructions I found on asus to set the printer up through the ADD PRINTER wizard and set up a standard TCP/IP port using the ip as the host name/IP address, then set the Protocol to LPR and the Queue Name to LPRServer and uncliked the LPR Byte Counting.

    This seemed to work. A test page printed on both the laptop and the desktop. Thought we were fine.

    Next I connected our USB external drive, it came up, I mapped to it from the laptop, and all the files came up fine.

    Went to work on something, and when I tried to print it, the file would not go to the printer. The printer seemed to be visible, but wouldn't print. Decided to open up the UI and take a look, and the UI would not come up. Not by typing it into the address bar, not by clicking on it in properties. Just page not found.

    Since both the printer and the usb external hard drive also use the address, I wondered if maybe it creates a conflict for the router?

    No matter what I did, I could not open the UI. I deleted the printer from devices and printers, unplugged both the printer usb cord and the external hard drive cord. Still could not open the UI.

    Hit the power button to power it back up, and now I can get into the UI--however, I am back to square two (internet-square one-still works) with no printer and no external hard drive.

    My specs: Both the laptop and the desktop are running Windows 7 64 bit.

    I am not a computer novice, but am fairly illiterate when it comes to networking. :(

    I am debating downloading the MERLIN FW, but I don't know if that would help me with my issues or give me more to digest? I do love the idea of being able to turn off the lights at night!! So even that might make it worth it...but I am not too proud to admit I need a little hand holding to get this thing set up.

    At this point, I have five more days to figure out if I need to take this router back to the store.

    I NEED to be able to do the following:
    1. Connect several computing devices to the internet over a large area.
    2. All devices need to be able to print from the one printer. I would love to use the ethernet (printer does have ethernet) but would be happy right now to use usb.
    3. All devices need to be able to access and read, write, save, delete etc the files on a 1tb external hard drive.

  2. RMerlin

    RMerlin Part of the Furniture

    Apr 14, 2012
    Ethernet support for printers have nothing to do with the router used. The printer sharing is entirely handled by the printer. Make sure the printer does have a different IP address - you cannot have two devices with the same IP on a network.
  3. pokermic

    pokermic New Around Here

    Mar 16, 2013
    Hi Merilin, thanks so much for answering! To be honest I was hoping it would be you that answered. Is it possible that changing my firmware to your new firmware (I am currently using the asus .270 firmware) will fix any of my issues, or just be a little more understandable for a newbie?

    When I installed the ASUS, I connected the printer via the USB port on the back. Then I ran the usual printer install--no good.

    Then I found a link to this ASUS support page and followed the instructions to the letter....including this ip or hostname:

    My printer gets "installed" but nothing will print to it. I'm almost ready to return the router--just doesn't seem like installing a printer should be this difficult.

    I am adding a few more images to show the settings I have tried. I did try to change (manually--at the printer) the printer's ip, but the format of the ip was restricted to three digits in each set. I couldn't get it to set the ip to (for instance), so I tried Here are the settings I have tried, as per the asus support instructions:

    Last edited: Mar 17, 2013

Share This Page