Smart Connect leads to service discovery issues and radio unreliability?

Jong

Senior Member
Is anyone else seeing the above?

I have two RT-AX88U boxes, on latest Asus firmware, in AiMesh mode, with wired backhaul. Mostly default settings are being used. Smart Connect is using all defaults.

All works perfectly with Smart Connect off but when turned on:
1. Service discovery is really flaky. I use Google Cast, Spotify Connect and Windows 11 file sharing. When devices join the network they appear to announce their availability just fine, but come back a few hours or a day later and most of them disappear - Chromecast no longer visible for casting in multiple apps and on multiple devices. Spotify can no longer find Spotify Connect devices. Windows can no longer find other shares on the network although putting in the IP address of the share works fine.
2. Within about 24 hours of a reboot the WiFi on the secondary node disappears and only the main node is available.
Neither of these problems happen with Smart Connect off.

Is anyone else seeing this? Anybody have any ideas of the cause?

Honestly all seems to work well without Smart Connect so I'm pretty happy leaving it off. But, it is surprising to see such a major feature cause such major issues.
 

L&LD

Part of the Furniture
Yes, Smart Connect is known to be not so smart.

Leave most of the 'auto' settings off, for a stable network (the main exception is the Wireless, General, Wireless Mode options for both bands).
 

Jong

Senior Member
Thanks for the reply. I guess I'll leave it off until some firmware update suggests it's been substantially improved and then give it another whirl!
 

Smokey613

Very Senior Member
I turned off Smart Connect and RoamAssist (on both bands). I find this to be more stable.

Most clients that do roam are usually smart enough to select the best router. None of my 2.4g devices ever change location so no need to enable roam assist on the 2.4g band.
 

bbunge

Part of the Furniture
I have no issues with SmartConnect and auto channel enabled. Clients choose which band they need and the router switches between 80 and 160 MHz as clients join or leave. 5 GHz usually chooses channel 52. I do turn off WPS and set 2.4 GHz to 20 MHz.
 
Similar threads
Thread starter Title Forum Replies Date
D RT-AC86U Aicloud smart access not working [SOLVED] ASUSWRT - Official 5

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top