1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

USB-AC68 Slow download after W10 Creators update solution

Discussion in 'ASUS AC Routers & Adapters' started by timex18, Apr 11, 2017.

  1. timex18

    timex18 New Around Here

    Joined:
    Aug 29, 2014
    Messages:
    3
    Thought I would pass this on to anyone else having the same problem. Upgraded to Windows 10 Creators Update a few days ago. Smooth install and everything is working fine except my internet download speed has slowed to a crawl. Prior to the update I could download ~185Mbs and Upload ~12Mbs
    Since the update I am getting ~4Mbs down and 11Mbs up.
    Uninstalled the Asus driver and reinstalled with same results.
    I can upload files within my network at full speed, but same slow download.

    Running Asus USB AC-68 with Version 2.1.3.0 driver through USB 3.0
    Windows 10 build 1703
    Router Netgear R7800 V1.0.2.28 firmware

    Found this thread (In German no less) discussing this as a driver issue. https://answers.microsoft.com/de-de...niedrige/27a55259-dca3-442d-81d4-d382a9c502d8
    There is a mention someone fixed it using a .inf driver from Realtek-Treiber 1030.13.704.2016 package. Sure enough, I found that file http://drivers.softpedia.com/get/NE...Network-Adapter-Driver-1030-13-704-2016.shtml, updated the driver from this package and now I am right back to where I started with 185Mbs down and 12 up.

    I am sure I am not the only one having this problem (or will get once Creators Update gets full rollout) so here's the fix until Asus can update their drivers.
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Arrow

    Arrow Regular Contributor

    Joined:
    Jul 28, 2012
    Messages:
    65
    I'm having the exact same issue with a Asus USB-AC68 and a USB-AC56R. Before the Windows 10 Creators 64 bit update, I was getting 350 Mbps down. Now I'm getting 2-5 Mbps down.

    Windows 10 Pro Version 10.0.15063 Build 15063 (64 bit)

    Using the Realtek driver fixes the problem (thank you), but first I had to also update chipset and usb drivers.
     
    Last edited: Apr 13, 2017
  4. R@pt0rs

    [email protected] Occasional Visitor

    Joined:
    Sep 23, 2014
    Messages:
    10
    Hi Timex 18,

    Thank you for this! I have an USB-AC56R as well and this tid-bit helped! I managed to get the speed back to my 100 Mbps that I should be getting from before the upgrade to Windows 10 Creator Edition.

    Just a note for those squirmish on using this file download (since it's not an ASUS direct driver download), you can actually get some of your speed back up by changing the Advanced settings in Device Manager. The big one was to disable Q0S and I got from 1 Mbps to 20 Mbps. But I vouch for this .inf solution!
     
    timex18 likes this.
  5. tarund

    tarund Occasional Visitor

    Joined:
    Jan 24, 2013
    Messages:
    14
    You are a savior! Thank you very much!
     
  6. al_bundy

    al_bundy New Around Here

    Joined:
    Nov 21, 2014
    Messages:
    1
    Thank you very much, timex18! solved my problem with the usb-ac68, too! :)
     
  7. jph1589

    jph1589 Regular Contributor

    Joined:
    May 5, 2016
    Messages:
    68
    Location:
    Wooster, Ohio
    I have an ASUS laptop that I recently updated to Windows 10 pro. It didnt update the Realtek network driver at that time nor did it update it for the Creator update. The existing driver was from 2013 which was actually 2 years older than the computer is. So I went into device manager and told it to search for new drivers and unlike the way I remember it working, it found a new driver from 2015 and installed it without any prompting. I rebooted my laptop and as soon as I started a speedtest the link went down. LOL.

    So I rolled back the driver and rebooted and speedtest ran fine. And while I was typing this, my ethernet connection disappeared. LOL!!

    I turned on my wifi so that I could finish typing this. Going to reboot again and see if it comes back.

    Leave it to microsoft to screw up drivers yet again.

    After reboot and disconnecting ethernet from router and reconnecting, everything seems ok.

    Yet another example of "IF IT AIN'T BROKE DON'T FIX IT!!"

    Note to self........Gibbs slap me if I do that again!
     
    Last edited: Apr 22, 2017
  8. chrisloup

    chrisloup Occasional Visitor

    Joined:
    May 11, 2014
    Messages:
    15
    omg. i'm facing this problem. i noticed it on 380.65_4 and thought was a firmware problem, then i upgraded to the latest beta when it didn't go away. ookla speed test on pc shows 10mb download , 100mb upload. on my phone using speedtest, it shows a fare more reasonable 90mb download/100mb upload so i surmised its probably not firmware

    after installing the driver http://www.speedtest.net/result/6254025256.png
     
  9. MikeH

    MikeH New Around Here

    Joined:
    Aug 16, 2017
    Messages:
    1
    Thank you, this solved my problem as well. 1.5 mbit down Old situation, after driver installation back up to 150mbit down. The upstream stayd roughly the the same.
     
  10. dlandiss

    dlandiss Senior Member

    Joined:
    Jul 14, 2013
    Messages:
    425
    Location:
    St. Louis, MO
    That would worry me too;)!

    10mb = 0.010 bits/second
    100mb = 0.100 bits/second
     
  11. damien

    damien New Around Here

    Joined:
    Oct 6, 2017
    Messages:
    1
    you
    you sir are amazing i was having the insainly slow download speeds with my new usb and it was driving me nuts. i created an account just to say thank you . the disable qos helps a little but but this new driver fixes it all the way
     
  12. sinnes

    sinnes New Around Here

    Joined:
    Jan 20, 2018
    Messages:
    1
    Signed up to say thank you! After hours of troubleshooting, this saved me.
     
  13. Dafore

    Dafore New Around Here

    Joined:
    Jan 21, 2018
    Messages:
    1
    This fix works! Thanks!
     
  14. TemplarDroid

    TemplarDroid New Around Here

    Joined:
    Thursday
    Messages:
    3
    Thank you so much! I just purchased an Asus RT-AC88U and I could only get 2mbps download with a 390mbps connection. Now I'm getting 70mbps download speed with a 520mbps connection 3 levels up from the router. I'm using a ASUS USB-AC56 Dual-band AC1300 USB 3.0 adapter.
    Is this a problem with just Asus AC routers (RT-N66U didn't have a problem), the AC56 USB adapter that I'm using, or does it affect just some or all AC routers?
     
    Last edited: Jul 12, 2018 at 9:41 PM
  15. TemplarDroid

    TemplarDroid New Around Here

    Joined:
    Thursday
    Messages:
    3
    Ah, I translated the page to get my answer.

    Quote:

    Thanks to the hints here in the forum the problem of the slow download speed could be solved.
    The problematic device is obviously the network adapter ! So first, the ASUS USB-AC56 turned off QoS support, which brought a slight improvement in the download, but was not really the solution.
    Then I followed the hint of Tom_West into the tp-link forum regarding drivers - and that brought the solution.
    There is actually a newer driver for the AC56 (even if the Windows update does not find it!), Namely the Realtek driver 1030.13.704.2016 from 19.12.2016! (This Realtek driver works according to inf-file not only for D-Link devices, but also for ASUS , ELECOM, Edimax, etc.)
    Have the driver then installed manually and now it works again as it should.

    Thanks to the helpers in this forum.

    End quote:
     
  16. Internet Man

    Internet Man Senior Member

    Joined:
    Sep 1, 2017
    Messages:
    206
    What about just using the latest driver straight from Realtek? It includes the ID of the USB-AC56.

    For the RTL8812AU/RTL8811AU/RTL8192EU/RTL8812BU/RTL8811CU/RTL8814AU

    Version: 1030.25.0701.2017
    Date: March 20, 2018
    Description: 32bit/64bit Windows7, Windows8.1, Windows10 WLAN USB driver (Install Package)
     
  17. TemplarDroid

    TemplarDroid New Around Here

    Joined:
    Thursday
    Messages:
    3

    I just tried the newest driver but unfortunately it disabled the 5ghz on my Asus USB-AC56 adapter and only 2.4 ghz connections were showing. I clicked the install rather than just the INF as before and it installed some CISCO programs along with the driver. I uninstalled it and reinstalled the 2016 dated driver and it was back to normal. This time I just used the INF file for the 2017 driver and again no 5ghz at all. So I chose to revert to the previous driver and as soon as it displayed the driver date of 2016 it rebooted and began a boot loop......SIGH. I reverted Windows 10 (64 bit) to the date before all of this and I was back up and running with 5ghz but with the old slow driver. Installed the 2016 driver using the INF as mentioned here and BOOM were FAST again.
    Maybe I screwed it up by using the install file, maybe its just my system, but I'll stick with the 2016 driver.
     
    Internet Man likes this.
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!