Windows 10 and Intel Wifi in 5ghz -> 20mhz only - Is there anyone having this issue too?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

citytrader

Occasional Visitor
I having an issue with Windows 10 and seems is not the problem of the intel drivers (it happens with 3 different machines on Windows 10), when checking speed with iperf3, on my galaxy S21 I'm getting 600mbps, but at the same distance with my machines (laptop and desktop) I only get near 300mbps, checking at the Intel driver configuration I see for channel bandwidth 2 options, AUTO and 20mhz only, no option for 80mhz for example, I did a check with the same computer but running Ubuntu and the speeds are near 500mbps, much better than Windows 10.
Could be possible that there is a problem with Location Aware Regulatory in Windows 10? Is there any registry hack to force 80mhz in the wifi drivers? I saw lot of people when googled this issue that has the problem without solution.

NOTE: I uninstalled the Intel drivers totally, used the Microsoft ones, I installed older Intel drivers, all shows no option for 80mhz bandwidth and if this is happening to 3 different machines, the problem is in Windows 10 (21H1)
 

ColinTaylor

Part of the Furniture
What Intel network card(s) are you having the problem with?

Log into your router and check what link speed the clients have connected with.

Change the 5GHz channel to something else.

Regarding location, what country are you in? Were the network adapters purchased in the same country or imported?
 

citytrader

Occasional Visitor
I'm located in Mexico (but this does not happen in Ubuntu)

The Intel cards are:
LAPTOP AX200 Bought in USA
DESKTOP AX200 Bought in Mexico
LAPTOP AC8265 Bought in Mexico (this machine in Ubuntu has full bandwidth, but in a Windows clean install it uses only 20mhz)


My desktop had full channel coverage and full bandwidth speed before I did some Windows upgrade that I didn't remember, for this I'm convinced that Windows did something to limit the drivers, otherwise I should have the same issue in Ubuntu but it does not happen.

I started to investigate this issue when I've got a new laptop and tested the wifi speed, this has nothing to do with the router because is happening with my R7800 and with other Asus, is related with Windows in the last versions.

If you check in the driver configuration, before some update I was able to select 80Mhz and now I can't, auto is useless because seems Windows is using only 20Mhz.

Network Card.jpg


Maybe all people should check if they have the same issue. (Mine is Windows 10 21H1 Enterprise)
 
Last edited:

ColinTaylor

Part of the Furniture
I have an Intel 7265. It also only has 5GHz bandwidth options of 20MHz or Auto. It has no problem connecting to my router at full speed (and 80MHz bandwidth) when using the Auto setting.
 

citytrader

Occasional Visitor
I have an Intel 7265. It also only has 5GHz bandwidth options of 20MHz or Auto. It has no problem connecting to my router at full speed (and 80MHz bandwidth) when using the Auto setting.
Did you do an iperf3 speedtest? if you don't do that test you don't really now if you are getting full wifi speed or not
 

ColinTaylor

Part of the Furniture
Did you do an iperf3 speedtest? if you don't do that test you don't really now if you are getting full wifi speed or not
With iperf3 I typically get ~440 Mbps transmitting and ~535 Mbps receiving. The iperf3 server is connected via Ethernet.

Did you verify the link speed on your router?
 

citytrader

Occasional Visitor
With iperf3 I typically get ~440 Mbps transmitting and ~535 Mbps receiving. The iperf3 server is connected via Ethernet.

Did you verify the link speed on your router?

The ethernet speed on the desktop is 935 Mbps, the same machine with wifi 350Mbps on Windows, 550Mbps in Ubuntu
 

citytrader

Occasional Visitor
Its reported correctly, 866Mpbs, so max throughput should be 80% of that near 692 Mbps like my Galaxy S21
I'm converting one of the laptops to Hackintosh to do the test again with Bigsur
 

L&LD

Part of the Furniture
Yes, that's the overhead and your Wi-Fi environment, and is within expectations.
 

citytrader

Occasional Visitor
Yes, that's the overhead and your Wi-Fi environment, and is within expectations.
withing expectations is a little less than 700Mbps caused by the wifi overhead, in my case and only in Windows is 350Mbps... this is not expected because is half of what my laptop is capable
 

L&LD

Part of the Furniture
How close are you testing? Are the laptops plugged in or running on battery? What power mode are you using?

I'm running 21H1 Pro on multiple machines and don't see this issue you have.

And at any reasonable real world distance, your expectations are too high.
 

citytrader

Occasional Visitor
How close are you testing? Are the laptops plugged in or running on battery? What power mode are you using?

I'm running 21H1 Pro on multiple machines and don't see this issue you have.
My Desktop has no other battery than the UPS :)
I tried to change the power plan and no luck, I'm getting 450Mbps and in the same distance with my Galaxy S21 I'm getting more than 600 Mbps, so distance is not the issue(1mts from the router) .

If the problem is only in Windows because the same machine in Ubuntu doesn't, something is related to Windows and 3 computers with different hardware and 1 with different wifi card...

Did you the test with iperf3? I arrived to this problem when I was testing one of the laptops.
 

citytrader

Occasional Visitor
Finally I solved this issue, the problem was the Iperf version I was using, I updated it to the last version and used the same version in both sides and now I'm getting correct speeds of around 680 Mbps in all my endpoints... seems the iperf version should be the same in all the endpoints, if one endpoint has different version, it could give unexpected results. Thanks to all for the feedback.
 

L&LD

Part of the Furniture
Glad you solved the problem.

1M is much too close to test Wi-Fi of current routers.

Minimum of 3 or 4M is optimal.
 

citytrader

Occasional Visitor
Glad you solved the problem.

1M is much too close to test Wi-Fi of current routers.

Minimum of 3 or 4M is optimal.
Thanks for the info, I don't have too much space because the router is in an office, but I lowered the power in the R7800 to 75%...
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top