YazFi YazFi DNS non responsive

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

BaronVonchesto

Occasional Visitor
Just installed YazFi 4.3.4 on my AC66U running john's fork 51E3 (the latest). I notice that on guest networks managed by YazFi im having severe DNS timeout problems. Devices connected to a guest network managed by YazFi keep having to try over and over again in the hope of resolving, whereas if I connect the same device to a guest network not managed by YazFi there is no such problem.

I have one way to guest turned ON,
Force DNS NO
Redirect all to VPN NO
Two way to Guest NO

any idea what the problem is? The DHCP gives the router as the DNS even though I specified the DNS server in the YazFi UI as 8.8.8.8
 

bennor

Senior Member
To avoid the router adding itself as a dns server make sure to set Advertise router's IP in addition to user-specified DNS to No on the Lan dhcp server page.
 

BaronVonchesto

Occasional Visitor
To avoid the router adding itself as a dns server make sure to set Advertise router's IP in addition to user-specified DNS to No on the Lan dhcp server page.
hmm I'll give this a try but i'm not so sure I want to do this.
In the first place my devices are fine when not on a YazFi managed network.
Secondly I'm planning to setup a Pi-Hole dns to blacklist suspicious urls, so I think I will need DNSmasq turned on.

Anyway I'll give your suggestion a try
 

Jack Yaz

Part of the Furniture
Just installed YazFi 4.3.4 on my AC66U running john's fork 51E3 (the latest). I notice that on guest networks managed by YazFi im having severe DNS timeout problems. Devices connected to a guest network managed by YazFi keep having to try over and over again in the hope of resolving, whereas if I connect the same device to a guest network not managed by YazFi there is no such problem.

I have one way to guest turned ON,
Force DNS NO
Redirect all to VPN NO
Two way to Guest NO

any idea what the problem is? The DHCP gives the router as the DNS even though I specified the DNS server in the YazFi UI as 8.8.8.8
sounds like something is going wrong if the client shows the router IP as DNS from DHCP, it should be 8.8.8.8
can you try using option1 of YazFi's SSH menu and check if any errors get thrown?
 

bennor

Senior Member
hmm I'll give this a try but i'm not so sure I want to do this.
In the first place my devices are fine when not on a YazFi managed network.
Secondly I'm planning to setup a Pi-Hole dns to blacklist suspicious urls, so I think I will need DNSmasq turned on.
Pi-Hole has and uses it's own DNSmasq separate and independent from the router's DNSmasq. If you plan on running Pi-Hole (which some of us do while also running YazFi) you will want, if not need, to set Advertise router's IP in addition to user-specified DNS to No. If one doesn't then its possible network clients (LAN and YazFi) can/will bypass the Pi-Hole(s) or what ever DNS servers one enters into the LAN DHCP DNS server and YazFi DNS server fields. One may/will also want to enable and configure DNSFilter as well to further force network clients to use the Pi-Hole.
 

BaronVonchesto

Occasional Visitor
sounds like something is going wrong if the client shows the router IP as DNS from DHCP, it should be 8.8.8.8
can you try using option1 of YazFi's SSH menu and check if any errors get thrown?
nop no errors. I also used option e to generate diagnostic logs but i didnt see anything wrong in YazFi.conf or Yazfi.dnsmasq

Anywya I turned off Advertise router's IP in addition to user-specified DNS and this seems to have done the trick, or at least i can run apt update/upgrade on my raspberry pi now without a "temporarily failed to resolve..." error
 

BaronVonchesto

Occasional Visitor
ok coming back to this as i figured it is better than just starting a new thread.

It's been a week since I last posted and the past few days I've been having very poor DNS query times. it feels intermittent, but it happens often enough that it is almost all the time. Basically all DNS queries tend to timeout at least once before subsequently resolving.

on my iphone i often get the "wifi network <name> appears to be not connected to the internet" message. and on my desktop (connected by lan) I often get DNS not resolved errors in chrome, but a refresh will immediately load the page. Funnily enough the problem is much more prominent in windows 10 than 7 (dual booting on the same computer). but it happens on all devices on my main network.

for what it is worth i have the dns servers manually configured on my desktop to google dns, so it shouldn't be bothering with router settings at all
 

bennor

Senior Member
.... but it happens on all devices on my main network.
Just to clarify, are your DNS issues affecting the main LAN/WiFi (non WiFi YazFi Guest) clients?
Are you using Pi-Hole, which you previously mentioned?
If so what is the Pi-Hole connected to? The main LAN/WiFi or to the YazFi Guest WiFi?
What is the main LAN DNS values set to?
What is your WAN DNS values set to?
Are you using nodes (AiMesh)?
Does the issue persist using major public DNS server values for the YazFi and LAN DHCP DNS fields?

Basically for others to help more information about your settings both on the Asus-Merlin, YazFi, and the Pi-Hole (if using Pi-Hole) and what troubleshooting steps you've taken would be helpful.
 

BaronVonchesto

Occasional Visitor
ok coming back to this as i figured it is better than just starting a new thread.

It's been a week since I last posted and the past few days I've been having very poor DNS query times. it feels intermittent, but it happens often enough that it is almost all the time. Basically all DNS queries tend to timeout at least once before subsequently resolving.

on my iphone i often get the "wifi network <name> appears to be not connected to the internet" message. and on my desktop (connected by lan) I often get DNS not resolved errors in chrome, but a refresh will immediately load the page. Funnily enough the problem is much more prominent in windows 10 than 7 (dual booting on the same computer). but it happens on all devices on my main network.
 

BaronVonchesto

Occasional Visitor
Just to clarify, are your DNS issues affecting the main LAN/WiFi (non WiFi YazFi Guest) clients?
Are you using Pi-Hole, which you previously mentioned?
If so what is the Pi-Hole connected to? The main LAN/WiFi or to the YazFi Guest WiFi?
What is the main LAN DNS values set to?
What is your WAN DNS values set to?
Are you using nodes (AiMesh)?
Does the issue persist using major public DNS server values for the YazFi and LAN DHCP DNS fields?

Basically for others to help more information about your settings both on the Asus-Merlin, YazFi, and the Pi-Hole (if using Pi-Hole) and what troubleshooting steps you've taken would be helpful.
Thanks for the reply.

DNS issues affecting main LAN& Wifi. I'm not sure guest wifi networks are affected anymore once i put both my guest networks on YazFi. Previously when just one was on YazFi and the other was not, it was definitely affected. This slow DNS resolution feels like an intermittent but frequent one, making it hard to nail down.

not using Pi-Hole yet.

Main LAN DNS settings are 8.8.8.8 & 8.8.4.4 with advertise router IP set to NO
For WAN DNS:
- Connect to DSN automatically is NO
- DNS servers 8.8.8.8 & 8.8.4.4
- Enable DNS over TLS -NO
- Enable DNSSEC -NO
- Enable DNS Rebind - NO
- Prevent Client auto DOH - Auto

YazFi set to serve 8.8.8.8 & 8.8.4.4 directly and it doesnt feel like guest networks affected.
What is strange is that even with the DNS manually configured to google dns on my desktop (connected to LAN) I still have the slow resolution issue.
 

bennor

Senior Member
DNS issues affecting main LAN& Wifi. I'm not sure guest wifi networks are affected anymore once i put both my guest networks on YazFi.
Your issues are most likely not tied to YazFi if main LAN/WiFi clients are also affected. As a troubleshooting step you can disable the YazFi Guest network and see if the DNS issues persist.

Another troubleshooting step is to experiment using other public DNS servers: https://www.lifewire.com/free-and-public-dns-servers-2626062

Are you running any other scripts on Asus-Merlin?

What does a trace route to the DNS servers you are using show?

Does the issues persist if you turn off/power off all other network devices except one local network computer connected by Ethernet directly to the Asus-Merlin router?

Have you looked into if your broadband provider is having network issues that may contribute to your DNS issue(s)?
 

BaronVonchesto

Occasional Visitor
Your issues are most likely not tied to YazFi if main LAN/WiFi clients are also affected. As a troubleshooting step you can disable the YazFi Guest network and see if the DNS issues persist.

Another troubleshooting step is to experiment using other public DNS servers: https://www.lifewire.com/free-and-public-dns-servers-2626062

Are you running any other scripts on Asus-Merlin?

What does a trace route to the DNS servers you are using show?

Does the issues persist if you turn off/power off all other network devices except one local network computer connected by Ethernet directly to the Asus-Merlin router?

Have you looked into if your broadband provider is having network issues that may contribute to your DNS issue(s)?
Your issues are most likely not tied to YazFi if main LAN/WiFi clients are also affected. As a troubleshooting step you can disable the YazFi Guest network and see if the DNS issues persist.
Yea thats what I thought too, which is why I first asked in the thread for the current version of john's fork which Im using. John suggested that while he isn't familiar with how YazFi works, perhaps a loop of continually trying to redirect DNS requests is happening if YazFi uses a DNSfilter, which is why I thought to ask here as well.

Another troubleshooting step is to experiment using other public DNS servers
have tried switching from 8.8.8.8 to 1.1.1.1 will give it a few days and report back on the results

Are you running any other scripts on Asus-Merlin?
nop. at least not as far as i know! I did a full factory reset to install john's fork and only recently installed YazFi. Did not configure any other script.

What does a trace route to the DNS servers you are using show?
Here's what i got

C:\Users\xxxxx>tracert 8.8.8.8

Tracing route to 8.8.8.8 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms RT-AC66U [192.168.0.100]
2 3 ms 3 ms 3 ms 175.142.207.254
3 5 ms 7 ms 6 ms 10.55.106.17
4 6 ms 4 ms 7 ms 10.55.100.197
5 7 ms 4 ms 7 ms 10.55.48.200
6 7 ms 7 ms 8 ms 72.14.204.208
7 17 ms 19 ms 19 ms 216.239.47.169
8 7 ms 8 ms 9 ms 72.14.239.243
9 7 ms 7 ms 7 ms 8.8.8.8

Trace complete.


Does the issues persist if you turn off/power off all other network devices except one local network computer connected by Ethernet directly to the Asus-Merlin router?
This will be a tough one to test out. the family uses the internet 24/7, with one of my more nocturnal sibling typically up even up at 3 or 4am. Will need to try and find a brief moment when i can do this test.

What i can say is that the issue is definitely happening on both LAN and wireless devices, as well as devices connected to the guest network. I have a headless raspberry pi connected to the guest network (isolated), and last night i had trouble running sudo apt distro-upgrade or sudo apt install xxx because it would keep running into "temporarily failed to resolve" errors and would need to rerun the commands with --fix-missing once or twice

Have you looked into if your broadband provider is having network issues that may contribute to your DNS issue(s)?
I haven't a clue as to how i'd investigate this. My problems only appeared after updating the firmware to 51e3 and installing yazfi (unclear exactly when as I waited a few days after firmware update to install yazfi, but only noticed it after installing yazfi)

What I can say is that when I turn on nordVPN on my computer and force all traffic including DNS queries through the tunnel than there's absolutely no problem. DNS resolves lightning fast.

I do have my old ISP provided router somewhere. Let me try replacing my AC66U with that and see if the problem persists
 

bennor

Senior Member
Yea thats what I thought too, which is why I first asked in the thread for the current version of john's fork which Im using. John suggested that while he isn't familiar with how YazFi works, perhaps a loop of continually trying to redirect DNS requests is happening if YazFi uses a DNSfilter, which is why I thought to ask here as well.
Do you have DNSFilter enabled? If so what are the settings?

There is a specific DNS loop/flooding issue that can crop up when one uses Pi-Hole and has the Pi-hole's Conditional Forwarding option enabled and uses the Pi-Hole in the WAN DNS fields. That doesn't sound like the case here if you are not using Pi-Hole IP address in any of the DNS fields (WAN, LAN, YazFi, etc.).

I haven't a clue as to how i'd investigate this. My problems only appeared after updating the firmware to 51e3 and installing yazfi (unclear exactly when as I waited a few days after firmware update to install yazfi, but only noticed it after installing yazfi)
Uninstall YazFi is probably the next step troubleshooting. That may possibly either rule out YazFi as the cause or point to it having some sort of an issue with that specific firmware version (51e3).

May even be a good idea to do a hard reset on the router taking it back to stock default values, and wiping out any scripts, then reconfiguring from scratch. Test things once the router is set up/configured and see if the issue persists. Only add in YazFi if everything is working properly and test again.
 

BaronVonchesto

Occasional Visitor
Do you have DNSFilter enabled? If so what are the settings?

There is a specific DNS loop/flooding issue that can crop up when one uses Pi-Hole and has the Pi-hole's Conditional Forwarding option enabled and uses the Pi-Hole in the WAN DNS fields. That doesn't sound like the case here if you are not using Pi-Hole IP address in any of the DNS fields (WAN, LAN, YazFi, etc.).


Uninstall YazFi is probably the next step troubleshooting. That may possibly either rule out YazFi as the cause or point to it having some sort of an issue with that specific firmware version (51e3).

May even be a good idea to do a hard reset on the router taking it back to stock default values, and wiping out any scripts, then reconfiguring from scratch. Test things once the router is set up/configured and see if the issue persists. Only add in YazFi if everything is working properly and test again.
no i'm not running any dnsfilter, and I have yet to configure my pi-hole. it isn't hooked up to the network at all.

You're probably right. I'll start by uninstalling yazfi, then before I nuke the router settings (hard reset, wipe jffs partition etc), I think i'll try swapping back to the old ISP router briefly to see if the problem is still there.

do i just use the uninstall option in the YazFi menu or do i first disable yazfi from my guest networks?
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top