Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

5Ghz Stops Broadcasting on Merlin 380.68_2 and above - AC3100

Discussion in 'Asuswrt-Merlin' started by webgrease, Oct 3, 2017.

  1. e38BimmerFN

    e38BimmerFN Senior Member

    Joined:
    May 25, 2012
    Messages:
    354
    Location:
    USA
    I'd give RTNs settings a try on your current FW and see if any thing helps.

     
  2. DAVIZINHO

    DAVIZINHO Occasional Visitor

    Joined:
    Mar 21, 2016
    Messages:
    32
    Now i copy this professional settings and apply. I tell you the results
    I cant flash now with other firmware because if i disconect the 2.4wifi my wife kill me :p
     
  3. e38BimmerFN

    e38BimmerFN Senior Member

    Joined:
    May 25, 2012
    Messages:
    354
    Location:
    USA
    Hope maybe new setting will help out.
     
  4. webgrease

    webgrease Occasional Visitor

    Joined:
    Mar 14, 2014
    Messages:
    22
    I did for many years, until it became apparent that the downsides of hiding the SSID outweigh the advantages from a security perspective. For the purposes of this issue, SSID is not hidden and hasn't been.
     
  5. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    24,220
    Location:
    Canada
    Hiding SSIDs just need to die, it's a completely useless feature that only leads to false sentiments of security. It does absolutely nothing for security, and the latest Windows 10 releases will even show them as "Hidden network" in the AP list.
     
    klungland likes this.
  6. webgrease

    webgrease Occasional Visitor

    Joined:
    Mar 14, 2014
    Messages:
    22
    Been up and running with no issues for just under 24 hours now. While it is still too early to "call it", lets assume that the singular setting of changing from 20/40/80 to 40MHz is the "fix" for the issue where a router stops broadcasting the 5GHz signal on recent Merlin builds. If that is true, it leads to the following questions:

    1) Why is this issue present on recent builds of Merlin? (i.e. 380.66_6 and above tested)
    2) Why is the issue NOT present on official Asus firmware?
    3) Why is the issue NOT present on Merlin 380.66_4? (needs to be retested to confirm)
    4) Why does changing from the default setting of 20/40/80 to 40MHz fix the issue?
    5) What do we lose by eliminating 20MHz and 80MHz bands?
    6) What is the root cause of the issue?
    7) How can it be fixed?

    Hoping Merlin can provide some insight here.

    For those of you that provided the tips on what settings to test, thank you! Also, it would be beneficial if you all could revert all but the forced 40MHz setting to rule out the impact of the other settings (Universal Beamforming and forcing a Control Channel).
     
  7. webgrease

    webgrease Occasional Visitor

    Joined:
    Mar 14, 2014
    Messages:
    22
    You've got some variables in play that are relevant to the issue at hand - forcing a Control Channel instead of Auto and completely disabling 2.4GHz (untested on this thread). If you enabled 2.4GHz and changed Control Channel back to the default setting of Auto, it would be interesting to see how long your 5GHz signal is being broadcast.
     
  8. eclp

    eclp Regular Contributor

    Joined:
    May 15, 2016
    Messages:
    128
    I have no dropouts in the 5Ghz (80MHz) band on the AC88U with 380.68_4.
    However, the signal quality in the 2.4Ghz (40MHz) range fluctuates significantly, measured with WifiInfoView, 2.27.
     
  9. martywd

    martywd Occasional Visitor

    Joined:
    Apr 11, 2015
    Messages:
    15
    Location:
    TX
    Just stumbled upon this thread when reading ==> https://www.snbforums.com/threads/w...rks-being-disabled-something-is-broken.41557/

    FWIW, last week and ~12 hours after updating from 380.68_2 to 380.68_4 on my RT-AC88U my 5 Ghz radio started 'dropping out', too.

    At first I figured the upgrade to 380.68_4 was to blame. So I flashed back to 380.68_2. Still the issue persisted with the 5 Ghz radio intermittently 'dropping'. Power down the RT-AC88U, unplugged. Waited. Plugged the router back 'in', power on, after a short time 5 Ghz radio still 'dropping'. At that point I pondered doing a factory reset and starting anew...

    But then as a last resort before doing a 'factory reset'... I clicked on the 5 Ghz Wireless-Professional tab, set the 'Enable Radio' _radio_button_ to 'Off', click 'Apply'. Then reset the 5 Ghz 'Enable Radio' to 'On' and 'Apply' again. Rebooted. After that the 5 Ghz radio seemed stable once again.

    Finallly, flashed again to 380.68_4, reboot once more. As of today, the RT-AC88U has been 'up' now for '3 days 17 hours 55 minute(s)...' with _no_further_issues_ with the 5 Ghz radio (knocking on wood).

    As already typed, fwiw.
    .
     
  10. DAVIZINHO

    DAVIZINHO Occasional Visitor

    Joined:
    Mar 21, 2016
    Messages:
    32
    with this settings i drop de 5ghz again :-(
     
  11. bnhf

    bnhf Regular Contributor

    Joined:
    Aug 11, 2017
    Messages:
    72
    Just thought I'd throw this out there for those of you having problems with 5GHz WiFi:

    Several of us were having very similar problems on the RT-AC66U and RT-AC68U a month or more ago. Like many of you, I was convinced the problem was related to specific versions of AsusWRT-Merlin. I was going back and forth between Asus stock and Merlin, and my testing seemed to point to Merlin firmware. Only 5GHz would drop out, 2.4GHz was always rock-solid.

    Ultimately, however, this turned out to be a power supply problem. The power supply I was using had a slightly loose fitting connector on the router side. Once I switched power supplies, the problem disappeared! Obviously, no guarantee that this is the issue for a few of you on the AC3100 -- but it's certainly worth eliminating as a possibility. I'm attaching a previous thread where you can see this problem was solved for people on the other Asus models I mentioned.

    https://www.snbforums.com/threads/ac66u-5ghz-radio-death.41025/#post-347656
     
  12. DAVIZINHO

    DAVIZINHO Occasional Visitor

    Joined:
    Mar 21, 2016
    Messages:
    32
    not a solution for me. i try today and drops again the 5ghz
     
  13. e38BimmerFN

    e38BimmerFN Senior Member

    Joined:
    May 25, 2012
    Messages:
    354
    Location:
    USA
    Have you gone back to v380.66_4 yet?


     
  14. RedBatman89

    RedBatman89 Regular Contributor

    Joined:
    Oct 25, 2014
    Messages:
    67
    I have noticed that randomly my 5ghz will drop too but only for a few secs.
     
  15. azdps

    azdps Occasional Visitor

    Joined:
    May 26, 2012
    Messages:
    25
    I've had an RT-AC3100 since October 2016 and have been using asuswrt-merlin firmware without any issues. I build my own custom firmware from asuswrt-merlin source code and use the default wireless settings (build 380.66_4). I'm using a cooler with my router which droped my wireless and CPU temperatures considerably. Now it would seem that the issue is possibly RMerlin specific based on what I've read in this thread.

    If you look t the source code changes RMerlin has made between build 380.68_2 and 380.68_4 there's really not much that's changed. Although, I think everyone should be using the 380.68_4 since it includes and updated dnsmasq which patched several exploits.

    Anyways, I think there might be other processes that each of you might be running on whatever RMerlin build you are using that could potentially be causing this 5GHz loss phenomenon. Seems like Asus stock firmware doesn't have the issue. To narrow down the problem you might want to discuss which services you using such as QOS, VPN, Tor, SSH, etc.

    Again, my router is rock solid but also I have eliminated a lot of unnecessary services from my build.
     
    Last edited: Oct 10, 2017
  16. DAVIZINHO

    DAVIZINHO Occasional Visitor

    Joined:
    Mar 21, 2016
    Messages:
    32
    i change to 80mhz yesterday, and its stable. I keep this configuration, and if drops again, i change the firmware to v380.66_4
    Its dificult change the firmware because my wife use the 2.4ghz and i need stay alone at home to make the downgrade :p

    @azdps I only use QOS and SSH, no more services
     
  17. webgrease

    webgrease Occasional Visitor

    Joined:
    Mar 14, 2014
    Messages:
    22
    Up and running now for 51+ hours with no issue. Since this uptime is twice as long as any previous time frame before 5GHz stopped broadcasting, I think I'm going to call it and state that the fix appears to be changing 20/40/80 to 40MHz. This matches the conclusion reached by @ScottW , @JMB64, @herrdude , @bandit8623 , and is one of the variables that fixed it for @Kruegs.

    I didn't see any response to the issue in other threads from @RMerlin , so I'll shoot him a direct message.
     
  18. Kruegs

    Kruegs New Around Here

    Joined:
    Oct 3, 2017
    Messages:
    3
    That's awesome... good work narrowing it down to that specific item. Now the question becomes, why is 40MHz fixed the solution? We'll see if Merlin has any ideas.
     
  19. jim769

    jim769 Very Senior Member

    Joined:
    Jul 18, 2013
    Messages:
    741
    Location:
    USA, Michigan
    Strange i have mine set to 80 mhz and have never had one single issue.
     
  20. webgrease

    webgrease Occasional Visitor

    Joined:
    Mar 14, 2014
    Messages:
    22
    Your signature line indicates you're running the official Asus firmware. Is that the case?
     

Share This Page