ASUS firmware DHCP "Continuous Mode" potential fix for "ISP's DHCP did not function properly"

Frankflash

Senior Member
Hey guys, none of this is new information (although it might be to people reading the DHCP error message red-herring).

I'm pretty sure both asus and merlin know the wanduck code is crap. They don't need me to give them my poor interpretation :)

What I meant by reach out to asus is: If you're experiencing issues with this error message, ask them for support and maybe they'll bother to put some time into fixing the code so it spits out something more informative.
it will get fixed may be in the next century
 

frooty

Regular Contributor
I'm wondering, has anyone tried using the MAC clone feature on the Asus router in an attempt to fix this? I mean, maybe cloning the MAC address of my LTE router (bridge) onto my Asus router would help? I'm just guessing, but would like to know if anyone's tried it yet, as I don't want to do it if it screws up my connection....
 

Vexira

Part of the Furniture
I'm wondering, has anyone tried using the MAC clone feature on the Asus router in an attempt to fix this? I mean, maybe cloning the MAC address of my LTE router (bridge) onto my Asus router would help? I'm just guessing, but would like to know if anyone's tried it yet, as I don't want to do it if it screws up my connection....
I'm using Mac cloning and I've had to switch Mac address bettwen Optus modems to fix at times, doesn't always work.
 

Vexira

Part of the Furniture
So you're cloning the MAC of your Vigor modem to your Asus AX? Is it easy enough to undo?
Optus modem Mac cloning, not my vigor that's in bridge mode or my VoIP ATA won't work if it's an non Optus mac.it fails to register it's a grandstream 812.
 

Icemanz

Occasional Visitor
Can I suggest the config page is not a "90's adventure game", please avoid the voodoo of "rub everything on everything else, with no context, to achieve an outcome".

Messing with TTL or MAC is unlikely to have any relevance here. These are usually to bypass ISP's who want to mandate specific hardware configurations. TTL detection is usually used by dormitories who don't want downstream routers plugged into their network.

MAC cloning is more complex and used in different ways.

The tickbox option in the asus code clones something (I'm unclear if it's pretending to clone the MAC of what it see's on the WAN port or the first client it see's on the LAN port but it doesn't matter).
It's unlikely to help you in this case but it *could* be hurting you. DOCSIS cable modems are often setup with a 'max host' parameter, identified by MAC. If your router is changing it's MAC without the DOCSIS modem getting a reboot, you might get weird behavior or no service without a power cycle.

What it won't do is magically resolve the issue causing the error from the subject of this post. The best advice I can give is - look in your routers log for associated events and work out what else is happening at that time - because the error message seems to be a fallback and may or may not be related to an ISP's DHCP server giving you an IP or not.
Jam the syslog up to level 8 if you have to (it gets noisy).
 

Vexira

Part of the Furniture
I'm wondering when this will make it to GPL I left a comment in whirlpool, since I'm considering testing the firmware.
 

Vexira

Part of the Furniture
So I posted in the Whirlpool thread wating on a response, I seem to be have the error more frequently, bit it's like a micro drop out, I'm still hoping for the fix to be out soon.
 

cplay

Senior Member
Any update?

Currently changing DHCP frequency from aggressive has fixed issue for few days however not holiding out much hope.

Tried using the MAC address of my modem in the mac clone section of wan in asus router however that just kills the connection completely for some reason.
 

Frankflash

Senior Member
So I posted in the Whirlpool thread wating on a response, I seem to be have the error more frequently, bit it's like a micro drop out, I'm still hoping for the fix to be out soon.


Vexira Continuous mode is in the stock firmware for rt88ax 3.0.04 384 8018 spoke to jack on whirlpool forums if you load stock you need to do a factory reset
 

cplay

Senior Member
Vexira Continuous mode is in the stock firmware for rt88ax 3.0.04 384 8018 spoke to jack on whirlpool forums if you load stock you need to do a factory reset

What about ac86u?
 

Frankflash

Senior Member
What about ac86u?


@cplay
The Continuous Mode module should have been included in the latest firmware 3.0.0.4.384.81792:
https://dlcdnets.asus.com/pub/ASUS/...294.89569257.1587338503-1559671859.1586821593
Once updated, please reset to firmware default, configure the router again, then follow the instructions below to switch to Continuous mode:
1. Ensure Telnet function is enabled under your Windows operating system. If you have alternative terminal software that will be OK too.
2. Open up ASUSWRT web GUI, under “Administration – System”, set “Enable Telnet” to “Yes”, the “Apply” to save change.
3. Open up Telnet or your preferred terminal software, telnet into your router, and then issue the following commands to change mode:
nvram set dhcpc_mode=2
nvram commit
reboot
4. Wait for router to reboot.
5. After router boots up, telnet into router again, and check the process status by the command:
ps -w | grep udhcpc
and make sure you can see "-t1 -T5 -A0" in the returned result. The full result should read something like this:
18950 admin 3184 S /sbin/udhcpc -i eth0 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t1 -T5 -A0 -O33 -O249
6. Once all of the above is set, your router should be under “Continuous Mode”.
Please kindly monitor for the next few days and let us know if problem returns.
regards,
Jack Cheng, ASUS Australia
 
Last edited:

cplay

Senior Member
@cplay
The Continuous Mode module should have been included in the latest firmware 3.0.0.4.384.81792:
https://dlcdnets.asus.com/pub/ASUS/...294.89569257.1587338503-1559671859.1586821593
Once updated, please reset to firmware default, configure the router again, then follow the instructions below to switch to Continuous mode:
1. Ensure Telnet function is enabled under your Windows operating system. If you have alternative terminal software that will be OK too.
2. Open up ASUSWRT web GUI, under “Administration – System”, set “Enable Telnet” to “Yes”, the “Apply” to save change.
3. Open up Telnet or your preferred terminal software, telnet into your router, and then issue the following commands to change mode:
nvram set dhcpc_mode=2
nvram commit
reboot
4. Wait for router to reboot.
5. After router boots up, telnet into router again, and check the process status by the command:
ps -w | grep udhcpc
and make sure you can see "-t1 -T5 -A0" in the returned result. The full result should read something like this:
18950 admin 3184 S /sbin/udhcpc -i eth0 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t1 -T5 -A0 -O33 -O249
6. Once all of the above is set, your router should be under “Continuous Mode”.
Please kindly monitor for the next few days and let us know if problem returns.
regards,
Jack Cheng, ASUS Australia

Did doing this fix your issue then?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top