ASUS RT-AC5300

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

cldeal

New Around Here
Has anyone with an Apple TV noticed that if you attempt to AirPlay from an iOS device on a different band than the Apple TV that AirPlay completely fails to work until both devices are on the same exact band? I have an Apple TV 3rd gen., iPad Air 1st gen., and an iPhone 6s Plus. My Apple TV goes to 5GHz-1 (designated for N only clients) as does my iPad Air. My iPhone 6s Plus goes to 5GHz-2 (designated for AC clients). AirPlay through the iPad works just fine while the iPhone doesn't work at all and Airplay just crashes altogether. If the iPad is handed down to 2.4GHz, via Smart Connect, then it ceases to work. Just wondering if anyone has experienced this and, if so, are there any fixes? I'm not turning Smart Connect off, just as a heads up. It's a feature that comes in quite handy for my multitude of N and AC clients and serves my environment well enough for what I need.
No, I haven't noticed this. It's just always worked, but I will admit that I've never paid any attention to which band the respective devices are using when I'm using AirPlay.
 

Puppa

Senior Member
You can override Smart Connect just for your Apple devices by setting up Guest network aliases for each of the bands. (Obviously, this means you need to grant decent network privileges to the guest SSIDS for this to work).

You don't have "AP Isolated" turned on in the Advanced Wireless Professional tab, do you? That could cause problems like you describe as well.

Sent from my SM-N920V using Tapatalk
 

joe012594

Regular Contributor
You can override Smart Connect just for your Apple devices by setting up Guest network aliases for each of the bands. (Obviously, this means you need to grant decent network privileges to the guest SSIDS for this to work).

You don't have "AP Isolated" turned on in the Advanced Wireless Professional tab, do you? That could cause problems like you describe as well.

Sent from my SM-N920V using Tapatalk

I just decided to do a firmware upgrade and full factory reset and it now works perfectly. I have no clue what could've caused the issue, but at least it's fixed some how. :)
 

joe012594

Regular Contributor
Another odd anomaly I'm noticing is that my iPhone 6s Plus (2x2 MIMO device) doesn't go beyond a PHY rate of 433Mbps. It's 866Mbps capable, yet I never see past half of that, as if the router thinks it's only a SISO capable device. I set it right next to the router as well, thinking it could be because of distance, and still nothing. Anyone else noticing the same or similar issue?


RT-AC5300_Clients.PNG
 

passerby

Occasional Visitor
Has anyone with an Apple TV noticed that if you attempt to AirPlay from an iOS device on a different band than the Apple TV that AirPlay completely fails to work until both devices are on the same exact band? I have an Apple TV 3rd gen., iPad Air 1st gen., and an iPhone 6s Plus. My Apple TV goes to 5GHz-1 (designated for N only clients) as does my iPad Air. My iPhone 6s Plus goes to 5GHz-2 (designated for AC clients). AirPlay through the iPad works just fine while the iPhone doesn't work at all and Airplay just crashes altogether. If the iPad is handed down to 2.4GHz, via Smart Connect, then it ceases to work. Just wondering if anyone has experienced this and, if so, are there any fixes? I'm not turning Smart Connect off, just as a heads up. It's a feature that comes in quite handy for my multitude of N and AC clients and serves my environment well enough for what I need.

my AppleTV 3rd Gen doesn't work to connect to SmartNetwork SSID at all. Only to separate networks. Any ideas?
 

madhatter01

Regular Contributor

Good job on the Review.





With the newest firmware (Not Alpha) has anyone else noticed the Gui is laggy? When I first got it, it was very speedy. After this last firmware its slow. I factory set it and still slow. Not at home but the firmware that was released in the last week. It looks like Asus pulled it now.
 

joe012594

Regular Contributor
Good job on the Review.





With the newest firmware (Not Alpha) has anyone else noticed the Gui is laggy? When I first got it, it was very speedy. After this last firmware its slow. I factory set it and still slow. Not at home but the firmware that was released in the last week. It looks like Asus pulled it now.
Can't speak for the latest official release as I'm on the latest alpha release which is, surprisingly, quite stable. Not noticing any lag or glitches over here. Looks like you're right though. They pulled the latest firmware from the support site. Is it just me or is their site really slow right now?
 

Keynote

New Around Here
Good job on the Review.





With the newest firmware (Not Alpha) has anyone else noticed the Gui is laggy? When I first got it, it was very speedy. After this last firmware its slow. I factory set it and still slow. Not at home but the firmware that was released in the last week. It looks like Asus pulled it now.
There is a new firmware update that was posted yesterday.
 

symantec9

New Around Here
What's the fw version?

Tks


Enviado do meu iPhone usando Tapatalk

ASUS RT-AC5300 Firmware version 3.0.0.4.380.1355
Improvements
- Enhanced samba stability
- Improved 2.4Ghz stability

Bug Fixes
- Fixed smart connect phy rate scale issue
- Fixed some UI bugs

About WTFast
- ASUS/WTFast router does in fact come with a free WTFast client. The free router client supports one selectable device.
- This firmware had a bug which shows 0 day on user interface. However, router users can still use it and this bug will be fix in next version firmware.
 

Puppa

Senior Member
Yeah, they pulled it. There must be a good reason. Perhaps too much flack about the UI bug?

Sent from my SM-N920V using Tapatalk
 

passerby

Occasional Visitor
ok. so I wrote a post about my AppleTV couldn't connect with SmartConnect. So I disabled it and connected directly to 5-1 (or 5-2). Worked okay, but then my Samsung TV started to drop the signal a lot. The connection was never more than 400 Mbps and constantly jumping with disconnects.
I flashed the AP with alpha version MU-MIMO, reenabled SmartConnect. TV connected again without issues with 877 Mbps. Rock solid as it was.
AppleTV couldn't connect with Error 5. So I was very stubborn and clicked Retry like 10-12 times and it finally connected! :)
I think AppleTV has lower than usual wait time for DHCP that's why it failed as couldn't get the IP. +SmartConnect adds additional delay. It's the only explanation I have.
Also I have no explanation why SamsungTV works great with SmartConnect and doesn't work without it...

*will flash stable firmware back and check if ATV works with it.

UPD.
reverted to 3.0.0.4.380_838. ATV successfully connected. Interesting...
 
Last edited:

doeboy

Regular Contributor
In the alpha firmware, it supports media bridge and MU-MIMO, so I guess they wouldn't be con's anymore :p

In the review he noted that they had an alpha or beta firmware out that supported it, but also said he doesn't mess around with the alphas or beta FM's lol....
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top