Release ASUS RT-AC68U Firmware version 3.0.0.4.386_48262

DiscoSi

Occasional Visitor
My RT-68U has just updated to 3.0.0.4.386_48262, I spotted the upgrade notification in the web UI. Can't see it live on the Asus website yet though so no info on changes etc at the moment. The numbering has moved on quite a bit though from the last version 46065.
 

DiscoSi

Occasional Visitor
Found the changelog & Direct download:

Version 3.0.0.4.386.48262

2022/03/25 92.71 MBytes

ASUS RT-AC68U Firmware version 3.0.0.4.386.48262
1. Fixed OpenSSL CVE-2022-0778
2. Added more security measures to block malware.
3. Fixed Stored XSS vulnerability. Thanks to Milan Kyselica of IstroSec.
4. Fixed CVE-2022-23970, CVE-2022-23971, CVE-2022-23972, CVE-2022-23973, CVE-2022-CVE-2022-25595, CVE-2022-25596, CVE-2022-25596,
5. Added 3rd party DNS server list in WAN --> DNS to help users enhance the connection security.

 

muddymind

Regular Contributor
I'm happy to report that this FW fixes the LAN speed cut by half when using the AC68U as a AiMesh node as described in this thread.

@RMerlin you should add the binaries from this release to your custom FW since the last Merlin FW still suffers from this issue :)
 

RMerlin

Asuswrt-Merlin dev
@RMerlin you should add the binaries from this release to your custom FW since the last Merlin FW still suffers from this issue
I don't work off firmware binaries, I work off source code.
 

banger

Senior Member
DoT still broken for Tapo Bulbs and Switches via Alexa. Noticed new DNS settings with descriptions which is good. Back to Merlin which DoT and IoT works.
 

VANT

Very Senior Member
DoT still broken for Tapo Bulbs and Switches via Alexa. Noticed new DNS settings with descriptions which is good. Back to Merlin which DoT and IoT works.
not only DoT is broken in this FW
 

muddymind

Regular Contributor
It probably only breaks wireless nodes because I've 5 wired ac68u nodes and I've no issues whatsoever. I always had issues with wireless backhaul with ac68u and switched those for 2 ax92u (one wired and another via wifi ax channel) and I've never had any issues since then.
 

bbunge

Part of the Furniture
DoT still broken for Tapo Bulbs and Switches via Alexa. Noticed new DNS settings with descriptions which is good. Back to Merlin which DoT and IoT works.
A work around for your bulbs is to manually assign an IP address to the bulbs (or problem client) and enter a DNS Server (Optional) setting. This will bypass the router DNS.
 

banger

Senior Member
not only DoT is broken in this FW
I didn't try it long enough to see if the Wireless backhaul was stable gone to merlin's latest which I am now testing.
 

VANT

Very Senior Member
I didn't try it long enough to see if the Wireless backhaul was stable gone to merlin's latest which I am now testing.
Wireless backhaul was stable up to this version. I went back to previous fw, and again work stable.
 

journeyman

New Around Here
After upgrading to this firmware on my RT-AC68U, the front panel LEDs are all off, though the router is working fine. I rebooted and watched the LEDs while it came up and they were on and cycling normally, up until the point the web interface came on-line (end of reboot cycle), at which point the LEDs turned back off. Is anyone else seeing this? Thanks.
 

LimJK

Very Senior Member
After upgrading to this firmware on my RT-AC68U, the front panel LEDs are all off, though the router is working fine. I rebooted and watched the LEDs while it came up and they were on and cycling normally, up until the point the web interface came on-line (end of reboot cycle), at which point the LEDs turned back off. Is anyone else seeing this? Thanks.
Hi, Not sure it is relevant to your case. In an AiMesh setup, there is an option to TURN-OFF LED. The following is a screenshot of the AiMesh setting of my daughter's home with similar Asus Routers as yours. Hope it helps:

Screenshot 2022-03-29 at 09.56.22.png
 

journeyman

New Around Here
Hi, Not sure it is relevant to your case. In an AiMesh setup, there is an option to TURN-OFF LED. The following is a screenshot of the AiMesh setting of my daughter's home with similar Asus Routers as yours. Hope it helps:

View attachment 40440

Thanks so much for pointing this out. I don't use AiMesh and so it never occurred to me to hunt there for an LED setting but, sure enough, it's there. It was set to enable the LEDs already, but toggling it off and then on again did indeed fix the issue and turned the LEDs on. Perfect! Thanks again. :)
 

andyross

Occasional Visitor
I have noticed that since updating from 385 to 386, that the system log shows it doing a firmware update check every day, even though I have it turned off. Even when the latest 386 became available, it didn't actually do anything and said something like no update necessary. I have toggled the auto-update on and back off, but no change.
Is this normal? Did 385 just not log the attempt at a check?
Mar 30 04:31:19 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7669)]do webs_update
Mar 30 04:31:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7687)]retrieve firmware information
Mar 30 04:31:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7702)]fimrware update check first time
Mar 30 04:31:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7733)]no need to upgrade firmware
Mar 30 04:31:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7669)]do webs_update
Mar 30 04:31:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7687)]retrieve firmware information
Mar 30 04:31:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7707)]fimrware update check once
Mar 30 04:32:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7669)]do webs_update
Mar 30 04:32:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7687)]retrieve firmware information
Mar 30 04:32:22 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7707)]fimrware update check once
Mar 30 04:32:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7669)]do webs_update
Mar 30 04:32:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7687)]retrieve firmware information
Mar 30 04:32:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7702)]fimrware update check first time
Mar 30 04:32:52 WATCHDOG: [FAUPGRADE][auto_firmware_check:(7733)]no need to upgrade firmware
 

RMerlin

Asuswrt-Merlin dev
Auto-update is not the same as checking for new firmware. The daily check cannot be disabled. All it does is download a manifest file from their server, check the version associated to your model, and display a webui notification if a newer firmware is available.
 

andyross

Occasional Visitor
I guess it must be a change in 386. The 385 I had either didn't check at all, or was just not logging it.
 

ScooterRS

New Around Here
I'm happy to report that this FW fixes the LAN speed cut by half when using the AC68U as a AiMesh node as described in this thread.

@RMerlin you should add the binaries from this release to your custom FW since the last Merlin FW still suffers from this issue :)
After a Firmware Upgrade from the latest working Merlin Firmware i upgraded to 3.0.0.4.386_48262 and get 980 Mbps but after a factory reset all Problems are back and i only get 485 Mbps. Any ideas whats now wrong?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top