Release ASUS RT-AX89X Firmware Version 3.0.0.4.386.47191 (2022/04/25)

Starrbuck

Senior Member
Version 3.0.0.4.386.47191

2022/04/25 56.84 MBytes

ASUS RT-AX89X Firmware version 3.0.0.4.386.47191
1. Fixed AiMesh issues.
2. Improve system stability.
3. Fixed Guest network related issues.
4. Fixed open VPN related issues.
5. Fixed DDNS related issues.


Please unzip the firmware file first then check the MD5 code.
MD5: 06f266d2147c641a581bbb652a14cb62
 

Starrbuck

Senior Member
Did a dirty upgrade and had an issue with the 5GHz channel setting itself to 120 even though I had 36 selected. I toggled the channel to 153 and back to 36 successfully.
 

slrt

Occasional Visitor
This upgrade finally made DDNS (with Google Domains) stop complaining (it actually worked before as well, but there was a continuous warning that it failed).
 

Starrbuck

Senior Member
Did a dirty upgrade now, i saw a 10% increase in wireless throughput, is it the same for you too?
Personally I am still zeroing-in on a configuration I like (Smart Connect off, best channels to use, etc.) so it's hard for me to say. Definitely not any worse.
 

Yakkosmurf

Occasional Visitor
I haven't noticed a wifi speed difference. But, I have noticed more wireless devices hanging on to the 89X rather than handing off to one of the AI-Mesh nodes. The Roomba is the easiest example.
 

lishan89

Occasional Visitor
oh NO!!! This miniupnpd issue is back... the temporary fix is to turn off and on upnp.

Code:
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
 

slrt

Occasional Visitor
oh NO!!! This miniupnpd issue is back... the temporary fix is to turn off and on upnp.

Code:
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
May 19 09:04:43 miniupnpd[3378]: accept(http): Too many open files
A better option is to just disable it altogether. UPnP is a terrible idea.
 

lishan89

Occasional Visitor
A better option is to just disable it altogether. UPnP is a terrible idea.
If I had a choice I would but HomeKit devices rely on it. Especially ecobee. :( However this is strange after a restart it seems the problem has not re-occur. this might have just been a dirty update. I will update if this continues.
 

Starrbuck

Senior Member
If I had a choice I would but HomeKit devices rely on it. Especially ecobee. :(
Hmm, I have two ecobee thermostats and I haven't noticed any issues with UPnP off.
 

lishan89

Occasional Visitor
Hmm, I have two ecobee thermostats and I haven't noticed any issues with UPnP off.
That is strange, turning off upnp, normally cause issues for me after 1 or 2 days. The Homekit app will keep saying the device is unavailable until I open the thermostat then after a while and with a bit of luck it responds. However with upnp on it always works. Also eufy cameras have a similar issue but with eufy cameras their issue is that they don't reconnect. If they loose connection and go offline even after coming back online in the eufy app they do not show as available on apple home app, until I manually restart the camera through the app or physically unplug them and replug. again with upnp they just start working without all this trouble. With that said I have not tried turning off upnp for prolong periods of time in this firmware version. I will give that a try.
 

majika

New Around Here
Ordered an Asus RT-AX89X Arriving tomorrow, Will be participating in testing firmware. I hope Merlin will offer support for this device, on paper this thing is a beast & perfect fit for my home 10G network
 

Tech9

Part of the Furniture

Tech9

Part of the Furniture
No idea, sorry. @RMerlin may know the details.
 

RMerlin

Asuswrt-Merlin dev
Broadcom BCM4912 CPU. Don't know what the wifi or switch chips are.
 

lishan89

Occasional Visitor
In this most recent firmware with the rt-ax89x, I have found that my IOT device keep malfunctions if they are connected to the ax89x node in aimesh. My work around has been to move all devices that malfunction to my gt-AC5300. I check the rt-ax89x logs and did not find anything during the disconnects.
Devices that stop working but are still connected includes: wemo switches, airprint through brother printer, Shark robot vacuums, and eufy camera.

My set up is as follows
Code:
RP-AC1900===RT-AX89X===GT-AC5300
               ||
              Modem
if anyone has similar issues please let me know
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top