What's new

ASUS ZenWiFi AX (XT8) mesh network doesn't work with Arlo doorbell

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

I have an Arlo Video Doorbell (Wire-Free) connected to Arlo Smart Hub (base station). The issue comes up when my iPhone is connected to ASUS ZenWiFi AX (XT8) Ai Mesh node and someone rings the bell and I receive the Arlo call on my phone. When I answer the call, I can hear live audio but I am unable to see live video. When I'm connected to the Asus ASUS ZenWiFi AX main node/router it works perfectly. Could it be related to how mesh network communicate with the node?

My setup:

- 1 Arlo Video Doorbell connected via Arlo Hub
- Asus Zenwifi AX XT8 Mesh
- iPhone 15 Pro
- All firmware and software updated to latest version, including router
- Full WiFi-signal in the Arlo Hub app and for the video doorbell.

Troubleshooting so far:

- Removed and reinstalled the doorbell in Arlo app
- Hard reset of Arlo doorbell
- Lowered video quality
- Allowed location to be always used by Arlo app
- Moved the Arlo Hub from 5 meter to 1 meter to the doorbell.
- Tried to connect doorbell via Wifi instead of hub, but have been unsuccessful after multiple tries
- Tried to connect (wired) the Smart Hub to the Asus main router instead of the mesh note.
Are you using smart connect? I had that doorbell prior to my ring doorbell and what I did was use smart connect and then bound that doorbell to my nearest XT8 and I didn’t have any issues doing it that way.
Yes, I've tried that. I also tried to setup a guest network 2,4 ghz. It works as long as I'm connected to the main node/router.
- Tried to connect doorbell via Wifi instead of hub, but have been unsuccessful after multiple tries

Maybe this suggests a conflict with router Wireless settings, or some firmware or hardware defect... since this should work, right?... why doesn't it connect to WiFi as designed?

It connects do WiFi too but same problem for WiGi (no video, when I'm on the mesh node). I found it a bit more stable when having it connected to Smart Hub.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!