Beta Asuswrt-Merlin 386.7 Beta is now available

Status
Not open for further replies.

RMerlin

Asuswrt-Merlin dev
Asuswrt-Merlin 386.7 Beta is now available for all supported models. This release focuses on GPL merges and component updates.

June 17th: Beta 2 has now been uploaded. Make sure you read the following note!
Changes since beta 1:
Code:
89778ae369 Updated documentation
5e7fd8632e rc: fix re-enabling wifi LEDs on the RT-AX86S
8fe761e94a HND5.02L07p2: replace dhd with build without debug enabled for RT-AX86U and GT-AXE11000
3605922c04 webui: change notification message shown if trying to enable AuraRGB while LEDs are disabled
0a54a8cf57 rc: don't re-enable AuraRGB when toggling LED stealth mode if it was previously disabled; remove dead code from setup_leds()
626bf4f117 HND5.02L07p2: fix mtd partition layout
45f552f233 httpd: fix wireless client log issue with guests (issue introduced with 67be92ce6b)
e8e525fd13 Bump version to beta 2


The highlights:
  • Merged with GPL 386_49335 (for the RT-AC5300) and 386_48966 (for all other models).
  • DNSFilter can now also intercept and redirect IPv6 DNS queries on HND models. You can also specify IPv6 DNS servers for the three custom settings.
  • Component updates: openssl 1.1.1o, haveged 1.9.18, openvpn 2.5.7 and tor 0.4.7.7.
  • Fixed CVE-2022-0934 and CVE-2022-26376.
  • And a few other fixes

Also for those not using a GT-AX6000 or XT12, this also includes the changes from 386.6, such as the improved IPv6 support for OpenVPN servers. Please review the 386.6 changelog for mode details.

Things in particular need of testing in this release:
  • DNSFilter and IPv6 support (also ensure no regression on older models)
  • IPv6 support with the OpenVPN server

Please keep the discussion on this particular release. Off-topic posts will be moved, deleted or ignored depending on my mood at the time.

Downloads are here.
Changelog is here.
 
Last edited:

RMerlin

Asuswrt-Merlin dev
Known issues:
  • JFFS partition getting corrupted or failing to mount on RT-AX86U, RT-AX68U, GT-AXE11000 and possibly RT-AC68U_V4 (flash partition layout issue, fixed in beta 2 - see this note)
  • Wireless console logging enabled on RT-AX86U and GT-AX11000 (obtained non-debug versions from Asus, fixed in beta 2)
  • Guest clients may show the wrong IP (Fixed in beta 2)
 
Last edited:

John Fitzgerald

Senior Member
Flash went well on AX86U. Did not have the JFFS issue.

Thank you.


EDIT: This was a dirty flash over the Alpha. When I first reported the JFFS issue in the Alpha thread and had to restore the JFFS from backup. This time it was clean.
 
Last edited:

heslo

Regular Contributor
Flashing soon, will report back. Thank you RMerlin!

EDIT: Successfully flashed my AX88U and AX58U with absolutely zero issues; was running alpha1 before this
 
Last edited:

Paul Smedley

Occasional Visitor
1x AX68U and 3xAX58U (1 via VPN) flashed fine. 1xAX56U (via VPN)is getting stuck at 'Please wait, Applying Settings..." that one might need to wait until I'm onsite.

edit: literally as I posted, the RT-AX56U decided to play nicely :)
 

LimJK

Very Senior Member
Hi, Just like to report that I have successfully flashed 386.7_beta1 (GPL:386_48966) over 386.7_alpha1 for my AiMesh setup:
  • AiMesh Router: AX88U 386.7_beta1
  • 2 x AiMesh Nodes: AX86S 386.7_beta1, AC86U 386.7_beta1
Thanks!
 

octopus

Part of the Furniture
I have update my two routers (RT-AX86U and RT-AX58U) to BETA 1 and all went fine.

I hope logs "kernel: CONSOLE:" can be removed, it's really spaming log.

Thank you!
 

FLA_NL

Regular Contributor
Updated (Dirty) my RT-AX86U from 386.5_2 to 386.7_beta1. Don't notice any errors. jffs seems also fine.
 
Last edited:

Ayitaka

Occasional Visitor
Dirty upgrade, 386.5_2 to 386.7_beta1 on AX86U
  • jffs unmounted, had to reformat and restore backup
  • web UI now showing all left-side navigation sub-links underneath the categories (did not do this until I reformatted and restored jffs)


386.7_beta1.png
 
Last edited:

octopus

Part of the Furniture
Dirty upgrade, 386.5_2 to 386.7_beta1 on AX86U
  • jffs unmounted, had to reformat and restore backup
  • web UI now showing all left-side navigation sub-links underneath the categories (did not do this until I reformatted and restored jffs)
I will be doing a fresh, full L&D reinstall this weekend.

View attachment 41735
Try first: Ctrl-F5 in eg Firefox.
 

RMerlin

Asuswrt-Merlin dev
Dirty upgrade, 386.5_2 to 386.7_beta1 on AX86U
  • jffs unmounted, had to reformat and restore backup
  • web UI now showing all left-side navigation sub-links underneath the categories (did not do this until I reformatted and restored jffs)
Please post the boot log from when it booted without the JFFS partition mounting.
 

underdose

Regular Contributor
Dirty upgrade from alpha to beta 1 without any errors on RT-AX58U.
 

GoNz0

Very Senior Member
Tried a dirty upgrade and lost JFFS, things spiraled downhill from there, backups wouldn't play ball etc.

Given up and will put everything back manually.
 
Last edited:

FLA_NL

Regular Contributor
@RMerlin, the change log link in the first post doesn't have the changes of this release. The one in git is up to date. Maybe the wrong link?
 

kernol

Very Senior Member
I have update my two routers (RT-AX86U and RT-AX58U) to BETA 1 and all went fine.
I hope logs "kernel: CONSOLE:" can be removed, it's really spaming log.

Dirty upgrade, 386.5_2 to 386.7_beta1 on AX86U (x 2) and on AC5300 - see signature for details and add-ons ... all of which are fully functional.
Just echoing @octopus wish for the "kernel: CONSOLE:" log entries to stop spamming log when the final firmware version is released.

I have SO enjoyed the much cleaner logs on firmware 386.5_2 :D. - MANY thanks @RMerlin .
 

GoNz0

Very Senior Member
On the main page DDNS isn't showing as connected but on the DDNS page is shows registered when you click apply. AX86 router, clean install with manual setup.

I had to reboot the router and now have the padlock and DDNS is working, the homepage still shows GO instead of my domain.
2022-06-11-(1).jpg
 
Last edited:

hancox

Regular Contributor
Please post the boot log from when it booted without the JFFS partition mounting.
Sorry, I reformatted prior to thinking about it, but from the syslog:

May 5 01:05:13 kernel: random: init urandom read with 12 bits of entropy available
May 5 01:05:13 kernel: proc_dostring_crashlogsave: crash log filename is /jffs/crashlog.log
May 5 01:05:13 kernel: crashFileSet: Failed to get mtd !
May 5 01:05:13 kernel: ++++ Powering up USB blocks
May 5 01:05:13 kernel: hub 1-0:1.0: config failed, hub doesn't have any ports! (err -19)
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top