Custom firmware build for R7800 v. 1.0.2.59SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Part of the Furniture
Continuation of

https://www.snbforums.com/threads/custom-firmware-build-for-r7800.36859/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-22sf.37222/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-23sf-v-1-0-2-24sf.37477/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-25sf-v-1-0-2-29sf.38032/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-30sf.38366/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-31sf.39142/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-32sf.39657/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-33sf.40198/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-34sf.40523/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-35sf.40794/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-36sf.41166/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-37sf.41317/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-38sf.41751/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-39sf.41945/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-40sf-1-0-2-41sf.42222/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-43sf.42683/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-44sf.42882/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-45sf.43853/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-47sf.44781/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-49sf.45296/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-50sf.45812/
https://www.snbforums.com/threads/c...800-v-1-0-2-53sf-1-0-2-53sf-kf-updated.46941/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-54sf.47947/

New version of my custom firmware build: 1.0.2.59SF.

Changes (vs 1.0.2.54SF):

1. Integration of changes from the stock v. 1.0.2.58.
2. OpenSSL is upgraded 1.0.2o->1.0.2p (CVE-2018-0732, CVE-2018-0737).
3. dnsmasq: dnsmasq.conf options optimized.
4. ntpclient: init script is changed (automatization of setting date for OpenVPN client).
5. dbus package is upgraded 1.12.8->1.12.10.
6. ubus package is upgraded 2018-01-16->2018-07-26.
7. libubox package is upgraded 2018-06-07->2018-07-25.
8. uci package is upgraded 2018-03-24->2018-08-11.
9. e2fsprogs package is upgraded 1.43.9->1.44.4.
10. util-linux package is upgraded 2.32->2.32.1.
11. ffmpeg package is upgraded 3.2.10->3.2.12.
12. libgpg-error package is upgraded 1.27->1.32
13. Firewall: user can keep own iptables seetings in /opt/scripts/firewall-start.sh
14. /sbin/cloud Changes of PATH.
15. Temporary fix for NG's bug (Attached Device List) is removerd (is working now).
16. /etc/profile default profile is changed (no PATH for /opt/bin:/opr/sbin). Entware users should set the PATH for Entware in /root/.profile file.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

NOTE 1: Most probably no reset is needed to upgrade from my previous versions. But if you face problems it is better to perform reset.

NOTE 2: Info for Entware users. /etc/profile default profile is changed (no PATH for Entware is set by default, i.e. /opt/bin:/opr/sbin). Set the PATH for Entware in /root/.profile file, something like:

Code:
export PATH=/opt/bin:/opt/sbin:/bin:/sbin:/usr/bin:/usr/sbin


Voxel.
 

gobble

Occasional Visitor
For those of us running the Kamoj debug page, does that continue to work or are there any extra steps?
 

Voxel

Part of the Furniture
For those of us running the Kamoj debug page, does that continue to work or are there any extra steps?
Kamoj debug page should be installed anew. No any extra steps. To say true, no so many differences stock 1.0.2.52 vs stock 1.0.2.58. Valuable are fixing NG's bug (Attached Device List) and fixing NG's bug in traffic meter.

P.S.
DNSCrypt-Proxy-2: the same remark as above.

Voxel.
 

det721

Part of the Furniture
@Voxel. Thanks for the very fast compile. Just flashed from 54 to 59 did a factory reset as i always like to do after a flash. Working good. Again Thanks for your time and effort and to all that contributed. :);):D It's much appreciated !!
 

Restalfep

Occasional Visitor
Thanks for the great works as always. After updating from .54sf to latest .59sf my 5g started acting up. It wouldn’t work at all on some channels and others it would work but then disconnect. Only happened on 5G. Did everything but a factory reboot since didn’t want to lose settings yet. Nothing helped except downgrading back to your .54sf. Any idea why this could happen? Thanks!


Sent from my iPhone using Tapatalk
 

det721

Part of the Furniture
Been using the new 59 all night and i am having no issues so far. All i use is 5Ghz and all my devices are working great.
 

Restalfep

Occasional Visitor
Been using the new 59 all night and i am having no issues so far. All i use is 5Ghz and all my devices are working great.

Damn. Must be on my side then. Makes it even harder to figure out why just on that version. Maybe I’ll try upgrading again and doing factory reset after for config.


Sent from my iPhone using Tapatalk
 

det721

Part of the Furniture
Yes try a factory reset. I did that after the flash. Please keep us posted on what you find. Sure hope there are no strange issues with this new release.
 

Restalfep

Occasional Visitor
Will do. I'll try to find a time (most likely tomorrow afternoon) when no one is home so everyone isn't yelling at me when the internet goes off during the testing haha. I'll report back once I do so...
 

Voxel

Part of the Furniture
It wouldn’t work at all on some channels and others it would work but then disconnect. Only happened on 5G.
Well, it is strange. No changes in QCA drivers 1.0.2.54SF vs 1.0.2.59SF (i.e. 1.0.2.52 stock vs 1.0.2.58 stock). Really, try to perform reset. For me it is working two days w/o dropouts.

There are some changes in 5GHz in 1.0.2.58 (included into my version too):

https://kb.netgear.com/000059692/R7800-Firmware-Version-1-0-2-58

  • Removes support for channels 132, 136, and 140 in 5G_HT80 mode to meet regularity.

so maybe it has a sense for you to change the channel you use.

Voxel.
 

davidm71

Occasional Visitor
On this firmware version my 5 Ghz signal strength is coming in strong but my 2.4G is a little week and disconnects. Still need to try other channels maybe.
 

Voxel

Part of the Furniture
On this firmware version my 5 Ghz signal strength is coming in strong but my 2.4G is a little week and disconnects. Still need to try other channels maybe.

As I answered in myopenrouter:


I do not think that level of signal was changed in the stock 1.0.2.58 (I use its changes in my 59SF version). The same QCA drivers. So the level of 2.4 and 5GHz signal should be the same.


So I rather agree with your supposition:

I actually did end up posting there. I'm sure its a channel interference issue. Just have to find a clean channel to use.

Voxel.
 

davidm71

Occasional Visitor
As I answered in myopenrouter:


I do not think that level of signal was changed in the stock 1.0.2.58 (I use its changes in my 59SF version). The same QCA drivers. So the level of 2.4 and 5GHz signal should be the same.


So I rather agree with your supposition:

I actually did end up posting there. I'm sure its a channel interference issue. Just have to find a clean channel to use.

Voxel.

Well I finally found a better channel to use. It took a few tries to find one.

Anyhow was wondering if you could take the 2.4 ghz QCA driver from the XR500 and incorporate it in your next release as a beta? I think it has a better 2.4 ghz driver...

Thanks.
 

Voxel

Part of the Furniture
Anyhow was wondering if you could take the 2.4 ghz QCA driver from the XR500 and incorporate it in your next release as a beta? I think it has a better 2.4 ghz driver...
Why do you think that drivers from XR500 are better than drivers from R7800? Latest stock firmware for XR500 was compiled in June, 7th. For R7800 in July, 17.

I do not think that:

1. QCA drivers in XR500 are really better than QCA drivers in R7800.
2. It is legal to use the drivers from XR500 in the firmware for R7800.

Voxel.
 

davidm71

Occasional Visitor
Why do you think that drivers from XR500 are better than drivers from R7800? Latest stock firmware for XR500 was compiled in June, 7th. For R7800 in July, 17.

I do not think that:

1. QCA drivers in XR500 are really better than QCA drivers in R7800.
2. It is legal to use the drivers from XR500 in the firmware for R7800.

Voxel.

I have heard reports of better signal strength. Did not know borrowing a driver breaks intellectual property laws.
 

avtella

Very Senior Member
I have heard reports of better signal strength. Did not know borrowing a driver breaks intellectual property laws.


If anything reviews I have seen showed the XR500 having worse 5Ghz performance and slightly better 2.4 GHz performance than the R7800 and that is probably due to just minor differences in board layout and not the drivers.
 

davidm71

Occasional Visitor
If anything reviews I have seen showed the XR500 having worse 5Ghz performance and slightly better 2.4 GHz performance than the R7800 and that is probably due to just minor differences in board layout and not the drivers.

Well that tracks with my experience. The 5ghz signal strength on Voxels firmware feels stronger than what I was on before (cough).. but the 2.4 ghz is a little weaker..
 

bzq2810

New Around Here
Thanks for the hard work.
I found that the device types are wrongly shown in network map in Netgear Genie app on iOS compared by the ones in the web GUI. I noticed that the index difference between the above-mentioned two places is always 1 for all the devices. I haven't tested this in the stock firmware.

bzq2810
 

Paul Smith

Occasional Visitor
Voxel. Many thanks for the firmware. Installed for the first time yesterday and everything seems good.

I managed to get the OpenVPN working as per your readme. I am a bit rusty but managed to get my NordVPN OPVN file working in the end. Just need to mess around to get a decent speed now. Hitting around 50 Mbps when on the router and 100Mbps via my laptop so definately room to improve.

Keep up the good work
 

davidm71

Occasional Visitor
Voxel. Many thanks for the firmware. Installed for the first time yesterday and everything seems good.

I managed to get the OpenVPN working as per your readme. I am a bit rusty but managed to get my NordVPN OPVN file working in the end. Just need to mess around to get a decent speed now. Hitting around 50 Mbps when on the router and 100Mbps via my laptop so definately room to improve.

Keep up the good work

Paul,

Can you please detail how you create a password file for NordVpn? I also am using Nordvpn and only loose like 5% download speed when using their vpn connection app. Have you tried DDWrt?

Thanks
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top