What's new

DDNS does not update dyndns.org when WAN IP changes

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

jbodnar

New Around Here
I have an RT-AX88U Pro with v3004.388.4, Previously I had cable internet service with an ARRIS Surfboard cable modem/router. With that device, whenever my IP address changed the device was able to automatically update my IP address with dyndns.org. I had the RT-AX88U running just as a wifi router.

I recently switched to Google Fiber, ditched the Surfboard and have the Asus as the main router for my home network. I've configured it with my dyndns.org credentials and after the initial configuration dyndns.org had my correct IP address. But ever since, every time my IP changes or if I force an update, the logs show no errors but my IP address doesn't change with dyndns.org. I contacted dyndns.org support and they are unable to help saying the issue is with my dyndns client.

My settings:

1699764109643.png


And the logs from a forced update:


Code:
Nov 11 22:30:28 rc_service: httpd 17832:notify_rc restart_ddns_le
Nov 11 22:30:28 ddns: update WWW.DYNDNS.ORG default@dyndns.org, wan_unit 0
Nov 11 22:30:28 ddns: Clear ddns cache.
Nov 11 22:30:28 ddns: Start Inadyn(10).
Nov 11 22:30:28 inadyn[18448]: In-a-dyn version 2.10.0 -- Dynamic DNS update client.
Nov 11 22:30:28 inadyn[18448]: Update forced for alias jbodnar.dyndns.org, new IP# 136.62.143.228
Nov 11 22:30:29 inadyn[18448]: Updating cache for jbodnar.dyndns.org
Nov 11 22:31:40 rc_service: httpd 17832:notify_rc start_sig_check

Reading through some other threads from users with similar issues I saw one person suggest turning off IPv6 but I've never had that configured.
 
I ran an nslookup on jbodnar.dyndns.org and it gives me an IP address of 136.62.143.228

I presume that’s not what your present IP address is?
 
Enable WAN IP and Hostname Verification.
 
Change the 'Forced update interval', to 1 day.
 
Change the 'Forced update interval', to 1 day.
Don't think that DDNS service setting has the forced interval setting. It does have the WAN IP and Hostname Verification.
 
Is it not right there in the screenshot in post 1 above?
 
I ran an nslookup on jbodnar.dyndns.org and it gives me an IP address of 136.62.143.228

I presume that’s not what your present IP address is?

That is my present IP address but the only reason your nslookup returned that is because I manually set my IP address on dyndns.org.
 
Enable WAN IP and Hostname Verification.

Does that force the router to check the IP address of the hostname every X minutes? If so, I don't think that's going to fix my problem. The problem seems to be that whatever the router is running to send the IP address to dyndns.org isn't working. I just manually set the IP address of jbodnar.dyndns.org to 136.62.143.111 and forced the router to do a DDNS update:

Code:
Nov 12 22:44:19 rc_service: httpd 17832:notify_rc restart_ddns_le
Nov 12 22:44:20 ddns: update WWW.DYNDNS.ORG default@dyndns.org, wan_unit 0
Nov 12 22:44:20 ddns: Clear ddns cache.
Nov 12 22:44:20 ddns: Start Inadyn(10).
Nov 12 22:44:20 inadyn[24539]: In-a-dyn version 2.10.0 -- Dynamic DNS update client.
Nov 12 22:44:20 inadyn[24539]: Update forced for alias jbodnar.dyndns.org, new IP# 136.62.143.228
Nov 12 22:44:20 inadyn[24539]: Updating cache for jbodnar.dyndns.org

but jbodnar.dyndns.org still resolves to 136.62.143.111 and dyndns.org shows the last update was on Nov. 12, 2023 10:43 PM (before the forced update by the router).

The problem seems to be with the code/script the router uses to send the update to dyndns.org.
 
I guess this is a problem with inadyn. If I clear the inadyn cache and run it from the command line of the router:


Code:
# inadyn -l debug --foreground --force
inadyn[26792]: In-a-dyn version 2.10.0 -- Dynamic DNS update client.
inadyn[26792]: Resolving hostname jbodnar.dyndns.org => IP# 136.62.143.111
inadyn[26792]: Get address for default@dyndns.org
inadyn[26792]: Checking for IP# change, querying interface eth0
inadyn[26792]: Checking IPv4 address 136.62.143.228 ...
inadyn[26792]: IPv4 address 136.62.143.228 is valid.
inadyn[26792]: Checking IPv4 address 136.62.143.228 ...
inadyn[26792]: IPv4 address 136.62.143.228 is valid.
inadyn[26792]: Current IP# 136.62.143.228 at default@dyndns.org
inadyn[26792]: Update forced for alias jbodnar.dyndns.org, new IP# 136.62.143.228
inadyn[26792]: Sending IP# update to DDNS server, connecting to members.dyndns.org([147.154.111.115]:443)
inadyn[26792]: Sending IP# update to DDNS server, initiating HTTPS ...
inadyn[26792]: SSL connection using TLS_AES_256_GCM_SHA384
inadyn[26792]: Certificate OK
inadyn[26792]: SSL server cert subject: /C=US/ST=California/L=Redwood City/O=Oracle Corporation/CN=members.dyndns.org
inadyn[26792]: SSL server cert issuer: /C=US/O=DigiCert Inc/CN=DigiCert TLS RSA SHA256 2020 CA1
inadyn[26792]: Sending alias table update to DDNS server: GET /nic/update?hostname=jbodnar.dyndns.org&myip=136.62.143.228 HTTP/1.0
Host: members.dyndns.org
Authorization: Basic amJvZG5hcjpmaW5hbGlzdA==
User-Agent: inadyn/2.10.0 https://github.com/troglobit/inadyn/issues

inadyn[26792]: Successfully sent HTTPS request!
inadyn[26792]: Successfully received HTTPS response (215/8191 bytes)!
inadyn[26792]: DDNS server response: HTTP/1.1 503 Service Unavailable
Date: Mon, 13 Nov 2023 05:00:37 GMT
Server: Apache
Strict-Transport-Security: max-age=31536000
X-UpdateCode: R
Content-Length: 6
X-User-Status: vip
Connection: close

dnserr
inadyn[26792]: Temporary error in DDNS server response:
inadyn[26792]: [503 Service Unavailable] dnserr
inadyn[26792]: Will retry again, rc=49
inadyn[26792]: Error code 49: DDNS server busy, try later
 
Is it not right there in the screenshot in post 1 above?
Yes, but it is not there in recent Asus firmware.
 
I don't know about recent Asus firmware, but I see it on my RT-AX86U on RMerlin 388.5 Alpha 1.
 
Found the issue. Dyndns has a "host updater key" (that I don't ever remember generating) and that needs to be used instead of the password associated with my account. Replacing the password with the key on the router DDNS settings resulted in a successful update.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top