dnsmasq-dhcp:not giving name to the DHCP lease because the name exists in /etc/host s.dnsmasq with address

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Khadanja

Regular Contributor
Nov 7 19:51:25 dnsmasq-dhcp[1165]: not giving name iPhoneS to the DHCP lease of 192.168.1.22 because the name exists in /etc/host s.dnsmasq with address 192.168.1.4
Why did the router assign .22 to iPhone? Shouldn't it always assign .4?
 
D

Deleted member 51572

Guest
my guess: your "iPhoneS" was initially connected with IP 192.168.1.4 and then, at some point, updated itself to iOS 14.x, and reconnected with a brand new Private MAC Address, thus a new IP address as well, hence the log entry: not giving NAME 'iPhoneS' to 192.168.1.22, because that network name is already in use by 192.168.1.4.

to resolve this, simply disable Private Address on your iPhone and reconnect with its real-hardware MAC address.

to disable Private Address for a particular network in iOS:
Settings > Wi-Fi > Your WiFi Network > Info > Private Address, move the slider to OFF
 
Last edited by a moderator:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top