1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

DNSMasq not working properly

Discussion in 'Asuswrt-Merlin' started by Kian, Feb 24, 2018.

  1. Kian

    Kian Occasional Visitor

    Joined:
    Feb 22, 2018
    Messages:
    19
    So I am using a Pi-Hole device with my Asus Router to block ads network wide.

    I also use a VPN on my Asus router with Selective Routing so that only my NAS uses the VPN.

    When my NAS is connected via VPN from router, certain apps on the device will not function because Pi-Hole will prevent DNS resolutions from occuring on them. Not with every app, just a few. And I had this problem before on my Tomato/Netgear router I had previously.

    My solution for the previous router was to add a dnsmasq entry to the router to bypass the pi-hole and set the NAS' DNS to 8.8.8.8(Google).

    This solution, no matter how I do it, will not work on the ASUS router.

    I have tried both:

    Code:
    dhcp-option=6,192.168.1.67
    
    dhcp-option=tag:mydns,option:dns-server,8.8.8.8
    
    dhcp-host=XX:XX:XX:XX:XX:XX,set:mydns

    and

    Code:
    dhcp-option=6,192.168.1.67
    
    # Google DNS
    
    dhcp-option=tag:googlesdns1,6,8.8.8.8
    
    dhcp-option=tag:googlesdns2,6,8.8.4.4
    
    # NAS set to Google DNS
    
    dhcp-host=XX:XX:XX:XX:XX:XX,set:googledns1
    as my dnsmasq.conf.add file in the /jffs/configs directory.

    Upon rebooting router and pi hole, the NAS would still not function properly. Certain apps couldnt resolve DNS resolutions.

    Ive tried changing my WAN DNS from my VPN providers DNS entries to Google's and it made no difference for the NAS.

    I've tried adding the Pi Hole IP as the LAN DNS server in ASUS router along with changing Pi Hole settings for this to work and it made no difference for the NAS.

    I've tried the DNSFilter section, adding a Customer DNS of Google for the NAS. No difference.

    I even tried adding a dnsmasq entry to the pi-hole device itself. No difference.

    I've triple checked x 1000 the MAC address is correct.

    Nothing works. I am at my wits end because this worked perfectly on my Tomato router.
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Kian

    Kian Occasional Visitor

    Joined:
    Feb 22, 2018
    Messages:
    19
    I'm a real dumby. The problem seemed to have been that my VPN was disconnected. Man oh man.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!