1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

lack of name resolution when using OpenVPN server

Discussion in 'Asuswrt-Merlin' started by Revelstone77, Jan 29, 2018.

  1. Revelstone77

    Revelstone77 Regular Contributor

    Joined:
    Sep 10, 2014
    Messages:
    61
    im using an AC86U running Merlins 382 code, but I've had this issue for quite a while. All windows network and when i travel i VPN into the home network but i cant connect to anything by name. works fine if i use the ip address. im usually using RDP to connect to another pc on the network. i end up needing to go into the the router, looking the client list to get the ip, then using RDP. not a deal breaker but would prefer to do it by name. its probably just a setting I'm missing but not sure what. I'm hoping someone has an idea.

    thanks,
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. martinr

    martinr Very Senior Member

    Joined:
    Nov 27, 2014
    Messages:
    1,202
    Location:
    United Kingdom
  4. martinr

    martinr Very Senior Member

    Joined:
    Nov 27, 2014
    Messages:
    1,202
    Location:
    United Kingdom
    Never tried it before but it works for me. I have a Humax Foxsat on my LAN and I remotely entered http://foxsat into my browser and got the DVR’s webui.

    In the Advanced VPN server settings, are the block of 4 starting with Push LAN to clients all set to Yes?
     
  5. Wingsfan87

    Wingsfan87 Regular Contributor

    Joined:
    Sep 18, 2015
    Messages:
    94
    Location:
    Michigan
    I got this working on my site to site VPN. 5 things you need to do

    1. Enable the WINS server that Merlin added under the USB Application tab and also set as master browser (you only need 1 WINS server as master browser)
    2. Under LAN set a custom domain such as local.lan
    3. In your OpenVPN server you only need the GUI option selected for Client will use VPN to access Local network only *NOTE* you do not need to select push DNS or respond to DNS.
    4. In the Open VPN Advanced Settings > custom server config box you need to add these two lines
      1. push "dhcp-option WINS XXX.XXX.XXX.X"
        push "dhcp-option DOMAIN-SEARCH local.lan"
    5. On the client side enable accept DNS configuration to Strict.
     
  6. Revelstone77

    Revelstone77 Regular Contributor

    Joined:
    Sep 10, 2014
    Messages:
    61
    sure do.
    thanks, all four are set to yes
     
  7. Revelstone77

    Revelstone77 Regular Contributor

    Joined:
    Sep 10, 2014
    Messages:
    61
    question, under Lan, I'm not seeing anywhere to set a custom domain unless under DHCP server you are referring to RT-AC86U's Domain name?
     
  8. Wingsfan87

    Wingsfan87 Regular Contributor

    Joined:
    Sep 18, 2015
    Messages:
    94
    Location:
    Michigan
    Correct.
     
  9. Bruce_H

    Bruce_H Occasional Visitor

    Joined:
    Mar 4, 2017
    Messages:
    13
    Location:
    Ontario, Canada
    I don't see an option under USB applications for a WINS Server, I am running 384.5 on an RT-AC68U. Am I missing something or is it not available in this version of the firmware
     
  10. Bruce_H

    Bruce_H Occasional Visitor

    Joined:
    Mar 4, 2017
    Messages:
    13
    Location:
    Ontario, Canada
    Did some more searching and found it USB Application > Media Services and Servers > Network Place (Samba) Share / Cloud Disk
     
  11. Bruce_H

    Bruce_H Occasional Visitor

    Joined:
    Mar 4, 2017
    Messages:
    13
    Location:
    Ontario, Canada
    I have two RT-AC68U routers on two different sub-nets; one is set as an Openvpn server and the others is the Openvpn client, I can ping any device from either end and get a response, so routing is working bi-bidirectionally. From the client to the server I can also ping any device on the server end by DNS name, but I can not get DNS name resolution to work from the server back to the client router. I currently do not have wins running on either router as it is my understanding the Windows 10 1803 no longer uses wins for network discovery. Anyone got any suggestions on how I can get DNS resolution to work from the Openvpn server back to the Openvpn client router so that I have bidirectional DNS name resolution.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!