Problem with Merlin and ISP config

gatitofroilan

New Around Here
Hi , i have a provider that send me internet data with ppoe and voice with DHCP on same ethernet wire (voip on vlan43) i have configured that on a tomato, ppoe on WAN1, and DHCP on WAN2 all on the same cable, then conected to my old router an ATA that get out the voice, but witth merlin i dont get how to configure a WAN2 on same wan Interface and configure DHCP for it.
that could be posible?

i have tried with iptv vlans, but no option to configure dhcp for vlan43 so i have no voice, my new router RT-N88u or RT-N86u (i have both) havent option to install tomato on it

Thanks!
 

Jeffrey Young

Very Senior Member
Which router? firmware?
 

gatitofroilan

New Around Here
Hi, i have a RT-AC88U , firm Merlin 386.4.

I have advanced a little bit, i have created Vlan43
$robocfg vlan 43 ports "4t 8t"
then with added to eth0
$vconfig add eth0 43
Then up vlan43
$ifconfig vlan43 up
now added route
$route add -net 10.1.0.1 netmask 255.255.255.255 vlan43

and i have 2 problems,
1st : (udhcpc -i vlan43 -p /var/run/udhcpc1.pid -s /tmp/udhcpc -b) i execute this command and it says to me the ip that reveive from dhcp vlan43, but dont assign it to the vlan interface, and i need that be assigned because if i set static would cause problems...
for the tests i are stablishing the ip manualy and dont using dhcp because dont work to me :(

2nd: when i ping from router from various interfaces:
LAN INTERFACE;
ping -I eth0 10.1.0.1
PING 10.1.0.1 (10.1.0.1): 56 data bytes
^C
--- 10.1.0.1 ping statistics ---
7 packets transmitted, 0 packets received, 100% packet loss

VLAN43:
ping -I vlan43 10.1.0.1
PING 10.1.0.1 (10.1.0.1): 56 data bytes
64 bytes from 10.1.0.1: seq=0 ttl=64 time=2.311 ms
64 bytes from 10.1.0.1: seq=1 ttl=64 time=1.329 ms
64 bytes from 10.1.0.1: seq=2 ttl=64 time=1.146 ms
^C
--- 10.1.0.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 1.146/1.595/2.311 ms

From vlan43 i ping the sip server, but from lan interface i dont

i am lost, any ideas?

thanks in advance :)
 

gatitofroilan

New Around Here
No one as idea?, im going crazy to make it work :(
 

Jeffrey Young

Very Senior Member
Sorry man, I don't. I only know of one person who does VoIP Phone with an Asus Router. In his case, he just setup port 3 as a STB port via the Router (IPTV as you suggested) and the VoIP box does the rest.

You are saying, you need your router to handle the DHCP IP reservation/VLAN assignment to your VoIP equipment. Strange that the VoIP equipment does not handle this.
 

gatitofroilan

New Around Here
Sorry man, I don't. I only know of one person who does VoIP Phone with an Asus Router. In his case, he just setup port 3 as a STB port via the Router (IPTV as you suggested) and the VoIP box does the rest.

You are saying, you need your router to handle the DHCP IP reservation/VLAN assignment to your VoIP equipment. Strange that the VoIP equipment does not handle this.
I will have access to voip lan from my network so i can register my voip line on softphone or asterisk. My problem is with routes i think but i dont get to troubleshot it. I have voip lan ip on vlan43 but i cant ping it from my lan
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top