What's new

Problems with GT-AX6000 after the factory reset: transmit queue 0 timed out

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Hi guys. Here's another strange problem that I started experiencing with my new Asus router.

1. After I unboxed it, I updated to the official firmware GT-AX6000_3.0.0.6_102.
2. On the same day, I flashed Merlin: 388.2_2.

Everything worked fine for a few days (except some little bug with my Realtek 2.5Gb drivers on Desktop PC).

4. Yesterday, I decided to restore the factory settings, directly on Merlin 388.2_2. I thought it would be better to clean everything up after having fun for the first few days.

Instantly after the factory reset, I noticed that my NAS 2.5Gb USB adapter is crashing with error: "transmit queue 0 timed out". I spent almost entire day trying to fix on the NAS side (since I was trying different drivers for realtek-r8152 drivers before).
I ended up restoring the full system image backup from April 2023 which I am 100% sure that worked flawlessly without issues for weeks without restarts. Unfortunately, nothing helped:

5. I started restoring factory settings on the older, official Asus versions, without uploading backupped settings. Unfortunately, nothing helped. This error was extremely easy to reproduce, because I could trigger it faster by starting wireguard (but of course it still occurrs without wireguard running).

This is how "transmit queue 0 timed out" error looks like:


The worst thing is that my NAS freezes / crashes fully when this r8152 driver has a problem.

6. Searching for more information about this problem, I found this thread: https://bugzilla.kernel.org/show_bug.cgi?id=216884

timo 2023-03-12 15:25:15 UTC
Sorry for the confusion; my reply was clearly posted in the wrong thread.

In my case, the errors happened when I connected a wireless router (TP-Link Archer C9) to these NICs of my server. Initially, I thought the error was in the Linux kernel of the server. However, I have recently replaced the wireless router by a different model and since then, I don't see the 'transmit queue 0 timed out' errors anymore. Not sure what happened; maybe the old device was sending repeated pause frames? Anyhow, it seems to be solved.

7. I decided to connect my old router (Xiaomi AX6000), also with the 2.5Gb LAN port.

Voila! The problem is fully gone. Nothing bad happens.

I decided that GT-AX6000 is not worth the money if there are firmware bugs like this one. I know it probably doesn't affect most of users, but in my case the problem is 100% the router, and I'm sure it started happening after restoring the factory settings on the newest version. There must be something really wrong, possibly related to this? https://www.asus.com/support/FAQ/1050466

I'm going to test how my NAS runs on the old router for the next 24h, and then I'll refund GT-AX6000, since it's too risky to keep that device for me :( I really liked that Asus routers allow a lot of configuration settings, but I can't always worry about errors of this type :(

Anyway, has anybody heard about something similar recently happening?
No such issues have been observed or reported for the GT-AX6000 here.

I suspect your setup.
The only issue I have with my AX6000 is that it takes a good amount of time (30 sec to 1 minute) to establish a 2.5G link even if I manually assign a static IPv4 on windows adapter properties. I use Marvell Aquantia 10G PCIe card and it works flawlessly on all 2.5G or 10G routers/switches where link is established within seconds.
That's strange. For me it didn't take that long to establish connection with the Switch / PC. Maybe it's actually flooding some weird packets?
Either way I was unable to fix it. Returned to the old router now, and all problems are gone. I think Asus became not so great after years.
I have link fast with 2.5G Realtek chip (Cudy PE25 2.5GB - PCIe Network Adapter - RTL8125).

Did you really reset to factory?? With Initialize all the settings checked and maybe also a WPS button reset, re-flash FW and another reset...? YES it can be needed as much (NOT Just ASUS) ;)
Yeah, I was factory resetting with many possible firmwares and settings initialization checked. I returned to the old router and not a single issue for over 1 month now. That Asus router got the deserved refund. I learnt not to try improve things (router change) that are working fine.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!