RT-AC68P SMB Windows login (solved, bug)

MrMoody

New Around Here
I have a 4TB USB3.0 drive plugged into the RT-AC68P, and it works fine as a Samba drive in Windows 10 with Guest Login allowed.

If I turn it off as recommended, I can't seem to get Windows to log into it.

The Network Place tab shows the default (master router) account at the bottom, which can't be edited, and the drive on the right.

Using this simple username and the main router password, Windows keeps saying, "The specified network password is not correct." I also tried ROUTER\username and [email protected] which don't work either.

Adding another account at the bottom of the Network Place tab, setting a password, and enabling R/W on the folders gives me the same result.

What am I missing? Thanks for any help.
 
Last edited:

wouterv

Very Senior Member
From security point I don't recommend to allow guest login, set "Allow guest login" to OFF.
Now you need your router credentials to access the router-drive.
Sometimes it takes a while for the network discovery to complete and allow you to login to the drive attached to the router.
 

eibgrad

Part of the Furniture
FWIW ...

I'm using Merlin 386.7 at the moment, and what I've noticed is that if guest login is NOT enabled, when I browse the router using Explore (e.g., \\192.168.1.1), all I see is my entware (ext2) partition on the USB flash drive, NOT the NTFS partition. So any attempt to login to the latter, even if I create a secondary account to match the credentials of the Windows PC, returns path not found. But as soon as I enable guest logins, the NTFS partition appears and I can access it either with or without a username/password.

So in that sense, I'm able to reproduce the problem, but it doesn't report invalid username/password, just that the path can't be found. The result is the same as the OP; I can't get in without guest login enabled. It's as if having guest logins permitted enables some other option that NTFS partitions need to be recognized/shared across the network.
 

BreakingDad

Very Senior Member
My settings, that work with guest off

workgroup WORKGROUP
wins server no
master browser no
simpler sharing name yes
protocols 1 + 2
 

eibgrad

Part of the Furniture
My settings, that work with guest off

workgroup WORKGROUP
wins server no
master browser no
simpler sharing name yes
protocols 1 + 2

Same settings here (tried others as well), same problem. I even have SMB1 enabled on the Windows client. So both client and server have access to SMB1 and SMB2. As I said, it just doesn't offer access to the NTFS partition during browsing unless I have guest login permitted. The other enware partition (ext2), NOT a problem. Works fine.

I'm thinking I might try changing the NTFS partition to FAT32 (it's only a 1GB flash drive anyway), just to see if that makes a difference. But I see no reason NTFS shouldn't be working.

BTW, I still don't know if the OP and I are experiencing the exact same problem. It just decided to experiment a little given the OP's claims and see if I could reproduce it, which I think I did.
 

MrMoody

New Around Here
I was hoping it was just some trick of formatting the user name or something. I use SMB with logins on the copiers at work with no issues.

I suspect you did reproduce it; the drive is NTFS and Windows isn't known for correctness and consistency of error messages. I too have SMBv1 enabled in Windows, which is disabled by default. I'm also on Merlin, updated from 386.2 to 386.7, made no difference.

I'm using the drive primarily as a media server, mostly just using SMB to maintain the videos. I suppose I could disable Network Place most of the time and just enable it to work on it.

Funny that it works for BreakingDad, though. Unless his drive isn't NTFS.

Edit: I am getting this in the log when Samba starts, although discovery works fine, Windows sees the network share immediately, and it blinks off and back on if you make a change.
Code:
Jul 15 23:17:30 wsdd2[1821]: starting.
Jul 15 23:17:30 wsdd2[1821]: wsdd-http-v6: open_ep: bind: Address already in use
 
Last edited:

BreakingDad

Very Senior Member
Same settings here (tried others as well), same problem. I even have SMB1 enabled on the Windows client.

I don't have any SMB enabled on windows, I used to add it, but it works without. Weird.
 

BreakingDad

Very Senior Member
Funny that it works for BreakingDad, though. Unless his drive isn't NTFS.
It is NTFS huge partition, and a small EXT4 partition, both are picked up. Different router though, I don't know if that makes any difference. I also have media server on, perhaps this is the difference? I am no expert.
Untitled.jpg
Untitled2.jpg
Untitled3.jpg
 
Last edited:

eibgrad

Part of the Furniture
Correction. Now it doesn't work at all, whether guest logins are allowed or NOT.

Ugg, this SAMBA stuff is so darn flaky. Even after all these years, it's so unreliable and inconsistent.
 

eibgrad

Part of the Furniture
Well here's something I never noticed before.

Using FAT32, I can NOT access the partition unless I have a folder defined. IOW, I can't access it at the root. I wonder if the same is true of NTFS. When I was using NTFS, I had no folders defined there either.
 

ColinTaylor

Part of the Furniture
Using FAT32, I can NOT access the partition unless I have a folder defined.
This is how it's intended to work (irrespective of the native filesystem format) unless you have enabled guest login.
 

eibgrad

Part of the Furniture
This is how it's intended to work (irrespective of the native filesystem format) unless you have enabled guest login.

Yeah, kind of makes sense. You can't correlate the permissions of a login if you don't have folders to match it against.
 

MrMoody

New Around Here
Good job guys! That was ONE of the issues. With Simpler Share Naming turned off (the way I wanted it) accessing the root folder using the volume name of the drive WORKS with guest login, but does NOT work with it off. Turning Simpler Share ON, you can see the drive root in the network share as BreakingDad shows in his screenshots. IF you don't have the problem below. Unfortunately this means you can't use the root folder as a mapped drive. Apparently the "disk name" fake folder doesn't support permissions as you say.

The OTHER problem (giving me the password error) is that my router password had symbols in it, and it didn't like at least one of them. I suspect it was $.

BTW, I'm not "new around here," but I hadn't been on in probably 3-4 years (the Asus is so trouble free) and my account disappeared.
 

MrMoody

New Around Here
A couple of notes about SMB v1 vs v2.

SMBv1 has been cracked and is not secure. Microsoft has removed it from Windows, although you can reinstall it under "Turn Windows features on or off" if you need it to connect to some legacy device. I recommend installing the Client only in this case. Whatever the server is should be considered vulnerable.

SMBv2 is included with Windows, enabled by default, and works for Network Place in this router. I would set the Network Place Samba Protocol Version to SMBv2 (only) because of the problem with v1.
 

wouterv

Very Senior Member
It wasn't clear we talk about Asuswrt-Merlin.
For completeness, this is what works for me in stock firmware:
1658041960588.png

Media Server and FTP Share are disabled.
Device Name can be set here or it is taken from the LAN settings Host Name, in my case ROUTER1
I use the default Windows Work Group name, also for the computers at home.
The Router Login Name shall reflect yours.
The Access Rights (R/W, R, No) you can only assign to a folder on the USB drive (not to the root), in my case folder "data".
To access the drive from either Windows 10 or Windows 11, open: \\router1
And Login with your router credentials.
 

MrMoody

New Around Here
Yes, I didn't realize this function was altered by Merlin, perhaps I should have posted in that forum.

To boil it down I had two problems, and the interaction made it difficult to troubleshoot:

-Root folder mapped drive: works with Guest login ON and Simpler Naming OFF, but does not (cannot) work with Guest login OFF.

-Router password contained ( $ characters, which oddly work for the main login but not SMB. This may or may not be a Merlin bug.
 
Last edited:

BreakingDad

Very Senior Member

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top