What's new

RT-AC86U - Enable efficient multicast forwarding (IGMP Snooping)

lukaszzsch

Regular Contributor
Now I have my RT-AC86U all set up with the latest Merlin firmware. But I have a new challenge...
I use Roon to manage my music library at home and play across multiple sources (network streamer, iPhone, galaxy phones, MacBooks, Apple TV,etc. )
But to use Roon I need a router that supports multi casting....https://kb.roonlabs.com/Networking_Best_Practices
And of course this specific model does not support multicasting. Is there a workaround or hack to enable multicasting on the RT-AC86U?
I have been using Roon with 86u for almost two years and now with ax88 without problems.
 

erizock

Occasional Visitor
I have been using Roon with 86u for almost two years and now with ax88 without problems.
That’s good to hear! Can you share any settings or tweaks you’ve made? Do you use Merlin software? I think I ran into problems after I switched from stock firmware to Merlin. Thanks
 

lukaszzsch

Regular Contributor
I did not make any changes regarding to Roon compability. It does work out of box with Merlin.

Do you experience any problems?
 

erizock

Occasional Visitor
Thanks for getting back to me. Yes, unfortunately I do. Audio zones that were previously enabled are no longer enabled and every time I to re-enable, they are unable to.
For example I now can’t play Roon on my iPhone, my wife’s Samsung note8, my Auralic streamer and more. It happened after I upgraded to the latest Merlin firmware. I have to think there are some setting(s) I need to change. I can share screenshots of my various settings if it’s helpful.
 

lukaszzsch

Regular Contributor
Look at enclosed screenshot.


All of my devices configured many months ago are enabled now.

Malina - streamer built on raspberry pi
iPad...
 

erizock

Occasional Visitor
After I install Merlin, I followed the suggestions from a fellow SNB member (L&LD) and made these change to the default settings... maybe i should enable Universal/Implicit Beamforming, Airtime Fairness and/or MU-MIMO on both bands in the Wireless/Professional pages?
======================================================
  1. L&LD said:
dlandiss is correct, there is no one ultimate setup. However, there is still a 'best practices' method that is a good starting point for all further configurations.

Look at the links in my signature for more in-depth information, but for an overview, the following is what will get you going in the right direction.
  1. Whether you will use RMerlin's firmware or not, flash the version of the firmware you will use and then proceed to do a full reset of the router, even if you haven't previously used it at all (i.e it is 'brand new, out of the box').
  2. When resetting to factory defaults with the GUI, make sure to tick the box that says 'initialize settings...' that is right beside it.
  3. If that checkbox is not available in your firmware version, then after doing a factory reset via the GUI;
  4. Also, perform the 'format jffs partition on next boot' and proceed to reboot the router 3 times in the next 15 minutes or so (with 5 to 10 minutes between reboots to allow the router to configure itself as needed).
  5. Now, we can manually and minimally configure the router to secure it and connect to our ISP. This means that we do not use a saved configuration file to 'restore' any previous settings.
  6. This also means that we accept the defaults for most settings too, especially if using an RMerlin firmware, or we have any doubt as to what the consequences might be.

With the above completed (it is less than 1/2 hour of 'work'), we will change the following defaults:
  1. Disable Universal/Implicit Beamforming on both bands in the Wireless/Professional pages.
  2. Disable Airtime Fairness on both bands in the Wireless/Professional pages.
  3. Disable MU-MIMO on both bands in the Wireless/Professional pages.
  4. Set Preamble type to Short on the 2.4GHz band in the Wireless/Professional pages.
  5. Set the Time Zone and DST Time Zone changes settings for our locale.
  6. Change the Memory Management: Regularly flush caches (default: Yes), to No (RMerlin Tools/Other Settings page).
  7. Change the Control Channels for both bands away from 'Auto' after testing which Control channel works best (2.4GHz use 1, 6 or 11 'only').
  8. With a new router or a fully reset one such as the above steps outline, I recommend a new SSID for each band too.
  9. Or, alternately, 'forget' the network on each client device that will be used in this network and then re-associate them. Some clients may need to have a 'reset networks' command and reboot too with this method. It is much easier to just use a new SSID.
With the above completed, you will have the fastest, most stable and most reliable network possible.

Of course, we can do much more with our Asus + RMerlin powered routers. Once the above is proven to be stable in your network, the additional features such as AiProtection, Parental Controls, etc. can be added as needed.

Don't forget the most powerful features of these routers: the excellent scripts available for them. My signature below contains some of the most popular ones I am currently using. For the additional 'cost' of a spare USB drive.

Hope this is enough to get you started. :)
 

erizock

Occasional Visitor
Everything is working now! Just had to reboot my Roon core and the audio zones are now visible and enabled! Thanks.
 
Last edited:

Kalashnikov

New Around Here
Hi!
Yesterday I got the AC86U to replace my old RT-N16 (thanks Merlin for the rock solid firmware), and I was shocked that IGMP snooping in the LAN switch is no longer available, due to the limitations already posted here. This just breaks my business case for this router, since I cannot use it with my IPTV service.

I will replace the AC86U for another one and I would like your help to tell me if the models AC68U, AC87U, AC88U or AX88U still have the IGMP snooping option?

Thanks.
 

EmeraldDeer

Very Senior Member
RT-AX88U
Wireless --> Professional --> Enable IGMP Snooping
LAN --> IPTV --> Enable multicast routing (IGMP Proxy)

Note: IGMP Snooping can be set on/off by individual radio.

No mention of IGMP Snooping in LAN --> Switch Control. Does this mean IGMP Snooping can be enabled for wireless but would not include the LAN? I do not know.
 
Last edited:

maxiarg14

Occasional Visitor
Although the efficient Multicast forward option is missing on the AC86 after turning on IGMP Proxy without selecting any IPTV ports i was able to to stream mutlicast successfully.
What version were you using when you wrote this? I'm doing the same as you, but image freezes after 2 minutes. I think is a snooping issue.

Thanks!
Regards
 

Kalashnikov

New Around Here
Any news on this? My ISP uses multicast and my box is freezing every 10 seconds, need IGMP snooping. Using RT-AC86u and Meo (Portuguese provider).
Good news! Thanks to a user in a portuguese forum, it's possible to have MEO IPTV working with the AC86U and AX88U. Here's the config, connecting the iptv box to port 3:

– ISP profile: manual
– Internet VID: 12 | PRIO: 0
– LAN Port 4: Blank | PRIO: 0
– LAN Port 3: VID: 12| PRIO: 1

– DHCP routes: “Microsoft”
– IGMP Proxy: “Disable” – hardware limitation bla bla bla
– UDP Proxy: 0
– IGMP default version: 3

The difference here for previous Asus models is that the router will create a specific priority LAN for the IPTV (I think it's what the PRIO: 1 configuration does). In my case the router created a subnet 176.78.11.x. (you can see it in the meobox definitions)

Since it's a separate LAN I think you don't even need IGMP snooping to filter the IPTV multicast from the rest of the network.

I have it working rock solid since this morning with latest Merlin firmware 384.17.

Don't forget to reboot the meo box.
 

francovilar

New Around Here
Good news! Thanks to a user in a portuguese forum, it's possible to have MEO IPTV working with the AC86U and AX88U. Here's the config, connecting the iptv box to port 3:

– ISP profile: manual
– Internet VID: 12 | PRIO: 0
– LAN Port 4: Blank | PRIO: 0
– LAN Port 3: VID: 12| PRIO: 1

– DHCP routes: “Microsoft”
– IGMP Proxy: “Disable” – hardware limitation bla bla bla
– UDP Proxy: 0
– IGMP default version: 3

The difference here for previous Asus models is that the router will create a specific priority LAN for the IPTV (I think it's what the PRIO: 1 configuration does). In my case the router created a subnet 176.78.11.x. (you can see it in the meobox definitions)

Since it's a separate LAN I think you don't even need IGMP snooping to filter the IPTV multicast from the rest of the network.

I have it working rock solid since this morning with latest Merlin firmware 384.17.

Don't forget to reboot the meo box.
Thank you. Will try today
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top