1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[RT-N66U] Open-VPN TCP Port 443 not binding

Discussion in 'ASUS N Routers & Adapters' started by doggydude, Apr 16, 2014.

  1. doggydude

    doggydude New Around Here

    Joined:
    Apr 16, 2014
    Messages:
    2
    For reasons, I need to set up openvpn on the rt-n66u to use port 443 and tcp. The VPN starts fine with UDP, but upon switching to TCP, the following error occurs keeping it from starting:
    Apr 16 11:34:41 openvpn[7196]: TCP/UDP: Socket bind failed on local address [undef]: Address already in use
    Apr 16 11:34:41 openvpn[7196]: Exiting due to fatal error

    After doing some research, people who have this error with an Open VPN server on their computers need to netstat to find what is using the port, so they can kill the process, but I don't know of any way to do this on my router.
    Any help would be greatly appreciated.
     
    BeerusSama likes this.
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    27,986
    Location:
    Canada
    Port 443 is used by AiCloud. You will have to disable AiCloud if you really want to host your OpenVPN on that port, or move AiCloud to a different port (configurable through http://192.168.1.1/cloud_settings.asp)
     
    BeerusSama likes this.
  4. doggydude

    doggydude New Around Here

    Joined:
    Apr 16, 2014
    Messages:
    2
    That fixed it,
    Thank you Merlin, I appreciate the hard work and dedication you have for this community, I wish I had even half the skills you have!
     
  5. BeerusSama

    BeerusSama New Around Here

    Joined:
    Jan 6, 2017
    Messages:
    2
    I logged in just to say thanks for the answer @RMerlin, more than 3 years later you helped someone again... :) I am trying to setup OpenVPN on my Asus RT-AC66U and had the same problem as @doggydude, disabling AiCloud (which I have NEVER used) fixes it instantly. :D
     
  6. Hello World

    Hello World Occasional Visitor

    Joined:
    Jul 18, 2014
    Messages:
    29
    Thanks Merlin. I've been pulling my hair out for months trying to figure out what was using port 443. I turned off AiCloud and now I can set my OpenVPN to TCP 443. A million thanks.
     
  7. carldivin

    carldivin New Around Here

    Joined:
    Sep 24, 2018
    Messages:
    1
    TCP port 443 is the default port used by HTTPS. If this port is blocked on any server or device from your computer to a given destination, such as www.Microsoft.com, your connection to any https site will fail and your browser will return an error message like "Secure Connection Failed" or "Page Cannot be Displayed" . However, the two most common locations for this failure are at your workstation or router. Moreover, if you can access the html page at your root domain (say https://midomain.com/), but pages in a directory like https://midomain.com/ give you a 404 Not Found error.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!