spdMerlin spdMerlin - Automated speedtests with graphs

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

L&LD

Part of the Furniture
I've had the opposite experience with my RT-AC66U_B1 in that the uploads are matching but the downloads are showing 20% less speed when compared to my ISP speed and/or a browser based test. As said in this thread, I am chalking it up to the limitation of my router.

It may help to note the ISP, paid for speeds on your RT-AC66U_B1 (which is an upgraded 'original' RT-AC68U w/1GHz dual-cores, correct)?
 

bluzfanmr1

Senior Member
It may help to note the ISP, paid for speeds on your RT-AC66U_B1 (which is an upgraded 'original' RT-AC68U w/1GHz dual-cores, correct)?

Correct on the router. I have Charter/Spectrum service with speeds of 200/10.
 

L&LD

Part of the Furniture
Correct on the router. I have Charter/Spectrum service with speeds of 200/10.

Yes, those ISP (upload) speeds won't tax the router at all. ;)
 

Jack Yaz

Part of the Furniture
I'm going to be removing ping from this script, in favour of a dedicated utility....
upload_2019-4-11_23-19-52.png
 

gattaca

Senior Member
Here's my update. I agree with L&LD's general observation about 10% low with 1 caveat. Any testers times, pings, and results will can vary widely based on the targets chosen, time of day and other workloads on the pNW routing infrastructure at your ISP. Just select an alternative target in speedtest.net (one closer or further away) and it's that many more hops your packets must transverse. So if we picked the same servers as speedtest.net, we might nearly identical results.
IDK if picking the same servers as speedtest.net (or whatever test you want) is feasible or even possible.

From speedtest.net
339/19Mb/s, ping 18 ms
spdMerlin-speedtest-net-20190411.jpg
262/16Mb/s ping 80+ms
RT-AC86U capture spdMerlin-20190411.jpg
 

L&LD

Part of the Furniture
Here's my update. I agree with L&LD's general observation about 10% low with 1 caveat. Any testers times, pings, and results will can vary widely based on the targets chosen, time of day and other workloads on the pNW routing infrastructure at your ISP. Just select an alternative target in speedtest.net (one closer or further away) and it's that many more hops your packets must transverse. So if we picked the same servers as speedtest.net, we might nearly identical results.
IDK if picking the same servers as speedtest.net (or whatever test you want) is feasible or even possible.

From speedtest.net
339/19Mb/s, ping 18 ms
View attachment 17010
262/16Mb/s ping 80+ms
RT-AC86U capture View attachment 17011

I was able to choose the exact same servers as when using speedtest.net on my computer. Very different results. ;)
 

Swistheater

Very Senior Member
okay so this wont work when doing a speed test against my isp :rolleyes:, but it works for every other server.

*edited* so far the only local server i can get it to work with is a tmobile server......it works perfectly fine in automated mode*edited*
 
Last edited:

Swistheater

Very Senior Member
how much data does this actually use per run?
 

Jack Yaz

Part of the Furniture
okay so this wont work when doing a speed test against my isp :rolleyes:, but it works for every other server.

*edited* so far the only local server i can get it to work with is a tmobile server......it works perfectly fine in automated mode*edited*
What errors are you seeing
 

Jack Yaz

Part of the Furniture
how much data does this actually use per run?
Not sure, to be honest. I think router originating traffic bypasses traffic analyzer etc. so I'm unsure of how to track usage
 

Swistheater

Very Senior Member
Not sure, to be honest. I think router originating traffic bypasses traffic analyzer etc. so I'm unsure of how to track usage
Okay. Are there any preferred settings I would want to enable on.the router so this works optimally. I have only found 1 local server that works for me. And the random server mode only works so often.
 

Jack Yaz

Part of the Furniture
Okay. Are there any preferred settings I would want to enable on.the router so this works optimally. I have only found 1 local server that works for me. And the random server mode only works so often.
My other post got flagged. Probably because I was quoting you using the t word.

What errors are you seeing?
 

Swistheater

Very Senior Member
No errors it just will say zero down and zero up and a really high ping ms number almost like it is not getting replys
 

Swistheater

Very Senior Member
One of my test came back with zero mbit down and zero up and had a ping of 4859 ms
 

Jack Yaz

Part of the Furniture
1.1.1 is now available
Changelog:
Code:
Remove inaccurate ping graphs in favour of connmon
Improve figure accuracy under graphs
Add button for speedtest on demand
Change schedule to 12 and 42 past

Please run u twice to get the new WebUI page
 

joe scian

Very Senior Member
1.1.1 is now available
Changelog:
Code:
Remove inaccurate ping graphs in favour of connmon
Improve figure accuracy under graphs
Add button for speedtest on demand
Change schedule to 12 and 42 past

Please run u twice to get the new WebUI page

I ran U twice and also force updated but I dont get the new ping graphs Jack on an AC5300 using 384.10.2
Maybe I need to wait after 42 past? Its now 47 past still no ping graphs - graphs still at 9:10 - have refreshed page - still same - also ran - run speedtest now button. sppedtest ran ok but no ping graphs or ping message info
 
Last edited:

QuikSilver

Very Senior Member
Same here after updating by using the -u option twice...Only showing Speedtest button, Last 24hrs (Download graph, Upload graph) and then last 7 days(Download graph, Upload graph).
 

Jack Yaz

Part of the Furniture
Ping graphs have been removed and replaced in connmon (unreleased script )
 

Therion87

Regular Contributor
Toggling option 5 causes the automatic script to use my chosen preferred server when running correct? If disabled it auto selects the server?
 

Jack Yaz

Part of the Furniture
Toggling option 5 causes the automatic script to use my chosen preferred server when running correct? If disabled it auto selects the server?
Yes that's right
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top