What's new

Trying to access a share

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I have a Win7 Home laptop and Win10 Home laptop on same network.
They both have the same workgroup name but I cannot get them to access under a shared user account.
(1) I have the same user acct name on both Laptops with same password.
(2) I have (in advanced sharing) shared the entire drive that I want to access from the other Laptop with the added permissions to the name of the pertinent User to the share.
(3) That user being the one I'm logged in on one Laptop and attempting to log in the share on the other Laptop.

Now in the Pre-Win10 days I could then attempt to access the other Laptop with a \\UNC_ShareName\ShareItem
and it would then prompt me with a password login box. And from there I was in. But that's not happening. It just trys for about 10 seconds and gives an error.

I have the following settings on each Laptop. The wording is a bit different on Win7 and Win10 but below is the essential summation of what both say in Network Advanced Sharing settings
(Private) Home or Work (current profile)
Turn Network discovery ON
Turn File and Print sharing OFF
Turn Password Protected sharing ON
Use User Accounts and passwords to connect to other computers
(Public) Network
Turn File and Print sharing OFF
(but users with accounts on this computer can still access these folders)
As said at start, cannot get the UNC share name to access, just returns an error.
As in \\TheOneLaptop\C (the drive) and \\UserAcctName\FolderName (the folder)
Network discovery is ON but nothing is seen except printer.
At first I thought it was because one laptop was wifi networked and the other was hard wired ethernet to same router. So I disabled the wifi and carried that laptop to the router room and hard wired it ethernet to the router also. but no go, same problem.

I'm wore out fooling with it tonight but tomorrow I will just remove the ISP Wan (internet access) cable from the modem and then turn on File and Print sharing for all networks public, whatever. Maybe then I can see something.

Anybody got some input that might help me?
i think you have to have file and print sharing on on the laptop that has the files.
Assuming you define your home network as "private" when windows linked to it, i think you would enable F&P sharing on the PRIVATE network. Leave the PUBLIC network as is.

If both laptops have files that need to be shared, it would be the same for each.

Otherwise get a simple NAS and use a public folder there. Keep F&P sharing off.
Update: I can ping both Laptops by name getting replies with no data loss. I also looked up the dhcp address pool in the router login. I also pinged them both also by IP address as in ping 192.168.1.x and got replies with no data loss.
Tried with networking again with ALL Network Discovery turned ON. File Sharing turned ON on EVERYTHING, rebooted but still nothing. No network items showing (except printer) and still won't even do a \\UNCSharename\ShareItem

So on lan adapter I Checked the WINs option of NetBios over Tcp and set it on and to start it in services.msc. Rebooted but still nothing.

Also tried turning OFF password protected sharing and again making sure to turn ON anything remotely eluding to file and print sharing of any kind. Rebooted, still nothing.

So I ran the MS diagnose routine, it got this,
The remote device or resource won't accept the connection.
The device or resource (TheLaptopName) is not set up to accept connections on port "The File and printer sharing (SMB)".
Contact your network administrator

So I re-checked everything above, rebooted and still nothing.

so I ran the MS diagnostic again and got a different msg this time,
Windows can't communicate with the device or resource (TheLaptopName) Detected.
It is available but is not responding to connection attempts. A firewall or network security policy on the remote computer might be blocking the connection on port "file and print sharing resource".

So I first looked at the firewall rules, the only thing I could see that was blocked was Incoming NetBios over TCP, outgoing was not blocked. So anyhow I shut down the Norton firewall completely on both laptops. Tried it again, still NOTHING.

So then I disconnected both laptops from the router and went into the adapter setups on each and set the IPv4 setting to Alternate config and set one laptop to and the other to I still had everything to do with Sharing ON. I then hooked them together with an ethernet cable. Pretty much the same thing, it just said UnIdentified Public network. But nothing showed up this time either. Not even the printer which for once made sense since wifi and router were disconnected.

I'm beat on this one. I read Windows 10 ver 1803 update did away with the Homegroup. The MS readme said it no longer functions. But I can't get ANYTHING to work, at all.
I guess I will have to copy the drive with a USB, I'm thinking that's gonna be a bit slower

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!