What's new

Trying to setup Moca with Google Wifi, IP assignment problems

thetodd34

New Around Here
Hi all, I'm hoping someone can help. My Google Wifi (GW) mesh performance has slowed ton a crawl lately. Even with all the pucks in the same room, I will get weak mesh connections. I know a bunch of people have similar problems, which they attribute to the latest firmware. I've tried trying to effectively create a wired backhaul by using Moca, but I need some help.

My provider is WOW (Wide Open West). 500/50 service. From the ONT, the coax coming into my family room is split into 1) the media gateway and 2) the Arris TG2427 modem/router.

**Pre-Moca:
From the Arris TG2427, I have an ethernet cable from one of the 4 LAN ports connecting to the primary GW WAN port. Then an ethernet cable runs from the primary GW LAN port to a TP Link 8 port unmanaged switch. A second GW puck is wired by ethernet to the TP Link switch, and a third GW puck connects wirelessly.

I set the Arris TG2427 into bridge mode and disabled the wireless 2.4/5 networks and the Arris TG2427 firewall. I've left the Moca function disabled. I've tried leaving the Arris TG2427 DHCP server on or turning it off, and I don't notice any difference -- it works both ways.


**Now with Moca:
I bought two GoCoax 2.5 Moca adapters, a couple Bi-Directional 2.4 Ghz 2 Way Coaxial Cable Splitters, and a POE filter.

I took the coax line that was originally going into the Arris TG2427 and plugged it into the GoCoax Moca adapter's Moca port. I connected a separate coax cable to the GoCoax Moca adapter's TV port, and plugged this into the Arris TG2427.

I left the ethernet cable from the Arris TG2427 plugged into the WAN port of my primary GW puck. I left the ethernet cable from the LAN port of the primary GW puck plugged into the TP Link unmanaged switch. I took an ethernet cable and attached it to the ethernet port of the GoCoax Moca adapter and attached it to the TP Link unmanaged switch.

I left my GW second puck attached to the TP Link unmanaged switch by ethernet.

In the room of my third GW puck, there is a coax wall port. I attached a cable from the wall coax to another GoCoax Moca adapter's Moca port. I attached an ethernet cable from that Moca adapter to my third GW puck's WAN port. An ethernet cable then connects the desktop computer to the GW puck's LAN port.

The POE filter attaches before the first splitter in the basement, where the coax line comes in from WOW.

On the router setting of the Arris TG2427, I left it in bridge mode and set the DHCP function to off. I left the internal Moca capability of the Arris TG2427 off. The reason being, if you enable the Moca function of the Arris TG2427, it seems to force itself out of bridge mode, and into Router with NAT mode. My desire is to keep all my devices on the GW subnet (192.168.96.x), not the Arris TG2427 subnet (192.168.0.x).

With this setup, most (but not all) of my home wireless devices will get on the GW network with a 192.168.86 IP address, and everything seems fine with those devices. However, many wireless devices (including my phone) will get an IP address from the 192.168.0.x subnet, not the GW subnet. The wired desktop computer also gets a 192.168.0.x address from the Arris TG2427. These devices are able to get online, but I'd like all my home devices to be on the GW 192.186.86.x subnet.

Here's another bit of information. Maybe it helps. For devices that are correctly assigned 192.168.86 IP addresses from Google wi-fi, I can access the Arris router settings by going to 192.168.100.1. This shows me the router settings as I've described. Bridge mode, DHCP off, firewall off, Wi-Fi off, and Moca disabled.

BUT -- the devices that are connected to the Arris subnet, 192.168.0, I can only access the Arris router settings by going to 192.168.0.1. Maybe that isn't so odd, but here is the weird part. When I access the Arris router settings from one of these devices on the wrong subnet, the router settings are completely different! The DHCP is on, the Wifi is on, the router mode is set to 'Routing with NAT', and the MOCA is enabled!

Please help!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top