uiDivStats uiDivStats - WebUI for Diversion statistics

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

gattaca

Senior Member
^^^^ Ditto.. again if not much trouble. Thanks for letting us know the reasons why you dropped it - makes sense. Since pixelserv address varies with installer IP range. so it might be more trouble than it's worth? FWIW, I've resorted to just keeping a web page open now to http://pixelservIP/servstats and refreshing when I want an update.
 

Smokey613

Senior Member
Tried to install UiDivStats and keep getting this error even though logging is enabled in Diversion.

190E9D90-0681-430E-933E-6D515F1E2AEE.png
 

Smokey613

Senior Member
I made sure no “extra” dns stuff was running, I had been playing with unbound and nextdns so I made sure they were uninstalled and now UiDivStats installed without a hitch. Here is the output now.


[email protected]:/tmp/home/root# /opt/bin/grep 'log-facility=/opt/var/log/dnsmasq.log' /etc/dnsmasq.conf
log-facility=/opt/var/log/dnsmasq.log
[email protected]:/tmp/home/root#

Can I run unbound without causing diversion issues?
 

dave14305

Part of the Furniture
I made sure no “extra” dns stuff was running, I had been playing with unbound and nextdns so I made sure they were uninstalled and now UiDivStats installed without a hitch. Here is the output now.


[email protected]:/tmp/home/root# /opt/bin/grep 'log-facility=/opt/var/log/dnsmasq.log' /etc/dnsmasq.conf
log-facility=/opt/var/log/dnsmasq.log
[email protected]:/tmp/home/root#
Yeah, NextDNS client doesn’t let anything else load from dnsmasq.postconf, such as Diversion.
 

Smokey613

Senior Member
Yeah, NextDNS client doesn’t let anything else load from dnsmasq.postconf, such as Diversion.
Will Unbound cause any issues?
 

Jack Yaz

Part of the Furniture
I for one would welcome that option (if it’s not too much trouble.)
^^^^ Ditto.. again if not much trouble. Thanks for letting us know the reasons why you dropped it - makes sense. Since pixelserv address varies with installer IP range. so it might be more trouble than it's worth? FWIW, I've resorted to just keeping a web page open now to http://pixelservIP/servstats and refreshing when I want an update.
Ready for testing on develop: https://github.com/jackyaz/uiDivStats/commit/0e45b4c40e6de5a8f2fbd41551a005be26c634e8
 

Wrkdbf_Guy

New Around Here
Last week, via Amtm, I updated all my scripts to the latest versions, including Diversion and uiDivStats. All updated nicely and with no issues.

But I show no Diversion stats in the UI. I even waited a week so that Diversion would do it's weekly thing - thinking that might be why the UI stats were empty. But now it's past a week and still no UI stats.

I suspect this is something the user (me!) hasn't done or doesn't know. But any help would be appreciated.

Bill

PS: yes, it I did search but didn't find anything especially relevant.
 

AntonK

Senior Member
Last week, via Amtm, I updated all my scripts to the latest versions, including Diversion and uiDivStats. All updated nicely and with no issues.

But I show no Diversion stats in the UI. I even waited a week so that Diversion would do it's weekly thing - thinking that might be why the UI stats were empty. But now it's past a week and still no UI stats.

I suspect this is something the user (me!) hasn't done or doesn't know. But any help would be appreciated.

Bill

PS: yes, it I did search but didn't find anything especially relevant.
I should be a new tab under the LAN settings. Clear your browser cache by using (ctrl + F5) or other method.

Annotation 2020-06-30 143019.jpg
 

Wrkdbf_Guy

New Around Here
Nope, I don't see that Tab under LAN. I *do* still have the tab under ADDONS. It's where I was looking for and seeing the empty stats.

Bill
 

QuikSilver

Very Senior Member
Nope, I don't see that Tab under LAN. I *do* still have the tab under ADDONS. It's where I was looking for and seeing the empty stats.

Bill
When is the last time you rebooted the router?
 

Marin

Very Senior Member
Nope, I don't see that Tab under LAN. I *do* still have the tab under ADDONS. It's where I was looking for and seeing the empty stats.

Bill
Did you try “uf” on the menu and refreshed your screens?


Sent from my iPhone using Tapatalk
 

Wrkdbf_Guy

New Around Here
When is the last time you rebooted the router?
Well, duh. (grin) I rebooted and got the correct Tab added to LAN. But still no stats. So I went into AMTM, clicked J5 to go into uiDivStats and it immediately started "1st time stats generation". I wouldn't have expected it to immiately do anythin. But I was intending to go in and update stats anyway, so I was good with that.

But then it stayed there "regenerating stats" forever - well over an hour. (How long should this take typically?) Eventually had to reboot to get it to move ...

Rebooted the Router a few more times, but everything "feels" sluggish, the CPU %'s are thru the roof and I've lost my AIMESH node. What should I do now to get my wireless access back in order?

Bill
 

AntonK

Senior Member
Well, duh. (grin) I rebooted and got the correct Tab added to LAN. But still no stats. So I went into AMTM, clicked J5 to go into uiDivStats and it immediately started "1st time stats generation". I wouldn't have expected it to immiately do anythin. But I was intending to go in and update stats anyway, so I was good with that.

But then it stayed there "regenerating stats" forever - well over an hour. (How long should this take typically?) Eventually had to reboot to get it to move ...

Rebooted the Router a few more times, but everything "feels" sluggish, the CPU %'s are thru the roof and I've lost my AIMESH node. What should I do now to get my wireless access back in order?

Bill
It sounds to me like you’re suffering from USB stickitis. I suffered too, and was only able to cure it by purchasing a new high-performance USB stick. Once in place, everything ran like a charm without sluggishness, CPU overload, etc.

You will see the same experience from others in this forum if you look around.

This model at $10.00 has worked perfectly for me.
 

QuikSilver

Very Senior Member
For those who are experiencing "sluggishness" with UiDivStats installed how many clients do you have on your network? I believe I am seeing a correlation with more clients the slower router seems. In two routers I have, both with high performance USB drives, the higher client count and higher bandwidth network seems slower. Just an observation.
 

AntonK

Senior Member
For those who are experiencing "sluggishness" with UiDivStats installed how many clients do you have on your network? I believe I am seeing a correlation with more clients the slower router seems. In two routers I have, both with high performance USB drives, the higher client count and higher bandwidth network seems slower. Just an observation.
I'm a small home network with 4 clients max. My router's CPU racing and consequent sluggishness was entirely solved by the swapping in of a performance USB stick to run uiDivStats and my other scripts on. The difference was immediate, and night v day.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top