What's new

Weird Wake on LAN problem with GT-AXE16000

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I'm running merlin 388.5 and I have my PC setup with a reserved IP address. I also have a cron job setup to run every hour to make sure the ARP entry stays perm'd because otherwise it gets deleted after awhile.
If I submit a WOL magic packet from Wifi on my smartphone to my PC's IP address, it won't wake up. If I disconnect from Wifi, then connect to my router's IPSec VPN over 4g/5g and submit the magic packet to the same local IP address from the app, then my PC wakes up.

Any ideas?
Can I ask why are you sending an IP WOL packet?
MAC magic packet is as accurate and much simple to use, as you don't need to keep an ARP entry in place. MAC magic packet will not work over VPN, but Asus has this mechanism in UI, so you can vpn to connect to the router (or just open WEB access from WAN if you want to do that) connect to the router and wake up whatever device.
I'm doing this for many many years and it always works.
My app on Android does include the MAC. If I don't target the IP address, then it never works.

I used to VPN in and then use the web interface but it's much more annoying than the app which is 2 taps to wake my PC vs opening a web browser and logging into my router, going to network tools, clicking my PC MAC address and clicking wake up.
Mine is two clicks as well. First click connects my phone to my router's vpn server:

Screenshot_20240328_091804_One UI Home.jpg

Second click starts a script that commands the router to wakeup the pc:

Screenshot_20240328_091849_One UI Home.jpg

Let me know if you are interested in more info.


  • Screenshot_20240328_091804_One UI Home.jpg
    Screenshot_20240328_091804_One UI Home.jpg
    48.5 KB · Views: 7
  • Screenshot_20240328_091849_One UI Home.jpg
    Screenshot_20240328_091849_One UI Home.jpg
    75.3 KB · Views: 7
Further testing:
On WiFi, the PC will wake up if I target the broadcast IP address ( but on external VPN connection, it won't. I have to target the reserved address specifically to wake it up over VPN.

Why is this?
As a reminder, this issue has already been discussed here:
Pardon, but I don't really see where in that thread this specific problem is addressed. I even posted in that thread on page 4 because I was initially using Port Forward to handle my Wake on WAN setup, but switched to VPN and not exposing the port to the net.
Let's walk back - what is the problem you are trying to solve?
The problem is I send wakeup packets using an app on my smartphone that uses the MAC address and IP of the target machine. I aim to be able to boot my PC both over local WiFi and over remote VPN. Using the specific IP address over WiFi doesn't work, but the broadcast IP does. Over VPN, the broadcast address doesn't work but the specific PC IP does. I currently have two 'machines' setup in the wake on lan app on my phone, but would greatly prefer just one and not have to worry about it. Ideally, the PC would wake up when my phone is on WiFi and not using the broadcast address (or vice versa.)
And now it won't wake over VPN at all regardless of target IP.
What is going on with this router? Why is WOL so messed up and annoying? Why does it act so randomly and unpredictably? I used a Cisco e4200 for 12 years and WOL never failed me nor DHCP reservation forgetting my PC. "Upgrade" to an expensive WiFi-6e router and nothing but problems even on custom firmware. It's whack.
I take it no one has an answer to this problem, why my VPN connection suddenly stopped allowing me to send a magic packet to wake up my PC when it previously worked just fine?
Even after 2 weeks of uptime, I can still wake my PC over WiFi from my phone just fine, using the broadcast IP. No one has any ideas here?
There are 2 types of magic packet:
- ip. Where network has to know ip/mac association so packet will reach the right device. This type of traffic can be VPN'ed
- mac. This way you just send a layer2 packet to a certain mac address and that machine will wake up. This type of traffic cannot be VPN'ed. VPN works at later 3 and there's no way to encrypt such L2 packet.

Depending what you're application is doing, it may or may not work over VPN.
A healty workaround: you do VPN, connect to GT-AXE16000 interface and it has the option to send a L2 magic packet to whatever mac address you want.
That's the strange thing, I've had success previously with this app and VPN just fine. It randomly stopped working after a few days of router uptime. What can explain that?
Actually I may have an idea.
I can't find Asus' default arp timeout. But that may explain why it works for you for a while than it stops working.
Every router will forget eventually ip/arp association. You can see the table with arp -a by ssh'ing to the router.

If your application sends an ip packet, something in the network must know mac address of that ip address. If Asus router or a switch gets an ip packet, it will have to resolve the mac address. Otherwise it won't be able to send the packet to the right host.

You can actually check that fairly simple:
- power up the host you aim to wake.
- shut it down
- send a WOL request
Fairly sure it will come up.
Try sending another WOL packet 24h and one minute later, without powering up that machine at all in between. I would suspect Asus uses 24h arp timeout, but I have no proofs.
I would expect that machine won't come up.

There are several topics here on how to create a static ip/mac association.
Or just use Asus' interface to wake up whatever device you want.
I actually have a cron job running every hour that adds my PC back to the ARP table so it's always PERM'd. This is the only way I can reliably wake my PC using my app over WiFi.
For the first few days after booting my router, the PC will remain with a static ARP without this intervention and in that case, the PC can be waked up by the app over VPN.
Once the PC is flushed from the ARP table and I have to re-add it back using SSH and either manual entry or cron job adding it, then the VPN won't be able to wake it up using the app.
I can still SSH into the router or use the web interface over VPN, but it's a much more annoying method and it still doesn't answer the bottom line question:
Why does VPN WOL work for the first 3 days after rebooting the router but fails to do anything after that?

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!