Windows won't recognize my USB drive in back of router

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JustinSTL719

New Around Here
I plugged my USB drive into the back of my router. I formatted it to be NTFS. I want Windows to discover my device so that I can go into File Explorer and add it as a network drive and basically do whatever I want with it. I want it to be a drive I can save Torrent files to. I want it to be a drive I can build a Plex Media Server with. I want to do all the things with it.
Here is what I've tried so far:
I have enabled SMBv1 via the "Turn Windows Features on or off" menu
I have gone into the router settings to enable SAMBA use. I toggled enable guest login to on.
I have tried to map a network drive to no avail and get nothing but error messages.
I have tried typing in the default gateway ip address into file explorer "192.168.50.1" and error message.
I have tried clicking add a network location, then I type in "\\192.168.50.1\Samsung whatever the name of the drive is" and then it prompts me for a username and password that I don't even know, so I type in my router SSID and WPA2 password but then error message.
I don't know what else there is to do and it's beginning to frustrate me because I see all these YouTube tutorials that tell me to do all the same things, and it should pop up as a computer storage device in the "networks" tab on File Explorer but nothing happens. My laptop is running Windows 10 with the latest version. And my router is an AX88U. So it's not like my technology is obsolete. I don't know a whole lot about computers and network settings. So anyone who wants to help me out with this, that would be great!
 

ColinTaylor

Part of the Furniture
The user ID and password will be the ones shown/created at the bottom of the Samba page, not the SSID password. There will already be one account created, the one that you log into the GUI with (e.g. admin).
 

Tech9

Very Senior Member
I want to do all the things with it.

Asus perhaps makes you believe you can, but in reality you can't. The hardware inside of your router is weaker than Raspberry Pi and Asuswrt file share implementation is not good. You'll run into issues sooner or later like many other folks around. This is a router, not a NAS. Use it as a router, get a NAS.
 

Adooni

Senior Member
I had the same challenge with Asus router and 2 PC connected to it one with win10home and 2nd with win10pro. The same configuration and one seen HDD and 2nd not
I used total commander on 2nd one (Net - network connection) and this works.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top