What's new

Zyxel ZyWALL USG 20 Works Fine on Comcast Business Internet, but Has Poor Connection on Faster Fiber

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Greetings! I have an old Zyxel ZyWALL USG 20 (the first version: https://www.smallnetbuilder.com/lanwan/lanwan-reviews/zyxel-usg20-unified-security-gateway-reviewed/ ) in my small office which has worked fine for years on my Comcast Business Internet (25 Mbps / 5 Mbps). I recently had fiber internet (100 Mbps / 100Mbps) from a different company installed and am having significant connection issues.
  1. I'm only getting ~70 down/up on the fiber connection, but I get a consistent ~100+ down/up on the fiber if I direct connect my computer to the fiber modem/ONT. This first item is relatively minor, but not insignificant and perhaps relevant to the second.
  2. My computer (while connected to the router, which is connected to the fiber modem) will lose internet connectivity to the point where I can't even browse web pages. An interesting detail, however, is I can still Remote Desktop to my home computer at these times via the VPN connection established between the office ZyWALL USG 20 and my home Zyxel USG20-VPN ( https://www.smallnetbuilder.com/lanwan/lanwan-reviews/zyxel-usg20-vpn-vpn-firewall-reviewed/ ).
The home Zyxel USG20-VPN (which is the newer version of the USG20) is on a fiber connection with the same provider and gets ~340 download and 140 upload just fine.

I have tried disabling the VPN connection just to rule out if that is contributing to the office connection issues, but it makes no difference.

The only thing that is different between the Comcast setup vs the fiber setup at the office is that the office ZyWALL USG 20 is plugged into the Comcast business router/modem (because they will not let me use my own modem), I think maybe via the DMZ port (or some other method to minimize/avoid double-NATing), whereas the ZyWALL USG 20 is directly connected to the fiber modem/ONT. But in both cases it is functioning as my primary router and firewall.

I know there is more network topology details I can potentially get into, but here is my question: Can there be some sort of hardware limitation (given how old the ZyWALL is) that would result in the above issues? It seems like that could be the case, but I would love to understand more of the "Why/How." I could understand it maybe struggling with the higher throughput (eg, being limited to ~70 down/up), but I don't understand why that then translates into a loss of connectivity on my computer?

I have gone ahead and ordered from Amazon a Zyxel USG20-VPN (same model as home router, but now called USG Flex 50), but I can return it unopened (after it arrives tomorrow) if there is an easier solution with my existing hardware.

Any help or guidance is greatly appreciated! :)
We tend to find issues with hw when the speed increases. Similar issue with an old Asus router that had gig wan but only did about 300mbps. It's possible it's just not capable on the 1st gen to get full speed. As for the PC connection bouncing that could be a myriad of things. Troubleshoot one thing at a time.
Thanks much for the reply! That is a helpful confirmation regarding the speed issue.

The PC connection bouncing is the high priority, though. I can potentially live with the speed limitation, but I can't wrap my mind around why the connection becomes so unreliable just from switching to being plugged into the fiber connection (as opposed to the cable internet).
If the Ethernet cable didn't change then I would look at the adapter settings and see if you had anything set static that might conflict with the ISP settings. If nothing shows up as odd then maybe delete the Ethernet adapter in devices manager and reboot.
Similar threads
Thread starter Title Forum Replies Date
P ZyXEL disconnects from 5G and doesnt reconnect automatically Routers 0

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!