386.1_2 Issue with Echo Multi-Room Music Groups - Guest WiFi

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Techaj

New Around Here
Anyone using multi-room music groups with Amazon Echo devices?
I tried to play music to my EVERYWHERE group earlier today, and none of my groups were functioning properly. I ended up trying all the normal stuff, and I am still unable to create a group, so I thought I would see if anyone else is having an issue. I have all my Echo and IoT devices on Guest Network 1 with unique names for 2.4 and 5Ghz.

Home Network Setup
AT&T 1`GB Fiber -- Bridged Mode
RT-AX88U -- 386.1_2 -- Primary router -- Also running SkyNet
RT-AC86U -- 386.1_2 -- Mesh router
5 Amazon Echo devices are ALL on my Guest Network 5Gz (GuestNetwork_5G)
All my IoT devices are running on my Guest Network either 2.4 or 5GHz (GuestNetwork and GuestNetwork_5G)

Notes:
1. Access Intranet is disabled on the my guest network -- tried turning it on and same results
2. Tried turning Skynet Off
3. Setup AP Isolated is set to NO in the wireless Professional settings
4. Tried turning IGMP Snooping to DISABLED in the wireless Professional settings

Things I have tried
1. Verified all Echo devices are on the same wireless network, including my mobile device
2. Uninstalled and Reinstalled the Alexa app on my Android phone -- Restarted Android phone
3. Powered down all Echo devices and all network equipment and brought up things in order -- AT&T Fiber, Primary Router, Mesh Router, Echo Devices...
4, Verified all echo devices are up to date on firmware
5. Removed all groups from the Alexa app

When I try to create a new group I can see all 5 of my Echo devices in the app
Alexa App -- Devices -- + --- Combine Speakers -- Multi-Room Music -- All 5 devices are listed as ONLINE and connected to my Guest Network 5Ghz (GuestNetwork_5G)
If I select a device to start a group, the rest of the devices than grey out and state Network Error * (GuestNetwork_5G)

I use the multi-room music several times a month and never had an issue until today.
Guest Network issue with 386, settings issue, or something else?

Thanks!
AJ
 

figorr

Regular Contributor
I had this same problem in the past, trying to pair 2 echo studio with 1 echo sub and 1 fire tv stick. When I started selecting one device ... the others suddenly went grey and were shown like they were on another network, but really all of them were under the same network.

I think It was an Alexa app problem and not a Network problem. I can remember I solved by uninstalling the Alexa App from the smartphone, waiting a couple of minutes and reinstalling the app again.

After that I was able to pair my devices under the same group, with the Echo Sub under the 2.4Ghz and the Echo Studios and Fire Tv under the 5Ghz.

If not ... then you can try to reset your echo devices as new and start the setup process for each one. I think you need to push the action button for a while ... 20 or 30 seconds until the echo device tells you that it is going to be reset.
 

ATLga

Senior Member
Anyone using multi-room music groups with Amazon Echo devices?
I tried to play music to my EVERYWHERE group earlier today, and none of my groups were functioning properly. I ended up trying all the normal stuff, and I am still unable to create a group, so I thought I would see if anyone else is having an issue. I have all my Echo and IoT devices on Guest Network 1 with unique names for 2.4 and 5Ghz.

Home Network Setup
AT&T 1`GB Fiber -- Bridged Mode
RT-AX88U -- 386.1_2 -- Primary router -- Also running SkyNet
RT-AC86U -- 386.1_2 -- Mesh router
5 Amazon Echo devices are ALL on my Guest Network 5Gz (GuestNetwork_5G)
All my IoT devices are running on my Guest Network either 2.4 or 5GHz (GuestNetwork and GuestNetwork_5G)

Notes:
1. Access Intranet is disabled on the my guest network -- tried turning it on and same results
2. Tried turning Skynet Off
3. Setup AP Isolated is set to NO in the wireless Professional settings
4. Tried turning IGMP Snooping to DISABLED in the wireless Professional settings

Things I have tried
1. Verified all Echo devices are on the same wireless network, including my mobile device
2. Uninstalled and Reinstalled the Alexa app on my Android phone -- Restarted Android phone
3. Powered down all Echo devices and all network equipment and brought up things in order -- AT&T Fiber, Primary Router, Mesh Router, Echo Devices...
4, Verified all echo devices are up to date on firmware
5. Removed all groups from the Alexa app

When I try to create a new group I can see all 5 of my Echo devices in the app
Alexa App -- Devices -- + --- Combine Speakers -- Multi-Room Music -- All 5 devices are listed as ONLINE and connected to my Guest Network 5Ghz (GuestNetwork_5G)
If I select a device to start a group, the rest of the devices than grey out and state Network Error * (GuestNetwork_5G)

I use the multi-room music several times a month and never had an issue until today.
Guest Network issue with 386, settings issue, or something else?

Thanks!
AJ
A recent update made them virtually impossible to run that way while connected to the guest. Same goes for pairing two together as Stereo. They need to be able to talk to each other and can't do that on a guest network. There is a message as such stating that if you click the ? next to the Network Error message you see. You'll need to move them off guest to use any features where they need to see and talk to each other.

Note: After making the network changes, you may need to "force close" the app on your phone to see the network error refreshed and things wont be greyed out.
 
Last edited:

bennor

Regular Contributor
I've had a number of issues running Amazon Echo devices on the Guest WiFi network. One workaround was to use the YazFi script. For the Echo paired speaker/multi room music option I found I had to disable Client Isolation in the YazFi script to get that Echo feature to work. The issue is, as a previous poster indicated, the Echo devices need to talk to each other on the WiFi network for the multi room option to work properly.

The other reason for using YazFi was due to using Pi-Hole to block ads and other things on the local network. Guest WiFi devices wouldn't access the Pi-Hole unless I disabled Guest Access Intranet option. Kind of defeats the reason to put IoT devices on an isolated Guest WiFi network. The YazFi script solves this by having the ability to set DNS servers on the local LAN for Guest WiFi devices while at the same time preventing other access to the man LAN (depending on both the Guest and YazFi settings).

More on YazFi:
https://www.snbforums.com/threads/yazfi-v4-x.70308/
https://github.com/jackyaz/YazFi
 

Techaj

New Around Here
I appreciate all the feedback!
I was not aware the guest network isolated clients, which is what I thought the 'Set AP Isolated' controlled in the Professional Tab of wireless settings.

I am going to look at a couple options presented this week and see what happens. Just trying to avoid bringing my IoT devices back on my primary network, as I like the separation.
-- Reset echo devices and re-join network
-- Look at YazFi script
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top