AC86U - update from 384.13 to 384.14 beta 3 - hangs

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

princi

Senior Member
Bizarre.

Trying to update from 384.13 release to 384.14 beta 3 and the process stops at:

Please Wait, Applying Settings...

Router is still operating fine - just the web interface is now unresponsive.

Closing the browser and trying to login from another device - unresponsive

Power cycle - same behaviour

I must have missed this in the threads - was the problem identified?
 

Vexira

Part of the Furniture
Ahh I see that's usually the cause for alot of other users, have you tested a factory reset by any chance?
 

kernol

Very Senior Member
I have had zero issues with the same upgrade path on my RT-AC86U - however I am acutely aware of the fact that the AC86U enjoys utilising plenty of its RAM the longer it runs for leaving precious little spare for a firmware update. So my path to any DIRTY firmware upgrade is: -
  1. Use webgui to eject any USB drives attached; [RAM consumption will drop]
  2. Go to Administration Settings > System ... and disable JFFS Custom Scripts and configs;
  3. Reboot the router under pre-upgrade existing firmware;
  4. Wait 5 minutes for this fast router to settle; [RAM consumption usually much lower at this stage - wait for processor activity to settle]
  5. Go to Administration > Firmware Upgrade ... and select the new firmware file to upload;
  6. Wait another 5 minutes after firmware upgrade applied [still no USB and no JFFS enable];
  7. Power off the router [not at power button - just pull the power cord] and wait a minute or so with power button still in ON position [drains the circuits];
  8. Power button OFF - replace power cord - and push power button back ON;
  9. Wait another 5 minutes - login to Webgui - insert USB and then Enable JFFS Custom Scripts and configs;
  10. Wait for router to settle [usually on the AC86 at least 5 minutes];
  11. Reboot from webgui and enjoy the new firmware :).
I believe something has gone awry with your firmware upgrade [could not have fully completed] - so think you will have to do a reset - with the WPS button depressed first then the power button and hold for up to 30 seconds until power LED blinks repeatedly. Follow Asus Rescue Procedures to reload chosen firmware.
 

princi

Senior Member
I don‘t have a problem with doing a full factory reset - I actually think it‘s good practice.

Just a little surprised that it‘s a necessity in this case.

Anyway, thank you everyone for the comments.
 

ozjason

New Around Here
First update in 5+ years of using Merlin to fail for me, however removing the USB drive resolved it.
 

Kingp1n

Very Senior Member
I was having issues updating thru Edge...with Chrome, I was able to update with no issues.
 

rgnldo

Very Senior Member
Bizarre.

Trying to update from 384.13 release to 384.14 beta 3 and the process stops at:

Please Wait, Applying Settings...

Router is still operating fine - just the web interface is now unresponsive.

Closing the browser and trying to login from another device - unresponsive

Power cycle - same behaviour

I must have missed this in the threads - was the problem identified?

Procedure:
- Firefox with cache cleared
- disable JFFS;
- reset to previous FW 384.13;
- Firefox with cache cleared;
- upgrade new FW beta;
- reset FW beta installed;

 

princi

Senior Member

Procedure:
- Firefox with cache cleared
- disable JFFS;
- reset to previous FW 384.13;
- Firefox with cache cleared;
- upgrade new FW beta;
- reset FW beta installed;
Thanks for your input, but it didn‘t work.

Tried a h/w reset with the WPS button - same behaviour after setting up.

Tried the firmware recovery mode wirelessly, but kept getting Invalid IP address. I have had success doing wired recoveries in the past, but not this time.

Guess I have to read-up on going nuclear - otherwise, just leave it stuck on 384.13
 

princi

Senior Member
Does the AC86U still have that GUI mode which you can access by holding the reset button for 30 seconds?
 

rgnldo

Very Senior Member
Thanks for your input, but it didn‘t work.

Tried a h/w reset with the WPS button - same behaviour after setting up.

Tried the firmware recovery mode wirelessly, but kept getting Invalid IP address. I have had success doing wired recoveries in the past, but not this time.

Guess I have to read-up on going nuclear - otherwise, just leave it stuck on 384.13
Strange. Check the sha256sum.sha256. Try to download the FW again.
 

rgnldo

Very Senior Member
Alternative procedure:
- Firefox with cache cleared
- Reset FW;
- disable JFFS;
- intall FW 384.13 stable;
- Firefox with cache cleared;
- upgrade new FW beta 1;
- reset FW beta 1 installed;

- Firefox with cache cleared;
- upgrade new FW beta 2;
- Firefox with cache cleared;
- reset FW beta 2 installed;
- upgrade new FW beta 3;
- reset FW beta 3 installed;

 

HardCat

Regular Contributor
@princi, if you are using a RT-AC86U, after a full reset the IP address to log into will be 192.168.50.1
 

rgnldo

Very Senior Member
Code:
opkg install coreutils-sha256sum
Code:
curl -L -O  https://sourceforge.net/projects/asuswrt-merlin/files/RT-AC86U/Beta/RT-AC86U_384.14_beta
3.zip > /mnt/sda1/RT-AC86U_384.14_beta3.zip && unzip RT-AC86U_384.14_beta3.zip
Code:
sha256sum RT-AC86U_384.14_beta3_cferom_ubi.w
 

L&LD

Part of the Furniture
In my experience, 50.1 is only for the AX88U

I have no problem logging in to the AC86U after a full reset - at 192.168.1.1
Then you did not do a full reset to factory defaults.

You may want to look at the link in my signature below for further details. :)
 

Kingp1n

Very Senior Member
Then you did not do a full reset to factory defaults.

You may want to look at the link in my signature below for further details. :)
L&LD, i haven't done a nuclear reset yet on my RT-AC86U router, however, I have done a full reset from the GUI which does reset my IP address back to 50.1. After setting up my router back up...by this time, normally all my devices have been assigned an automatic IP address. My question is, when I'm trying to restore my dhcps (static IPs) using Xtrenk's guide. Although the dhcp staticip addresses do populate, they never get assigned the static ip's that I want even after rebooting the router. Is there a way to force the static ips to be assigned again?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top