• ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

gday_its_jimmy_jay

New Around Here
Hi SNB friends,

Firstly, thank you for your amazing threads. Now, I have successfully been able to access my LAN remotely via OpenVPN Server, tunneled through a OpenVPN Client.

This is on a ASUS RT-AC86U running the latest version of ASUSMerlinWRT. This is 90% of the way there, for what I'm trying to achieve.

The next step for me is to be able to run my Raspberry Pi 4 through the OpenVPN Client, but still be able to reach it remotely when I use the OpenVPN Server.

Right now, when I run it through the OpenVPN Client, I am able to connect to it when on the LAN, but not when accessing it via the OpenVPN Server.

I've tried installing VPN clients on the Rasperry Pi itself directly and also for specific containers via Docker. But I haven't been able tosolve this problem.

I'm happy to explore any options that are done on the router via AsusMerlinWRT, or on the Raspberry Pi itself.

Has anyone got experience in making this work? The device itself doesn't need to be a Raspberry Pi, as I'm sure there are lessons to be learned from other similar devices.

Thank you!
 

eibgrad

Very Senior Member
Just to be clear, I know next to nothing about RPi or pi-hole. So I'll have to make an assumption this is an alternate DNS server from the one offered by the primary router, and your LAN clients have been configured to use it. Or else DNSMasq on the router has been configured to redirect to it.

In order for OpenVPN clients to use the pi-hole, obviously its IP address must be push'd to those same clients. Assuming that's been done in the OpenVPN server config, it has to be accepting IPs from the VPN's tunnel. Sometimes processes, for reasons of security, are configured by default to *only* allow access by clients on their own local IP network (this is how Windows 10 works). IOW, the RPI might be firewall'd wrt other IP networks. Also, the RPi has to have a route back to the OpenVPN server (or more precisely, the OpenVPN tunnel network). By default, it doesn't (not unless you added one). And if you didn't, then it must have a default gateway that points back to the primary router where the OpenVPN server (and its tunnel) are being hosted.

9 times out of 10, it's either a routing or firewall issue. And since I have a very limited knowledge of how you configured the RPi (did you specify a default gateway??), I can only guess at some of the possibilities.
 

gday_its_jimmy_jay

New Around Here
Thanks Eibgrad!

I've used your guidance to find a solution.

It got me looking into the Pi's VPN client, and I was able to whitelist the VPN's subnet, and now I'm able to connect to my VPN remotely permanently to always have access to my home network, which is super convenient.

Some stability issues, but I'm working through them.. so far, haha.

Greatly appreciated
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top