AImesh rt-ac86u -> rt-ac68u

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Don->

Occasional Visitor
I have recently set up a small AIMesh network. The Master is the RT-AC86U with the remote RT-AC68U being the Mesh node. From Various observations I have seen I have Disabled the "Enable Smart Connect" within WiFI settings on the 86U as the 68U does not support this feature. I have a smart TV Device that when it comes out of standby in the mornings it may or May Not connect to the 2.4Ghx Wifi. It cant use the 5Ghz wifi as it uses that already for another propriety Mesh to "speak" to similar devices about the house. This TV device sits roughly between both routers. Thus Wifi power is similar from each Router.

If it does not connect 1st time I can reset the WiFi on the Device, or disable / enable the 2.4Ghz Wifi. etc However its becoming tedious.

I speculate that the TV device saves the MAC address of the first ASUS routers broadcasting the SSID and will only connect to that specific router till I do something about it.

I don't know the AImesh characteristics that well, and wondered if there was a way to "spoof" the MAC address to be the same on the AIMesh remote nodes as the Master Node (RT-AC86U. The SSID is always the same and propagated through the AIMesh along with the WiFi password and the WiFi Channel.

The reason I believe this device holds onto the MAC address is that If I change out the Router but keep the WiFi settings the same everything rehomes to the new router with the old wifi settings, except this solitary device. Being a static device I do not believe it can rehome like mobile devices.

Any thoughts ?
 

OzarkEdge

Part of the Furniture
I have recently set up a small AIMesh network. The Master is the RT-AC86U with the remote RT-AC68U being the Mesh node. From Various observations I have seen I have Disabled the "Enable Smart Connect" within WiFI settings on the 86U as the 68U does not support this feature. I have a smart TV Device that when it comes out of standby in the mornings it may or May Not connect to the 2.4Ghx Wifi. It cant use the 5Ghz wifi as it uses that already for another propriety Mesh to "speak" to similar devices about the house. This TV device sits roughly between both routers. Thus Wifi power is similar from each Router.

If it does not connect 1st time I can reset the WiFi on the Device, or disable / enable the 2.4Ghz Wifi. etc However its becoming tedious.

I speculate that the TV device saves the hardware MAC address of the first ASUS routers broadcasting the SSID and will only connect to that specific router till I do something about it.

I don't know the AImesh characteristics that well, and wondered if there was a way to "spoof" the MAC address to be the same on the AIMesh remote nodes as the Master Node (RT-AC86U. The SSID is always the same and propagated through the AIMesh along with the WiFi password and the WiFi Channel.

The reason I believe this device holds onto the MAC address is that If I change out the Router but keep the WiFi settings the same everything rehomes to the new router with the old wifi settings, except this solitary device. Being a static device I do not believe it can rehome like mobile devices.

Any thoughts ?
Configure separate SSIDs for each band and connect the TV to only the 2.4 GHz SSID. For example, Don and Don-24, and connect the TV to Don-24. If you upgrade to Smart Connect later, you can use Don for both bands and only have to redefine the 2.4 client connections.

Ideally, wire the TV.

FYI, every client has a unique MAC address that does not change. The router DHCP server assigns an IP address to each client when it connects that can change. You don't need to spoof anything.

OE
 

Don->

Occasional Visitor
Configure separate SSIDs for each band and connect the TV to only the 2.4 GHz SSID. For example, Don and Don-24, and connect the TV to Don-24. If you upgrade to Smart Connect later, you can use Don for both bands and only have to redefine the 2.4 client connections.

Ideally, wire the TV.

FYI, every client has a unique MAC address that does not change. The router DHCP server assigns an IP address to each client when it connects that can change. You don't need to spoof anything.

OE
Evening OE, thanks for coming back to me.

Splitting the SSID's on the 2.4 and 5.x wifi wont work. Both nodes would then broadcast SSID "don" on 2.4 and "don5" on 5.x ghz. In essences nothing has changed as the TV device only connects on 2.4Ghz.

I could hard wire the TV device but I have a downer on cables running through the house and the TPlink ethernet over Power cables is feasible but not really for me.

Each network adapter has a Unique mac address(normally burnt in) split into Vendor portion and 6 other hex characters. In networking it is allowed to "self assign Mac Addresses" on an adapter and Spoofing Mac addresses may be frowned upon but done in special circumstances to get around issues.

so extrapolating this Further it could mean the mesh has a limitation when working with WiFi clients that do not Rehome or hop from one SSID to the Same SSID on a different router. If the 86U wifi Mac address could be spoofed onto the 68U wifi adapter then this " could" spoof the wifi client to hop the SSID without actually making any decisions.

I don't know where to obtain the specifications of the AImesh to understand this specific circumstance from the ASUS design point of view. I don't know if the AIMesh was designed to support this functionality but doesn't (bug). Or if this is Functioning as designed, or indeed if this was ever considered.

Thanks
Don
 

OzarkEdge

Part of the Furniture
I have recently set up a small AIMesh network. The Master is the RT-AC86U with the remote RT-AC68U being the Mesh node. From Various observations I have seen I have Disabled the "Enable Smart Connect" within WiFI settings on the 86U as the 68U does not support this feature. I have a smart TV Device that when it comes out of standby in the mornings it may or May Not connect to the 2.4Ghx Wifi. It cant use the 5Ghz wifi as it uses that already for another propriety Mesh to "speak" to similar devices about the house. This TV device sits roughly between both routers. Thus Wifi power is similar from each Router.

If it does not connect 1st time I can reset the WiFi on the Device, or disable / enable the 2.4Ghz Wifi. etc However its becoming tedious.

I speculate that the TV device saves the MAC address of the first ASUS routers broadcasting the SSID and will only connect to that specific router till I do something about it.

I don't know the AImesh characteristics that well, and wondered if there was a way to "spoof" the MAC address to be the same on the AIMesh remote nodes as the Master Node (RT-AC86U. The SSID is always the same and propagated through the AIMesh along with the WiFi password and the WiFi Channel.

The reason I believe this device holds onto the MAC address is that If I change out the Router but keep the WiFi settings the same everything rehomes to the new router with the old wifi settings, except this solitary device. Being a static device I do not believe it can rehome like mobile devices.

Any thoughts ?
Are you using same SSIDs for each band?

So, when the TV wakes, it's not connecting at all?

OE
 

semigator

Occasional Visitor
Evening OE, thanks for coming back to me.

Splitting the SSID's on the 2.4 and 5.x wifi wont work. Both nodes would then broadcast SSID "don" on 2.4 and "don5" on 5.x ghz. In essences nothing has changed as the TV device only connects on 2.4Ghz.

I could hard wire the TV device but I have a downer on cables running through the house and the TPlink ethernet over Power cables is feasible but not really for me.

Each network adapter has a Unique mac address(normally burnt in) split into Vendor portion and 6 other hex characters. In networking it is allowed to "self assign Mac Addresses" on an adapter and Spoofing Mac addresses may be frowned upon but done in special circumstances to get around issues.

so extrapolating this Further it could mean the mesh has a limitation when working with WiFi clients that do not Rehome or hop from one SSID to the Same SSID on a different router. If the 86U wifi Mac address could be spoofed onto the 68U wifi adapter then this " could" spoof the wifi client to hop the SSID without actually making any decisions.

I don't know where to obtain the specifications of the AImesh to understand this specific circumstance from the ASUS design point of view. I don't know if the AIMesh was designed to support this functionality but doesn't (bug). Or if this is Functioning as designed, or indeed if this was ever considered.

Thanks
Don
Are you trying to get it to only connect to your RT-AC86u primary router on 2.4Ghz? If yes, I use 2.4Ghz a guest network that allows intranet access to accomplish this. I have many IoT things that don't like seeing all the nodes in my AiMesh network, so I throw them on the guest network because it is only on the main router and does not extend to the AiMesh nodes.
 

Don->

Occasional Visitor
Are you trying to get it to only connect to your RT-AC86u primary router on 2.4Ghz? If yes, I use 2.4Ghz a guest network that allows intranet access to accomplish this. I have many IoT things that don't like seeing all the nodes in my AiMesh network, so I throw them on the guest network because it is only on the main router and does not extend to the AiMesh nodes.
HI Semigator,
I may give this a try as a workaround that may become the solution. I do realise that 'Guest Networks' are not propagated into the Mesh.

I am a great fan of KISS "Keep It So Simple". I had hoped that the Mesh would be the simplest form of all.
Regards

Don
 

semigator

Occasional Visitor
HI Semigator,
I may give this a try as a workaround that may become the solution. I do realise that 'Guest Networks' are not propagated into the Mesh.

I am a great fan of KISS "Keep It So Simple". I had hoped that the Mesh would be the simplest form of all.
Regards

Don
I like AiMesh, but it can be a headache. I have all kinds of scenarios I have needed to do stuff like guest network in order to make it work. My guess is sometimes it's the device's wireless NIC and driver... other times it is Asus. In my head, AiMesh is mainly for roaming around my house and transitioning between access points. Apple actually does this really well and I keep all my Apple devices on the Roaming Block List so they decide. For things that aren't going to move, like a TV or Homekit device, I actually want to try to get them to stay on the appropriate access point instead of bouncing. Some of the devices either are too sticky or freak out if they see all the same SSID... I have spent too much time on it :)
 

OzarkEdge

Part of the Furniture
When the TV devices wakes up it May Connect or May Not connect.
Are you using the same SSID for each band?

I would configure a 2.4 SSID and connect the TV to it. If the TV wakes and doesn't reconnect, then I'd update its firmware to make it smarter, or wire it.

OE
 
Last edited:

retuor

Occasional Visitor
I have a smart TV Device that when it comes out of standby in the mornings it may or May Not connect to the 2.4Ghx Wifi. It cant use the 5Ghz wifi as it uses that already for another propriety Mesh to "speak" to similar devices about the house.
Hello Don,

I used to have similar AiMesh setup, except the node is 68R.

Regarding your TV's wifi, does it have 2 wifi adapters? It seems like you have configured it to two different networks: the 5GHz wifi adapter is on one network and the 2.4GHz wifi adapter is on the ASUS network.

I'm just curious because I didn't know there are TV's like that.

But back to your issue, I have had similar problems where some of my devices won't re-connect after the wifi has been purposely shut down for a period of time and then brought back to life. I would need to go to each problematic device and re-configure wifi. The wifi was purposely shut down due to some other wifi issues and I wanted to reset/re-configure the router/AiMesh.

For testing purposes, how about experimenting with connecting to the ASUS 5GHz and see how your TV responds to standby/wakeup?
 

Don->

Occasional Visitor
Hello Don,

I used to have similar AiMesh setup, except the node is 68R.

Regarding your TV's wifi, does it have 2 wifi adapters? It seems like you have configured it to two different networks: the 5GHz wifi adapter is on one network and the 2.4GHz wifi adapter is on the ASUS network.

I'm just curious because I didn't know there are TV's like that.

But back to your issue, I have had similar problems where some of my devices won't re-connect after the wifi has been purposely shut down for a period of time and then brought back to life. I would need to go to each problematic device and re-configure wifi. The wifi was purposely shut down due to some other wifi issues and I wanted to reset/re-configure the router/AiMesh.

For testing purposes, how about experimenting with connecting to the ASUS 5GHz and see how your TV responds to standby/wakeup?
Morning Retuor,
Unfortiunately this is not possible . The TV device only works on 2.4Ghx Wifi band. I have two Routers sharing the same SSID on the same channel in AIMesh mode. The wifi Power is the same at the location of the TV device so there is nothing to assist the wifi client make a decision to which router is "joins.
Thanks for your assistance.
Regards
Don
 

retuor

Occasional Visitor
Morning Retuor,
Unfortiunately this is not possible . The TV device only works on 2.4Ghx Wifi band. I have two Routers sharing the same SSID on the same channel in AIMesh mode. The wifi Power is the same at the location of the TV device so there is nothing to assist the wifi client make a decision to which router is "joins.
Thanks for your assistance.
Regards
Don
Here are some options I thought of:

1. Turn off roaming assistant for 2.4
This prevents your router from switching your client device to another router in the AiMesh network if the wifi signal is beyond a threshold. I'm guessing the TV might have issues switching back and forth. I've learned that sometimes the problem is not the router but the clients.

2. Turn off Airtime Fairness for 2.4
I've just learned to turn this feature off.

3. Then try turning off all the beamforming for 2.4
I've also learned to turn this feature off for experimenting when things don't work.

4. Experiment with turning off AiMesh, essentially turn off your node router, 68U, and see how your TV responds to standby/wakeup.

5. Create a whole new name and password for 2.4 and re-configure your TV.

If possible, I recommend resetting the TV's wifi configuration to factory defaults before trying each option. This is just to clear the TV's memory of the previous wifi.

If none of these options produce meaningful results, then I second OE's recommendation to use wire. Just experiment with a long LAN cable and connect to either router and see how TV responds to standby/wakeup.

Good luck!
 

Don->

Occasional Visitor
Here are some options I thought of:

1. Turn off roaming assistant for 2.4
This prevents your router from switching your client device to another router in the AiMesh network if the wifi signal is beyond a threshold. I'm guessing the TV might have issues switching back and forth. I've learned that sometimes the problem is not the router but the clients.

2. Turn off Airtime Fairness for 2.4
I've just learned to turn this feature off.

3. Then try turning off all the beamforming for 2.4
I've also learned to turn this feature off for experimenting when things don't work.

4. Experiment with turning off AiMesh, essentially turn off your node router, 68U, and see how your TV responds to standby/wakeup.

5. Create a whole new name and password for 2.4 and re-configure your TV.

If possible, I recommend resetting the TV's wifi configuration to factory defaults before trying each option. This is just to clear the TV's memory of the previous wifi.

If none of these options produce meaningful results, then I second OE's recommendation to use wire. Just experiment with a long LAN cable and connect to either router and see how TV responds to standby/wakeup.

Good luck!
Morning Retuor,

Over the last couple of months, before investing another Asus router for a mesh, I have tried all the things you suggest. I cant run the house on just one Wifi Router. Until I invested in the AIMesh I used a Linksys WRT1900ACS with a variety of Firmware acting in a non Mesh way. The best result was native firmware running in Bridge mode but then it did have issues as well(two mac addresses for the same SSID). I had naively thought the Mesh would use a master MAC address for WiFi connections, but alas no.

I have taken the advice of #Simigator and reverted back to the single WiFi for the TV device and my Water Leak detector. I now have to check that the WiFi devices in the Garage can see this Single Wifi Guest Network (xxxxxxxx_Media) as this is where I started many many many weeks ago.

I will keep at it as I now know there is no Magic bullet that I have overlooked, in my time trying to resolve the coverage issue, without introducing new issues.

Must also fix my "Pi-Hole" as that has a corrupt Micro SD card.... so using an ad Blocking Public DNS at the moment.

I thought I had given up a life of communications since I retired but again alas no.

Thanks for your suggestions

Don
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top