What's new

Solved ASUS DSL-AC68U to ASUS EA-AC87 Media Bridge not forwarding traffic after Firmware upgrade

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I have an issue with media bridge no longer working in my home office after a router firmware upgrade. The media bridge has been replaced with some TP power lines, which are ok but work at a slower speed, but I'm really curious to know what is causing the media bridge to not forward the packets correctly. Does anyone have any ideas on why or where to look to help solve this mystery?

Original setup: BT Smart Hub + ASUS EA-AC87 in media bridge mode in home office (~900Mbps wireless connection)
11 May 2022 : BT Smart Hub firmware was upgraded SG4B1000E079

12 May 2022 : Home office has no internet, factory reset the EA-AC87, no joy. Intermittent pings from computer to Router, about 1 in every 8 to 12 would reply. Contacted BT and they kindly fixed my VDSL copper line which I did not know was broken (filled with water after fibre crew dumped the junction box on the floor of the cabinet), no help on the router. Figured it was the BT Hub being incompatible with the ASUS media bridge.

Sometime in June : Purchased a ASUS DSL-AC68U to replace the BT Hub, configured it and the EA-AC87. The VDSL WAN and wifi to the Media bridge is all working correctly and I have my internet back in my home office. Prompted to upgrade the DSL firmware, why not?, upgraded ok and then I lost the internet in the home office again, checked the media bridge - its no longer forwarding packets - intermittent pings same as the BT Smart hub. I did a factory reset on the DSL/EA and re-configured them again but no change. I did not note down what the original firmware of the DSL was before upgrading.

Test Setup
To simplify things I setup a simple network:

[Laptop1] -eth-> [DSL-AC68U] <-- ASUS_5G wifi --> [EA-AC87] <-eth- [laptop2]

ASUS EA-AC87 Operation Mode: Media bridge Firmware Version:
ASUS DSL-AC68U Operation Mode: Router/Access Point Firmware Version:

I logged on to Laptop1, Laptop2 and the EA-AC87. I did not test from the DSL.

Wifi connected between the DSL and EA was strong in all of the tests and I placed them in the same room for the testing.

I found that during the router start up, I would get a consistent 20 pings in a row before the intermittent pings would start and the router HTML page would load.

Thinking it was firmware related I reloaded older firmware until I found one that worked:

ASUS DSL-AC68U Firmware (factory reset after loading new firmware)
2022/09/14 Version Intermittent pings, during router startup pings ok
2022/03/04 Version Intermittent pings, during router startup pings ok
2021/09/30 Version Intermittent pings, during router startup pings ok
2021/05/26 Version Intermittent pings, during router startup pings ok
2021/02/25 Version Pings ok for all

I also tried the Asus Merlin Gnuton DSL firmwares and the newest one that worked was 386.01_2-gnuton1, which I think is based upon GPL 386_41700

I checked the EA-AC87 'brctl showmacs br0' and 'cat /proc/net/arp' and could see the macs of the 2 laptops

Its like the EA-AC87 can connect to both sides ok, just traffic is getting stuck and cannot pass through it. The only change I can see was the firmware on the BT and ASUS routers. From the ASUS support pages the EA-AC87 is not supported anymore, by the looks they gave up updating the firmware a while ago, but I'm still interested from a technical point why this problem is happening.

Any ideas on what it could be or where to look next?
Fixed by updating the EA-AC87 firmware via manual download from ASUS website. The check for firmware update in the admin web page was not finding any new firmware so I had assumed it was at the latest.

The EA-AC87 can now see the higher wifi channels, connected on channel 100 to the DSL-AC68U and passing traffic as a media bridge. Getting ~900Mbps over the wifi now and disconnected the TPlink 1Gbps, which had a throughput of ~ 100Mbps.

When I was using the EA-AC87 as a switch I had an issue where it was handing out IP addresses and setting itself as the gateway, ie no internet, I'm not sure if this was due to the TP =link taking too long to sync up and pass the dhcp request to the DSL-AC68U, but I didn't think the EA-AC87 had dhcp server enabled when in media bridge mode.

Factory default firmware :
Latest Supported firmware :
Latest firmware found :

I updated to and restored the factory defaults.

There are hints that firmware exists but the download no longer is available at http://www.asuswrt.net/firmware/EA-AC87_3.
ref 1 : https://www.snbforums.com/threads/solved-ea-ac87-mu-mimo-fw.32517/
ref 2 : https://www.snbforums.com/threads/quiet-release-of-ea-ac87.24865/page-2#post-268184

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!