What's new

ASUS RT-N66U udpxy IPTV stream to WAN

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Hi Guys,

my ISP provides me IPTV and I can watch it using VLC player, for exampe IPTV stream from my ISP: udp://@
On RT-N66U I enabled Udpxy with port 4000. Now I can watch IPTV also with URL . This URL also works when I connect from remote PC to VPN connection and I easily can watch TV. But... How I can make IPTV stream available from WAN without VPN connection? For example I want to use this URL: http://MY-EXTERNAL-IP:4000/udp/ ?

Dunno if will work but you can try this commands from putty terminal:

# iptables -I INPUT -p tcp --destination-port 4000 -j ACCEPT
# iptables -I INPUT -p udp --destination-port 4000 -j ACCEPT
# iptables -I INPUT -p tcp --destination-port 5000 -j ACCEPT
# iptables -I INPUT -p udp --destination-port 5000 -j ACCEPT

Also you may redirect port 5000 to 4000 or 4000 to 5000 to ip in port forwarding page. See here an example at the bottom page of tutorial.
Dunno if will work but you can try this commands
That's not enough because udpxy is started with some command line keys to define upstream (wan) and downstream (lan) interfaces. After opening necessary ports we must restart udpxy without "-a" key.

aurelijusb, please note, that udpxy have no any authentication mechanisms, so every internet user will able to use udpxy on your router.
I tried to forward UDP/TCP 4000 port to, also started udpxy without -a and also tried to use -a eth0. But still not working from WAN. Thats really strange. Could it be that ASUS unable to open any listening WAN port to itself?
Here is my firewall rules, maybe someone will find where is the issue (now removed all forwards to, because its not working, so no reason to leave it here):

-A INPUT -m state --state INVALID -j DROP
-A INPUT -i lo -m state --state NEW -j ACCEPT
-A INPUT -i br0 -m state --state NEW -j ACCEPT
-A FORWARD -m state --state INVALID -j DROP
-A FORWARD -i br0 -o br0 -j ACCEPT
-A FORWARD -i lo -o lo -j ACCEPT
-A logaccept -m state --state NEW -j LOG --log-prefix "ACCEPT " --log-tcp-sequen
ce --log-tcp-options --log-ip-options
-A logaccept -j ACCEPT
-A logdrop -m state --state NEW -j LOG --log-prefix "DROP" --log-tcp-sequence --
log-tcp-options --log-ip-options
-A logdrop -j DROP
somebody try this:

iptables -A INPUT -p tcp --dport 1234 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 1234 -j ACCEPT

It is reported by user peterp from t-2 forum that it works

for peterp :D
I can confirm that using this

iptables -A INPUT -p tcp --dport 1234 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 1234 -j ACCEPT

in firewall section of scripts on tomatoRAF for wrt54GL iptv will work on wan port.

It is necessary to have static ip or you will have to modify your play list every time ip changes

playlist fow vlc should be something like that:

http://WAN IP/udp/
Looks like working fine now, also I need to run udpxy process with parameters "/usr/sbin/udpxy -m eth0 -p 4000" instead of "/usr/sbin/udpxy -m eth0 -p 4000 -a br0" so it will stream to all interfaces.
Now another question:
after rebooting router all these settings back to default and again I need to connect using telnet and again enter mentioned IPTABLES commands , also kill running udpxy process and run again without "-a" parameter like mentioned above.
Maybe somehow I can add some startup commands? Or maybe somewhere I can modigy iptables file and updxy config?

I see on issue here:
Its working when firewall is Disabled under

When its enabled looks like 4000 port still closed (i added mentioned iptables rules).

I using Merlin firmware now, added mentioned iptables commands to /jffs/scripts/firewall-start

Looks like some default firewall rules blocks my added iptables rules.
Who can help me to bypass this issue? I not do want to Disable firewall on my router because of security reasons.
Last edited:
So AurelijusB, how did you modified the udpxy config? Or someone please help.

I not modified integrated udpxy config, but added my own rules in startup scripts:

iptables -A INPUT -p tcp --dport 4000 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 4000 -j ACCEPT
iptables -I INPUT -p tcp --dport 4000 -j ACCEPT


sleep 10
killall udpxy
/usr/sbin/udpxy -m eth0 -p 4000

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!