Asus XT8 - Is it dead?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tatenda

New Around Here
Hi All,

I'm new here but from googling seemed to be my best hope of an answer.

I took a gamble on a "faulty" XT8 (AX6600) on a well known auction site, with the description that it powered up but wouldn't connect to the app for setup. I assume the original owner made a warranty claim and this was the left over device. I thought it sounded like something that a firmware update might solve, but also went in fully in the knowledge that I might be wasting my money. I'm by no means an expert but thought it was worth a try.

I'm able to boot into the router and enter the initial setup.
If I set up as a router / access point, there is seemingly no WiFi broadcast but LAN/Routing work fine.
If I set up as Repeater / Bridge, it is able to detect the existing WiFi networks i nthe area during setup, but when it goes to reboot after setup, it cannot connect to them.

The only other things I have by way of a clue is this repeated log entry
kernel: MDIO Error: MDIO got failure status on phy 31

I confess to not being expert enough to understand that directly and despite some create googling the only similar reference I can find concerning an asus product is on a chinese forum and if google translate is to be believed resolved itself.

I've tried factory reset (several times), I've tried a few different versions of firmware, flashing through the WebUI and also the firmware recovery tool (in rescue mode)

I'm more curious than expecting that I am actually able to fix it as to my mind the symptoms seem quite strange and am using this as a learning exercise to understand more about what is going on in my router!

Many thanks for reading and in advance for any insights you have.
 

JagoUK

Regular Contributor
I've had one of these where after uploading a corrupt certificate holding the factory reset button didn't work.
I managed to factory reset it a different way but can't remember how. It may have involved holding reset before plugging in or just holding it for a very long time.

lok at screw terminals for signs of tampering, you could have bought a dud. Might even be a fake.
 

leerees

Regular Contributor
Have you tried the WPS button reset, I think that wipes the nvram as well.
 

tatenda

New Around Here
Thanks for your suggestions. I'm pretty sure the router is genuine. I've actually opened it up myself to see if there was anything obvious that I could fix (antennae disconnected) and the warranty seal was in tact.

I've tried the WPS reset, I got a bit excited as it seemed the app was able to find the router. But either via configuring via the app or by web interface it seems unable to do anything WiFi related. Same error in the log. May be time to give it up as a bad job!
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top