1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Double NAT and In-a-dyn problem

Discussion in 'Asuswrt-Merlin' started by Badstraw, Aug 14, 2019 at 5:37 PM.

  1. Badstraw

    Badstraw New Around Here

    Nov 27, 2018
    Hey guys !

    I’ve been trying to find information about double NAT issues without luck, I have an asus AC86U and my ISP doesn’t let me set the modem in bridge mode.

    I haven’t tried the script posted a year ago because I read that I can use DDNS with Method to retrieve WAN IP to “external” in Merlin.

    14 15:59:10 inadyn[3186]: In-a-dyn version 2.5 -- Dynamic DNS update client.
    Aug 14 15:59:11 inadyn[3186]: Update forced for alias myrouter.ddns.net, new IP# 189.Xxxxxxxx
    Aug 14 15:59:12 inadyn[3186]: Updating cache for myrouter.ddns.net
    As you can see it retrieves the real ip but on the main interface of the router I’m still seeing the LAN ip.

    I’m also trying to access to my modem externally with this address:

    But it doesn’t work.

    I would appreciate any help
  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Mar 31, 2014
    That's because that is its IP address.

    By "modem" I assume you really mean "router", i.e the Asus.

    You need to forward port 8443 on your ISP modem/router to the Asus (, or put the Asus in your ISP device's DMZ.
  3. Val D.

    Val D. Senior Member

    Jun 16, 2019
    Do you have access to ISP's router?
    If you do, then just place your ASUS router IP address in DMZ as @ColinTaylor suggests. This is the equivalent of Bridge Mode. Not exactly, but no Double NAT issues either and you can access your ASUS router easily.

    Better disable WAN access and set a VPN server to access your router. It's more secure than WAN access with ports open.
    Vexira likes this.
  4. Badstraw

    Badstraw New Around Here

    Nov 27, 2018
    My mistake, I meant that I'm trying to access the router, not the modem.

    I had to port forward the port from the modem, and now It's working!!

    Thank you.
  5. Badstraw

    Badstraw New Around Here

    Nov 27, 2018

    That's what I did, I'm using ovenvpn and now I can access every device on my network like a local network.

    Thanks for the suggestion man, I appreciate your help.