Forcing devices to use VPN disables SSL (RT-AC5300)

G3ex

New Around Here
Hello,

I'm new to these forums so apologies if this is the wrong section.

I have an ASUS RT-AC5300 with Asuswrt-Merlin (v384.19)

I'm currently using the feature 'Force Internet traffic through tunnel' under 'VPN -> VPN Client -> Additional Settings' because I'd like to force a number of streaming devices on my network to use a VPN.

Although, when I've activated the setting to force internet traffic.. Multiple apps like Netflix complain they can't play content because 'an SSL error has occurred and a secure connection to the server cannot be made'.

If I disable 'Force Internet traffic through tunnel' and force all the devices on my network to use the VPN, then apps like Netflix which didn't work before now work again. So it's definitely something going on with that option.

Does anyone know if this is a bug? Any help is much appreciated.

Many thanks,
 

L&LD

Part of the Furniture
Welcome to the forums @G3ex.

Has this worked previously for you? Did you just buy the router and flash RMerlin firmware on it without doing a full reset to factory defaults afterward?

What VPN are you using? Did you import and configure all the required fields in the VPN section?
 

RMerlin

Asuswrt-Merlin dev
It's more likely to be an issue that Netflix detects VPNs and will refuse to work then, as it's frequently used to bypass geolocks.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top