Release [Fork] Asuswrt-Merlin 374 LTS release 49E4

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

L&LD

Part of the Furniture

newguy1

New Around Here
I'm trying to change from Asus Official [N66U] to this fork, but everytime I try to do it, it just ends up at 192.168.1.1/f2.htm and broken page; from ASUSTeK - CFE miniWeb Server

Am I doing something wrong or is there another way to try this?
 

ColinTaylor

Part of the Furniture
After it says it's uploaded the firmware it usually takes about 45 minutes to actually apply it in my experience. The N66U has very slow nvram chips. So ignore what the web browser says during that time and just wait.
 

newguy1

New Around Here
well my problem is that I can't even tell if its uploaded. after I press the upload button, it just goes to the 192.168.1.1/f2.htm page
Even If i wait, which is what i'm trying now, how do I know its done? Do i reboot after a few hours and load and hope it works?
 

ColinTaylor

Part of the Furniture
Even If i wait, which is what i'm trying now, how do I know its done?
You don't know. There's no indication, you just have to wait and hope. Then reboot (if it doesn't by itself) after what you think is a "suitable" amount of time. Note that this a problem that is peculiar to the N66U. Other models can the flash firmware in a few minutes.

Sometimes I've had to repeat the process after doing a factory reset on the router. I can't say whether this was actually required or just coincidental and it was just a case of repeating it until it worked.
 

dev_null

Senior Member
well my problem is that I can't even tell if its uploaded. after I press the upload button, it just goes to the 192.168.1.1/f2.htm page
Even If i wait, which is what i'm trying now, how do I know its done? Do i reboot after a few hours and load and hope it works?
Suggest you ssh into the router and open top or htop and monitor what's running during the update. To keep ssh open for longer periods, first set the timeout to 0 (zero) in the UI.

IIRC, the first time I flashed the N66U to this firmware it took about 30-35 minutes. Subsequent updates do not take that long.
 

ColinTaylor

Part of the Furniture
Suggest you ssh into the router and open top or htop and monitor what's running during the update. To keep ssh open for longer periods, first set the timeout to 0 (zero) in the UI.

IIRC, the first time I flashed the N66U to this firmware it took about 30-35 minutes. Subsequent updates do not take that long.
You can't SSH into the router when you're flashing the firmware from recovery mode.
 

newguy1

New Around Here
You can't SSH into the router when you're flashing the firmware from recovery mode.
I was about to ask is there any other way that this can be done from this device [N66U]

I can't get the asus recovery software to detect the router from that application. but maybe I'm doing it wrong.

If i can't SSH into the router for the flash, can i SSH and somehow better prepare the router for the change, or are there logs I can review after it fails to get a sense of what is happening?

Am I using the wrong .trx file? is there like an initial file I need to flash over or is "RT-N66U_374.43_49E4j9527.trx" the right file to use?

Wait wait.....I think I got it ..disconnected wifi (with internet) from the computer and only connected lan to router.

It's not a blank page anymore it says upload successful.

So.....lesson is when doing this upgrade/flash...don't try to also watch YouTube with the same computer.
 
Last edited:

dev_null

Senior Member
well my problem is that I can't even tell if its uploaded. after I press the upload button, it just goes to the 192.168.1.1/f2.htm page
Even If i wait, which is what i'm trying now, how do I know its done? Do i reboot after a few hours and load and hope it works?
You can't SSH into the router when you're flashing the firmware from recovery mode.
I replied to @newguy1's mention of the 192.168.1.1/f2.htm page, which would imply he's flashing from the UI... But you are accurate if he was flashing from the CFE loader, which my version of the N66U doesn't have (or I've never been able to trigger).

@newguy1: monitoring via ssh will work if you're flashing from the UI/firmware update page. I'd suggest connecting to ssh first, then flashing and monitoring. At some point it should reboot, which would terminate the ssh connection.

And when possible, flash with a wired connection (no hiccups) and, as you figured out, don't be running other apps at the same time.
 

ColinTaylor

Part of the Furniture
@john9527 I notice that the download directories haven't contained the @UpgradeMatrix.txt document for quite some time. Is that intentional?
 

john9527

Part of the Furniture
Development version posted 49D6
https://1drv.ms/f/s!Ainhp1nBLzMJiF2l3WjM46lSmxrH

For all supported routers...
some miscellaneous updates including a new versions of NANO and CURL, updated OUI db, and some AVAHI improvements.

For the AC68U...
Includes an integration of the wireless driver with the FragAttack fixes. Now, my last attempt at a new driver broke non-router modes (AP, Media Bridge, Repeater), so I tried something a bit different this time. I won't have the opportunity to check those alternate modes myself for a few days, but it's available if someone else would like to try it out.

An observation while running in router mode....some of my 2.4GHz devices initially 'balked' at the new wireless driver....would connect and then disconnect. After about 5min they settled down and stayed connected. Haven't had any problems since.

For now, please post any feedback on the development version to this thread. Thanks.
 
Last edited:

followmsi

Regular Contributor
Tested Development version 49D6 on RT-AC68P in media bridge mode.
No problems this time .. now the device connects to primary RT-AC68U in router mode. (still running 49E4)
Will update primary router to 49D6 in the next days and check again.

Thanks for all your work !
 

MysticGold04

Regular Contributor
I flashed this to one of my RT-AC68u’s and am testing repeater mode.. so far it’s working just fine!!

I’ll try the other modes as well if needed!!
Thank you @john9527
 

genestar

New Around Here
I installed this fork on my N66 two week ago and so far so good, but there is one strange thing in the wifi schedule: I've set it to switch on at 6.30am and off at 11.30pm, but sometimes when I wake up at 7.00am I found the wifi switched off and I have to manually turn on in the config page. Has it happened to others?...
 

Jerom7

Occasional Visitor
I guess it could be linked to daylight saving time, 1 hour offset that was witnessed with other beta firmware 386.xx ...

Did you try 5.30am and check it's on as you would like?

I can also test on my N66U (Brussels EU GMT).
Cheers,
 

john9527

Part of the Furniture
but sometimes when I wake up at 7.00am I found the wifi switched off and I have to manually turn on
I can't remember ever having touched the wireless schedule code. You said 'sometimes' it doesn't work....so there are times it does?
Anything in the system log....I'd expect an entry for start_wireless at the start time.

Also, as far as I know, DST ishould be working on my fork (but double check what it thinks are the default start/stop times)..
 

genestar

New Around Here
I can't remember ever having touched the wireless schedule code. You said 'sometimes' it doesn't work....so there are times it does?
Anything in the system log....I'd expect an entry for start_wireless at the start time.

Also, as far as I know, DST ishould be working on my fork (but double check what it thinks are the default start/stop times)..

There's nothing in log: no "start wireless", no "stop wireless"; I find two "restart_wireless" when I manually restart. I will test the schedule with different hours.
 

ColinTaylor

Part of the Furniture
All working fine here since Monday. Just a simple "router mode" setup. No WiFi or other oddities.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top